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INTRODUCTION
Welcome to the Mastercam Basics Tutorial. This tutorial helps you explore Mastercam’s interface and learn basic con-
cepts of the software. This tutorial includes the following:

l A broad look at the Mastercam interface, including the ribbon interface, Quick Access Toolbar (QAT), Selec-
tion Bar, Quick Masks, Status Bar, andManagers.

l An introduction to Mastercam’s Filemenu, also known as the Backstage, where youmanage and print files,
alter SystemConfiguration, customize the interface usingOptions, and access help, tutorials, and other
MastercamCommunity resources.

l An overview of Mastercam’s graphics window, using viewing options and introducing levels and planes.

Tutorial Goals

l Gain an understanding of basicMastercam functions.

l Set up a configuration file and customize Mastercam’s interface for your working style.

l Manipulate Mastercam’s graphics window, levels, and planes to view your part.

WARNING: Screen colors in the tutorial pictures were modified to enhance image quality; they may not
match your Mastercam settings or the tutorial results. These color differences do not affect the lesson or
your results.

Estimated time to complete this tutorial: 5 hours

General Tutorial Requirements
All Mastercam2019 tutorials have the following general requirements:

l Youmust be comfortable using the Windows® operation system.

l The tutorials cannot be used withMastercamDemo/Home Learning Edition. The Demo/HLE file format
(emcam) is different fromMastercam (mcam), and basicMastercam functions, such as file conversions and post-
ing, are unavailable.

l Each lesson in the tutorial builds on the mastery of the preceding lesson's skills. We recommend that you com-
plete them in order.

l Additional filesmay accompany a tutorial. Unless the tutorial provides specific instructions on where to place
these files, store them in a folder that can be access from the Mastercam2019 workstation, either with the
tutorial or in any location that you prefer.

l Youwill need an internet connection to view videos that are referenced in the tutorials. All videos can be
found on our YouTube channel:
www.youtube.com/user/MastercamTechDocs

l All Mastercam tutorials require you to configure Mastercam to work in a default Metric or Inch configuration.
The tutorial provides instructions for loading the appropriate configuration file.

Mastercam Basics Tutorial—Introduction

http://www.youtube.com/user/MastercamTechDocs
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CHAPTER 1
MASTERCAM INTERFACE OVERVIEW

Mastercam’s ribbon interface is based on standardWindows design guidelines. The ribbon comprises familiar con-
trols, including aQuick Access Toolbar (QAT), tabs, contextual tab groups, galleries, buttons, and the Backstage. It
also features special on-screen controls, andmovable, dockable Managers.

This section briefly touches on the elements that make up the Mastercam interface to give you a better under-
standing of how to use these elements to create andmachine your parts.

Goals

l Explore Mastercam's Interface.

l Customize the Quick Access Toolbar.

l Explore the ribbon interface.

l Configure systemattributes.

l Understand Selection Bar, AutoCursor, and Fast Point.

l Use Quick Masks.

l Explore the Status Bar.

Exploring Mastercam’s Interface
Start Mastercamby either:

l Double-clickingMastercam’s desktop icon.

Or

l LaunchingMastercam from the Windows Start menu.

Take a fewmoments to explore Mastercam’s interface.

The following image indicates the elements that make up the Mastercam interface. The corresponding sections
provide brief descriptions of each element and its use.
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1. Quick Access Toolbar (QAT): A customizable set of commonly used functions that are always available in the
interface. The QAT can be located above or below the ribbon.

2. Tab: Groupings of related controls. Tabs are organized in a simple-to-complex workflow from left to right.

3. Tab Group: A region of the tab that contains a set of related controls.

4. Contextual Tab: A tab that displays when youmake a specific selection inMastercam. A contextual tab
presents relevant controls and commands to your current activity.

5. Tooltip: A small windowwith descriptive text that displays when you hover over a command or control.

6. Selection Bar: A toolbar that combines AutoCursor controls and general selection tools used to select entit-
ies in the graphics window. There are two selectionmodes, Standard Selection and Solid Selection, which are
activated based on the function you are using. AutoCursor controls allow you to detect and snap to locations
as youmove the cursor over geometry in the graphics window. AutoCursor becomes active whenever
Mastercamprompts you to select a position in the graphics window.

10
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7. Quick Masks: A group of controls that helps you to select all entities of a certain type, or to select
only entities of certain type. Most Quick Mask controls are divided in half. Clicking the left or right side
of the control toggles between selectionmodes. When aQuick Mask control is selected it highlights to
indicate the selectionmask is on. You can toggle multiple Quick Masks at a time.

8. Status Bar: A bar across the bottomof the workspace that shows the coordinate position of the
cursor and provides quick access to modify the Cplane, Tplane, WCS, and Z Depth of geometry and
toolpaths in the graphics window. The right side of the Status Bar has wireframe, shading, and trans-
lucency controls that change the appearance of your part.

9. Dynamic Gnomon: The on-screen gnomon allows you tomanipulate geometry and planes inter-
actively. The gnomon comprises three axes connected at the origin, with selection points that let you
choose different types of transformations.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



10. Managers: Managers include controls for toolpaths, solids, planes, levels, recent functions, and Art. The Man-
agers can be stacked, docked, floating, or hidden.

l Toolpaths Manager: Lists the toolpath groups andmachine types for the current file. Use the
ToolpathsManager to generate, sort, edit, regenerate, and post operations.

l Solids Manager: Lists each solid in the current file along with its operation history and associated
toolpaths. Use the SolidsManager to edit solids and their operations.

12
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l Planes Manager: Shows the planes in the current file. Use the PlanesManager to display, create, edit,
select, andmanage planes and work offsets.

l Levels Manager: Shows the levels in the current file. Use the LevelsManager to create, select, hide or
show levels, and set the active level.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



l The Recent Functions Manager: Provides quick access to recently used functions.

l Art Manager: Manages the elements of the current Art model. (Only available if MastercamArt is
installed.)

11. Graphics window: The workspace in which you view, create, andmodify your parts. The graphics window
also displays information about the current measurement system (inches or millimeters), and the coordinate
axes for the current view or plane.

14
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Common Interface Controls
The following table shows common controls used in the Mastercam interface. The iconsmay vary slightly depending
on their location inMastercam.

OK and Create New Cancel

OK/Save Help

Apply About Mastercam

Exercise 1: Customizing the Quick Access Toolbar
The Quick Access Toolbar (QAT) is a collection of frequently used functions. The QAT is always available and can be dis-
played above or below the ribbon. You can add or remove functions from the QAT.

In this exercise youmove and customize the QAT.

1. Click the QAT drop-down, and select Show Below the Ribbon.

The QAT displays between the ribbon and the managers.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



2. Click the QAT drop-down again, and selectMore Commands.

The Options dialog box opens.

3. On the Quick Access Toolbar page, select View from the Choose commands from drop-down.

4. Select Fit in the Commands list, and then click Add. The command appears at or below the selected command
in the right-hand pane.

Note that to make items easier to find, the Commands list is in alphabetical order.

16
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5. ClickOK, and the Fit command shows in the QAT.

6. Alternatively, you can add any command in the ribbon to the QAT by right-clicking the command in the ribbon
and selecting Add to Quick Access Toolbar.

7. Return the QAT to its placement above the ribbon.

Exercise 2: Exploring the Ribbon Interface
The ribbon interface comprisesmultiple tabs that group together related functions and controls. Tabs are organ-
ized in a simple-to-complex workflow from left to right. Some tabs are contextual and only display when needed in
the workflow. For instance, youmust select amachine before the contextual toolpath tab displays on the ribbon.

Click each tab to open it, or left click the ribbon and then use the scroll wheel on your mouse to move through the
tabs.

In this exercise youmanipulate the ribbon tabs.

1. Right-click the ribbon, and selectMinimize the Ribbon.

View the maximized workspace.

2. Click any tab to display it. Click in the graphics window to hide the tab again.

3. Right-click the ribbon and deselectMinimize the Ribbon to show the tabs again.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



4. Click theMachine tab.

5. ChooseMill, Default to select your machine.

Note: Available machine types are based on your license andmay vary fromwhat is shown in this tutorial. If
Mill is unavailable, select the default machine for amachine type licensed to you.

6. Mill's Toolpaths contextual tab displays.

7. Click the Expand gallery arrow in the 3D gallery. The related toolpaths display.

8. Click theMachine tab again and select Router, Default. Explore Router's Toolpaths contextual tab. If
Router is not available, select a different machine type that is licensed to you.

9. Continue to select different machines and view the related toolpaths tabs.

18
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Exercise 3: Customizing the Ribbon
You can create a new ribbon tab and customize it with functions of your choice. In this exercise, you create a new
tab, add several functions, and change the tab’s position on the ribbon.

1. Right-click the ribbon, and select Customize the Ribbon.

The Options dialog box opens.

2. Select the View tab in the Customize the Ribbon list, as shown in the following illustration.

3. ClickNew Tab. The New Tab (Custom) andNew Group (Custom) appear in theMain Tabs list.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



4. SelectNew Tab (Custom) and then click Rename. Alternatively, you can right-clickNew Tab (Custom) and
select Rename from the context menu.

5. EnterMy Tab for the Display Name and clickOK.

6. SelectNew Group (Custom) in the list of tabs and click Rename.

7. EnterMy Group for the Display Name and clickOK.

20
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8. Select Pan from the Commands Not in the Ribbon list, and then click Add.

The command is added toMy Group (Custom).

9. Select Zoom Target from the Commands Not in the Ribbon list, and then click Add.

The command is added toMy Group (Custom).

Mastercam Basics Tutorial—1: Mastercam Interface Overview



10. SelectMy Tab (Custom), and use the up arrowbutton to position the tab below the Home tab.

11. ClickOK to close the Options dialog box.

12. ChooseMy Tab to view your customized tab with the Pan and Zoom Target commands.

13. On your own, return to the Options dialog box to addmore commands to your tab, or rearrange the order
of the ribbon tabs.

22
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Exercise 4: Setting System Attributes for the Current File
Systemattributes control point and line styles, as well as colors associated with types of entities you create inMaster-
cam. You can change the attributes of selected entities in the graphics windowusing the controls on the Home tab
or from the right-click mini-toolbar (shown below).

When nothing is selected in the graphics window, you can also set systemattributes for the current file using these
controls. Alternatively, set systemattributes that persist between sessions using the Color and CAD Settings pages
of the System Configuration dialog box.

In this exercise, you use the attributes controls located on the mini-toolbar, which is accessed by right-clicking in the
graphics window.

1. Right-click the graphics window to open the mini-toolbar and context menu.

2. Click the last button (shown in the previous illustration), to pop off the mini-toolbar. You can resize and pos-
ition the mini-toolbar anywhere in the graphics window.

3. With nothing selected in the graphics window, click the Line Style drop-down, and choose the style shown
below.

Newgeometry you create will use the chosen line style.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



4. Select the Line Width shown below.

Newgeometry you create will use the chosen line width.

5. Click theWireframe Color drop-down, and select green as shown below.

6. On theWireframe tab, choose Rectangle.

The Rectangle function panel opens.

7. Click in the graphics window and draw two rectangles of any size. (Follow the prompts shown in the graphics
window.)

24
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8. ClickOK to close the Rectangle function panel.

Mastercam creates the rectangles using the line style, width, and color you previously selected in this pro-
cedure.

Your rectanglesmay vary from the examples shown below.

9. Hold down your left mouse button and drag to draw awindow around one rectangle in the graphics window.
Mastercam selects the rectangle, as shown in the second image below.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



10. Click theWireframe Color drop-down and select purple.

Only the rectangle you selected changes to purple as shown in the following illustration.

11. Notice that the default wireframe color has not changed on the mini-toolbar. Any newwireframe geometry
you create still uses the default color, green.

12. Click the last button on the mini-toolbar to close it.

13. With nothing selected in the graphics window, return the Line Style and Line Width to the options shown
below.

26
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14. Return theWireframe Color to standard blue shown below.

15. Click File, Save. Name your file ATTRIBUTES.mcam, and save it in the same location as the other tutorial files.

To set default systemattributes that persist from session to session, use the System Configuration dialog box and
save the settings to the configuration file. See "Working with Configuration Files" on page 51 for more information.

Exercise 5: Understanding the Selection Bar and AutoCursor
The Selection Bar combines general selection tools used to select entities in the graphics window and AutoCursor
controls. The Selection Bar is located across the top of the graphics window. It has twomodes, Standard Selection
and Solid Selection, which are activated based on the function you are using.

AutoCursor controls allow you to detect and snap to points as youmove the cursor over geometry in the graphics
window. AutoCursor becomes active whenever Mastercamprompts you to select a position in the graphics window.

In this exercise, you locate points and lines using AutoCursor and Fast Point fields.

1. If necessary open the file, ATTRIBUTES, that you saved from the previous lesson.

Your file may look slightly different than the one below.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



2. Select Line Endpoints on theWireframe tab.

The Line Endpoints function panel opens, andMastercamprompts you to specify the first endpoint.

3. Click the AutoCursor drop-down and selectMidpoint.

4. Click anywhere on the top line of one of your rectangles and drag up to draw a line.

Mastercamuses the midpoint of the entity that you selected as the first endpoint.

28
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5. Click to set the second endpoint.

6. Choose OK in the Line Endpoints function panel.

7. Select Circle Center Point on theWireframe tab.

The Circle Center Point function panel opens, andMastercamprompts you to enter the center point.

8. As shown in the following image, select AutoCursor Fast Point on the Selection Bar (or press the spacebar
on your keyboard), to display the Fast Point field. You can enter numbers, formulas, or X,Y,Z coordinates.
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9. Type 0,0,0 to enter the coordinate location of the circle’s center point, and then press [Enter].

10. Drag and click to set the radius of the circle. The center point of the circle is at 0,0,0.

11. Choose OK in the Circle Center Point function panel.

12. If the entities are outside of the graphics window, right-click and choose Fit.

13. Save your file.

30
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Exercise 6: Using Quick Masks
Mastercam’sQuick Masks allow you to select all entities of a specific type, or to select only entities of specific type.
Most controls are divided in half. Clicking the left or right side of the control toggles between all/only selection
modes. You can select multiple Quick Masks.

Hover over each control to view the tooltip describing its function.

In this exercise, you select entities using severalQuick Mask functions.

1. If necessary click File, Open, and open ATTRIBUTES, which you saved in the previous lesson.

2. Before beginning this exercise, click Clear all masking.

3. Click Select all line entities.

Mastercam selects the rectangles and line that you drew in the previous exercise. The circle is not selected
because it is an arc.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



4. Click Clear selection.

5. Choose Select only arc entities.

6. Click and drag to window-select all entities in the workspace.

Mastercam selects only the circle, as shown in the following illustration.

32
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7. Click Clear selection.

8. Choose Select all entities by color. The Select All dialog box opens.

The Quick Masks, Select only arc entities, and Select only wireframe entities remain selected from the
previous steps and affect the outcome.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



9. Select the blue checkbox, and then clickOK.

Mastercam selects only the circle because it is the only blue arc entity. The blue line is not selected as shown in
the following illustration.

10. Select Clear all masking before proceeding with the next lesson.

34
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Exercise 7: Exploring the Status Bar
The Status Bar across the bottomof the workspace gives a visual indication of the position of the cursor on the
workspace (X,Y,Z). It also provides quick access to the 2D/3D switch and lets youmodify the Cplane, Tplane, WCS,
and Z Depth of geometry and toolpaths in the graphics window. The right side of the Status Bar contains wire-
frame, shading, and translucency controls.

In this lesson, you use the wireframe, shading, and translucency controls to change the appearance of a part. See
Help for information on other Status Bar features.

1. Open BRACE, which was provided with the tutorial. Choose Don’t Savewhen prompted to save your file from
the previous lesson. If you see amessage for switching units from inch tometric, clickOK to allow the
change.

The part displays as a solid.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



2. ChooseWireframe on the Status Bar.

3. Choose No Hidden on the Status Bar.

36
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The part displays only the wireframe that is visible in the current view.

4. Choose Outline Shaded and Translucency on the Status Bar.

The part displays as a translucent solid.
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5. Continue to experiment with the appearance controls.

Note: You can also alter how a part displays using the Appearance controls located on the View tab.

6. Click File, New.

You have now completed Chapter 1 of the Mastercam Basics tutorial. In the next chapter, you learnmore about the
Mastercammanagers.

38
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CHAPTER 2
WORKING WITH THE MANAGERS

Mastercamhas severalmovable, dockable managers that provide flexible access to frequently used functions includ-
ing:

l Toolpaths

l Solids

l Planes

l Levels

l Recent Functions

You can toggle the display of the managers, as well asmove one or more managers to a new location. Dock aman-
ager to a fixed location on the interface, float it anywhere on the workspace, or evenmove it to another monitor.
Mastercam remembers the settings even after you close the application.

In this exercise, you use different methods to move, hide, display, and customize amanager.

Goals

l Dock, undock, andmove amanager.

l Hide and display amanager.

l Customize amanager.

l Explore the Recent FunctionsManager.

Exercise 1: Moving and Docking Managers
In this exercise, youmove and dock one or more managers.

1. Click the title bar of the topmanager, and drag the stack of managers into the graphics window. Drop the
managers onto the blue docking icon on the right side of the interface.

All of the managers are nowdocked in the new location.
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2. Click the Planes tab, and drag and drop it anywhere on the workspace (except on a docking icon).

3. Resize the PlanesManager by clicking and dragging any of its edges.

4. Double-click the PlanesManager’s title bar to redock it on top of the stack of managers.

40
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5. Click the title bar of the stack of managers, and drag it to the left side of the graphics window, where it was
docked at the beginning of this exercise.

Note: If you work with twomonitors, position the managers onto the monitor that is not runningMastercam
to free the entire graphics window for drawing.

Exercise 2: Hiding and Displaying a Manager
In this exercise, you hide and display the ToolpathsManager.

1. Click the Toolpaths tab to bring ToolpathsManager to the front.

2. Hide ToolpathsManager by clicking the Close button in its upper right corner.

3. Re-display ToolpathsManager by choosing Toolpaths in theManagers group on the View tab.

Note: You can use the keyboard shortcut [Alt+O] to toggle the display of ToolpathsManager.
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4. Hide ToolpathsManager by clicking the Auto Hide button in its upper right corner.

ToolpathsManager collapses against the left side of the graphics window. If you have other managers docked
together, they also collapse against the side of the graphics window.

5. Hover over the Toolpaths tab to temporarily display ToolpathsManager.

6. Click Auto Hide again to redock ToolpathsManager.

42
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Exercise 3: Customizing a Manager Display
In this exercise, you learn to customize the background color of ToolpathsManager. Some managers have different
options that are not shown in this exercise.

1. Select Background color from the Options drop-downmenu in the upper-right corner of ToolpathsMan-
ager.

The Color dialog box opens.

2. Select the color shown below.

3. ClickOK.

The background of ToolpathsManager is the chosen color.
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Note: You set the color for lines, as well as font attributes, using the Options drop-downmenu.

4. Select Options, Restore default attributes to return the background color to its default setting for the
remainder of this tutorial.

Exercise 4: Exploring the Recent Functions Manager
Recently used functions are recorded in Recent FunctionsManager. You can access one of these functions by select-
ing it in the list.

In this lesson, you build a recent functions list, resize and dock the Recent FunctionsManager, and then access a pre-
viously used function.

1. On theWireframe tab, click Rectangle.

The Rectangle function panel opens.

2. Follow the on-screen prompts to draw a rectangle of any size in the graphics window. ClickOK when done.

3. Click the Recent Functions tab to bring it to the front.

Note that Create rectangle has been added to the top of the list.

44
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4. On theWireframe tab, click Line Endponts.

5. Follow the prompts and draw a line of any size in the graphics window. ClickOK when done.

Note that Create Line Endpoint has been added to the list.

6. Click the Recent Functions tab and drag it onto the graphics window.

7. Resize the Recent FunctionsManager until only the icons show. This keeps the recently used functions on
screen while minimizing the space required.
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8. Click the title bar of the Recent FunctionsManager, and drag it to any convenient location on the screen, or
dock it on the right side of the graphics window, as shown in the illustration.

9. Click the Create rectangle icon to quickly access that previously used function.

Note that you can press the spacebar to open the last function you used.

10. Follow the prompts to create another rectangle in the graphics window, and then clickOK to close the Rect-
angle function panel.

11. Click and drag the Recent FunctionsManager to the left side of the interface and dock it with the other man-
agers.

46
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You have now completed Chapter 2 of the Mastercam Basics tutorial. In the next chapter, you learnmore about the
MastercamBackstage.

Mastercam Basics Tutorial—2: Working with the Managers
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CHAPTER 3
MASTERCAM’S BACKSTAGE OVERVIEW

The File menu inMastercam is also known as the Backstage. The Backstage is the areawhere you open, save, con-
vert, manage, or print files. You also access the File menu to open System Configuration and set default system
parameters, or openOptions to modify the user interface. In addition, the File menu provides access to Help,
tutorials, software updates, and connects you with the Mastercam community.

This section provides a brief overview of the Backstage and some of its functions.

Goals

l Open and review the Backstage pages.

EXPLORING MASTERCAM'S BACKSTAGE
Click File to open the Backstage view. The image below shows the Info page of the Backstage with links on the left
side to other pages and functions.

The following section provides brief descriptions of some of the functions and pages located in the Backstage. Click
each page to explore the Backstage.

l Info: Presents information and properties of the current Mastercam file. The Info page gives you access to
functions that take action on the currently open file including, Project Manager, Change Recognition, Track
Changes, AutoSave, and Repair File.

l New: Opens a new file.
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l Open: Accesses the Open page where you can select a recent document or browse for a file to open. You
can pin frequently used files or folders to the Recent Documents and Recent Folders sections.

l Open in Editor: Opens a file using a file editor of your choice.

l Merge: Imports andmerges entities froman existing part file into the current file.

l Save/Save As: Saves the current part file or saves the file with a newname. You can pin frequently used
folders to the Recent Folders section of the Save As page.

l Save Some: Saves only entities that you select in the graphics window.

l Zip2Go: Creates a compressed .ZIP or .Z2G file of the current file that includes your Mastercam con-
figuration, machine definition, post files, tool andmaterial libraries and other necessary files. A Zip2Go file is
helpful when sharing file information with other users or Technical Support.

l Convert: Provides access to Import and Export functions, as well as the MigrationWizard so that you can
update older Mastercam files to the latest version.

l Print: Previews, configures, and prints the current Mastercam file.

l Help: Presents information about Mastercamand licensing. Includes links to the What’s New and ReadMe doc-
uments, tutorials, and the Help system. Visit this page to check for software updates. Some functions require
an active Internet connection.

l Community: Links your account to Mastercam.com, MastercamUniversity, the MastercamCommunity App,
Mastercam Forums, MastercamKnowledge Base, the customer feedback program, and satisfaction surveys.

l Configuration: Opens the System Configuration dialog box where you set systemdefaults for Mastercam.

l Options: Opens the Options dialog box where you customize the Mastercam interface.

You have now completed Chapter 3 of the Mastercam Basics tutorial. In the next chapter, you learnmore about the
Configuration files.
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CHAPTER 4
WORKING WITH CONFIGURATION FILES

The System Configuration dialog box defines andmanages the configuration files that store Mastercam’s settings.
You can change your system configuration or create a new configuration at any time. It is easy to switch fromone
environment to another because each configuration is saved to a separate file.

In this lesson, you change options in the System Configuration dialog box to see the different kinds of settings
that are stored within one configuration file.

Goals

l Create a configuration file.

l Change system colors and CAD styles.

l Modify the size and opacity of on-screen controls.

l Set up AutoSave and Backup.

Exercise 1: Creating a Configuration File
In this exercise, you create a configuration file (.config).

1. Select File, Configuration to open the System Configuration dialog box.

2. If necessary, selectmcamxm.config <Metric> from the Current drop-down to enable the Metric con-
figuration.
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3. Since there is currently no geometry, clickOK when the following warning appears.

4. Click the Save As button in the lower left corner.

The Save As dialog box displays.

5. Enter Tutorialconfig for the File name.

6. Click Save.

Mastercam creates a new .config file. You can create multiple .config files using the same method.

In the following exercises, you save system settings to this configuration file.

Exercise 2: Changing System Colors
In this exercise, you change some default colors to customize Mastercam’s interface and geometry colors.

1. In the System Configuration dialog box, select the Colors page from the list.
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2. SelectWireframe geometry from the list.

You can see thatWireframe geometry is currently assigned to color 1.

3. Type 163 for the Color value, and press [Enter].

Wireframe geometry you create nowuses this color.

4. Select Background (gradient start) from the list.

Color 111 is the current assignment.

5. Type 15 for the Color value, and press [Enter].

The start of the gradient background is nowwhite.

6. SelectNone (Use Graphics background color) from the Gradient background direction drop-down.

This uses only the Background (gradient start), instead of creating a gradient background.
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7. Click Apply to save the settings on this page.

8. Choose Yes to save all current settings to the Tutorialconfig.config file.

Note: You can also change colors for Wireframe, Solids, and Surfaces of the current file by using the controls loc-
ated in the Attributes group of the Home tab. See Setting SystemAttributes for the Current File .

These are just some of the color changes that you canmake to customize your Mastercam interface.

Exercise 3: Changing CAD Settings
In this exercise, youmake changes to the CAD Settings page.

1. Select the CAD page from the list.

You will use the CAD page to specify design defaults, such as default line and spline attributes.

2. In the Default attributes section, select the Line style shown in the illustration below.

Wireframe geometry you create will nowuse this line style.
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3. Select the Line width shown in the illustration below.

Wireframe geometry you create will nowuse the selected line width.

4. ClickOK in the System Configuration dialog box.

5. Click Yes to save all current settings to the Tutorialconfig.config file.

Choosing Yes saves your changes such that they are in effect every time you openMastercam. If you choose
No, the changes are in effect only until you close Mastercam.

6. Choose Rectangle on theWireframe tab.

The Rectangle function panel opens.

7. Follow the prompts to create a rectangle, and then clickOK in the Rectangle function panel.

The line style and width of the geometry matches the selections in the CAD page of System Configuration,
as well as the geometry color set in the Colors page.
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Exercise 4: Changing the Size and Opacity of On-screen Controls
In this exercise, you set the size of the on-screen gnomons and text and change the opacity of the Selection Bar
andQuick Mask buttons.

1. Click File, Configuration to open the System Configuration dialog box.

2. Select the Screen page.

3. In the Graphics window overlays section, type 1.5 for Scale display gnomons and text and press [Enter].
The size of the elements is immediately changed in the graphics window.

4. The slider control for Selection controls opacity adjusts the opacity of the Selection Bar andQuick Masks.
The setting only affects the static display of the on-screen controls. The Selection Bar andQuick Mask con-
trols become opaque when you hover over them. Move the slider to the left to increase transparency and to
the right to increase opacity. Watch as the opacity changeswith the slider movement, and choose a opacity
setting you like.

5. Click Apply to save the settings on this page.

6. Select Yes to save the settings to the configuration file.

Exercise 5: Setting up AutoSave and Backup
When you are working on a part, Mastercam can save your work automatically, at intervals that you specify. Master-
cam can also save versions of your files as backups.

In this exercise, you set up these functions.

1. Expand the Files category, and select the AutoSave / Backup page.
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2. In the AutoSave / Backup page, do the following:

l Select the AutoSave checkbox to activate the AutoSave options.

l Enter 10 for Interval (in minutes).

l Select theMastercam Backup Files checkbox to activate the automatic backup feature.

Mastercamwill save your work automatically every 10 minutes and keep the 10 most recent versions of
your file.

3. Select the Files page to view the location of your backup files.

4. Choose Backup files (Mastercam format) in the Data paths list. The path displays in the Selected item
box as shown in the following illustration.
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5. Selectmcamxm.config <Metric> from the Current drop-down to enable the Metric configuration for the
remainder of this tutorial.

6. ClickOK.

Note: If you would like to learnmore about the individual settings on any System Configuration page, click the
Help button located in the lower right-hand corner of the dialog box.

You have now completed Chapter 4 of Mastercam Basics Tutorial. In the next chapter, you learnmore about the Cus-
tomize dialog box.
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CHAPTER 5
CUSTOMIZING MASTERCAM

In this lesson, you learnmore about the Options dialog box. Use the Options dialog box to customize your Master-
camworkspace, including tab and interface options, the graphics window context menu, and keyboard shortcuts.

Goals

l Customize the graphics window context menu.

l MapMastercam functions to keyboard shortcuts.

l Set display options for tabs and interface colors.

Exercise 1: Customizing the Graphics Window Context Menu
In this exercise, you customize the graphics window context menu that displays when you right-click in the graphics
window. Customizing the context menu allows you quick access to your commonly used functions.

1. Click File, Options to open the Options dialog box.

2. Select the Context Menu page.

Categories of functions are displayed on the left side of the dialog box, while the right side contains the Con-
text Menu list as shown in the previous illustration.

59



3. Right-click the last item in the Context Menu list, and select Insert Separator.

A separator line appears after the last item.

4. Select File from the Category drop-down list.

5. Select the Save As function in the Category list and SEPARATOR in the Context Menu list, and then click
Add.

6. ClickOK to save these changes to the right-click menu.
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7. Right-click in the graphics window to see the updated context menu.

Save As has been added to the bottomof the menu.

Exercise 2: Mapping Functions to Keyboard Shortcuts
In this exercise, youmap aMastercam function to a shortcut key.

1. Click File, Options to open the Options dialog box.

2. Click Customize next to Keyboard shortcuts at the bottomof the Quick Access Toolbar page or Cus-
tomize Ribbon page.
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The Customize Keyboard dialog box opens.

3. Select Home from the Categories list.

The Commands list populates with functions from the Home tab.

4. Select Statistics from the Commands list.

Notice that the Current Keys list is blank. This is because there are no shortcut keys assigned to this function.

5. Click in Press new shortcut key, and press [Ctrl+Shift+H] to create a new shortcut key.
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6. Click Assign to map this shortcut key to the Statistics function.

7. Click Close to exit the Customize Keyboard dialog box, and thenOK to close the Options dialog box.

8. In the graphics window, press [Ctrl+Shift+H] to access the Statistics function.

The Statistics dialog box displays a summary of the entities in the current file, including total number of vis-
ible entities by type, and the number of operations and tools.

In this example, Statistics reports four lines because of the rectangle created in the previous lesson.

9. ClickOK to close Statistics.

Exercise 3: Setting Mastercam Display Options
In this exercise, you set some of Mastercam’s display options.

1. Select File, Options to open the Options dialog box.

2. Select the Options page.

3. Under theManager panels section, select Large icons.
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4. Under Interface, selectMedium for the Theme and set the Accent color to Green.

The Accent color changes the color of the Status Bar, the active tab, and the highlight color of functions.

5. ClickOK to close Options and view the Mastercam interface. The interface has larger icons and the selected
green theme.

6. Click File, Options, and return the settings to the original options or any other settings you choose.

You have now completed Chapter 5 of Mastercam Basics Tutorial. In the next chapter, you learnmore about work-
ing with files.
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CHAPTER 6
WORKING WITH FILES

Mastercamnot only saves and loads its own file types, (.mcx-*, .mcam), but also many common file formats, includ-
ing the following:

SOLIDWORKS CATIA Autodesk Inventor

AutoCAD IGES SpaceClaim

Parasolid ProE/Creo Mastercameducational

Solid Edge Alibre Cadkey

Rhino

Loading and saving native Mastercam files is as easy as selectingOpen, Save, or Save As from the Backstage shown
below. You can also choose one of these commands on the QAT.

You can also open files by:

l Dragging aMastercam file or third-party compatible file fromWindows Explorer and drop it in Mastercam’s
graphics window.

l Dragging and dropping a file onto the Mastercamdesktop icon to open a new instance of Mastercam.

Goals

l Open a non-Mastercam file.

l Import multiple files.

l Save patterns (Save Some).

l Export one or more files.

l Use Zip2Go files.
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Exercise 1: Opening Non-Mastercam Part Files
Importing files fromother applications is similar to opening native Mastercam files. Depending on the file, you
might need to specify howMastercam imports elements of the file. In this exercise, you convert a SOLIDWORKS
(.sldprt) file to aMastercampart.

1. Select File, Open. Click Computer and then Browse.

The Open dialog box displays.

Note: ClickDon’t Save if a dialog displays asking if you want to save changes to the current Mastercam file.

2. In the Open dialog box, select SOLIDWORKS Files (*.sldprt; *sldasm) from the drop-down.

The dialog nowdisplays only SOLIDWORKS parts.

3. Navigate to SW_Part.sldprt, which was provided with this tutorial.

4. Select the file, but do not double-click it.

5. Click the Options button.

The SOLIDWORKS File Parameters dialog box opens.

When importing a non-Mastercam file, youmight need to change the options so that it can be read properly
into Mastercam. Use these options, which change based on the file type, to control how files are read into the
Mastercamdatabase.
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6. ClickOK without making changes.

7. ClickOpen in the Open dialog box. Mastercam converts and opens the part.

8. Right-click in the graphics window, and select Isometric (WCS) from the menu.

See the following illustration of the imported SOLIDWORKS file.
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9. If necessary, clickOutline Shaded and Translucency to view the part as a solid.

You learnmore about the graphics window and views in later sections of the tutorial. If you would like more inform-
ation, you can also refer to the MastercamHelp.

Exercise 2: Importing Multiple Part Files
When you have many files to import into Mastercam, you can convert themall at once using the Import Folder com-
mand.

1. Select File, Convert and then click Import Folder.

The Import folder dialog box opens.
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2. Select SOLIDWORKS Files (*.sldprt; *sldasm, *slddrw) from the Import from files of type drop-down.

3. Click the Browse button to the right of the From this folder box.

The Browse For Folder dialog box opens.

4. Select the location where you stored the tutorial files, and then clickOK.

5. Click the Browse button to the right of the To this folder box.
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6. Browse to \Documents\my mcam2019\parts and then clickOK.

7. ClickOK in the Import folder dialog box.

Mastercam converts all SOLIDWORKS files in the selected tutorial files directory, but does not display the con-
verted files in the graphics window. In this instance, there is only one. You can find the resultingMastercam
file (SW_Part.mcam) in the \parts folder.

70

Mastercam Basics Tutorial—6: Working with Files



71

Exercise 3: Saving Patterns (Save Some)
A pattern is a set of reusable entities. For example, youmay have a bolt that you use inmany different parts. By sav-
ing that bolt as a pattern, you canmerge it with your other parts as needed.

When you save aMastercampart, you can choose to save the entire file or to save only selected entities. Saving a
set of selected entities is one way to create a pattern froma part file. This exercise demonstrates the File, Save
Some command, which lets you choose the entities to save.

1. Open 2D_CHAMFER_MM, which was provided with this tutorial. In the Open dialog box, youmight need to
change your file type toMastercam Files (*.mcam).

2. Select File, Save Some.

3. ChooseWireframe on the Status Bar to show the wireframe of the solid body making it easier to select the
arcs.
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4. Select the five arcs shown in the picture below. The arcs change color when they are selected.

5. Press [Enter] to accept the selection. The Save As dialog box opens.

6. Type 2D_CHAMFER_ARCS for the File name.

7. Click Save or press [Enter] to save the file. Mastercam saves only the selected arcs.

8. Open 2D_CHAMFER_ARCS, and notice that it contains only the arcs that you selected.
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Exercise 4: Exporting a Single File
When exporting, youmight need to set a few options so that you get the type of file you expect. Inmost cases, you
need only select the software package to which you are exporting the file. In this exercise, you learn to convert a
single file fromone format to another.

1. Open 2D_CHAMFER_MM, which was provided with this tutorial.

2. Select File, Save As, and then click Browse.

The Save As dialog box opens.

3. Select StereoLithography Files (*.stl) in the Save as type drop-down list.

4. ClickOptions.

The Save as an STL File dialog box opens.
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5. Select the ASCII option.

6. ClickOK to close the Save as an STL File dialog box.

7. Click Save in the Save As dialog box.

Mastercam saves the file in ASCII StereoLithography format.

Note: Because the StereoLithography file is ASCII, you can view it with any text editor, such as Notepad, as
shown below.
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Exercise 5: Exporting Multiple Files
When you have many Mastercam files to export into a different format, you can convert them simultaneously using
the Export Folder command. This exercise demonstrates how this function works.

1. Select File, Convert, and then click Export Folder.

The Export folder dialog box opens.

2. Select IGES Files (*.igs, *iges) from the Export to files of type drop-down.
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3. Click the Browse button to the right of the From this folder box.

The Browse For Folder dialog box opens.

4. Select the directory where you stored the tutorial parts, and then clickOK.

5. Click the Browse button to the right of the To this folder box.
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6. Browse to \Documents\my mcam2019\parts, and clickOK.

7. ClickOK in the Export folder dialog box.

Mastercam converts the files in the selected tutorial folder. You can find the resulting IGES files in your
\parts folder.

Exercise 6: Using Zip2Go
You use the Zip2Go utility to gather and compress the current openMastercampart data into a .ZIP or .Z2G file.
These files can then be opened and viewed withmost zip/unzip programs. This is especially useful if you are trying to
share information with other users or Technical Support.

Zip2Go scans the machine groups in your current file and captures certain information such as your Mastercam con-
figuration, machine definition, post files, tool andmaterial libraries, and other necessary files. In this exercise, you
run Zip2Go to compress a file.
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1. Open Brace, which was provided with this tutorial.

2. Select File, Zip2Go.
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The Zip2Go dialog box opens.

Use this dialog box to create and view Zip2Go files. The file list displays information about the files contained
in the Zip2Go archive. You can also select files that you want, and deselect files that you do not want to
include in the Zip2Go file. For this tutorial, keep the default settings.

3. Select File, Options from the menu bar.

The Options dialog box opens.
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Use this dialog box to configure the default settings for Zip2Go. Make sure the current default output folder
is your \Documents folder.

4. ClickOK to close the Options dialog box.

5. Click Create Zip2Go.

The Save Zip2Go file dialog box opens. By default, Mastercam creates a zipped file with a .ZIP extension in
the selected folder. You can change the file type to .Z2G in the Save as type drop-down.
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6. Click Save. The Zip2Go file list is populated by files included in the Zip2Go file you created.

7. ClickOK to close the Zip2Go dialog box.

Note: If the part file contains no toolpaths, Zip2Go only packages the configuration files.

You have now completed Chapter 6 of the Mastercam Basics tutorial. In the next chapter, you learnmore about the
graphics window and related functions.

Mastercam Basics Tutorial—6: Working with Files



82



CHAPTER 7
WORKING WITH THE GRAPHICS WINDOW

The graphics window is your workspace in the Mastercam interface.

Mastercamprovidesmany tools you can use to change the graphics windowdisplay to suit your needs. This section
introduces some of these tools, and teaches the basic skills you need tomanage your Mastercamworkspace.

Goals

l Customize on-screen prompts.

l Change standard views.

Exercise 1: Customizing Function Prompts
When you use a function that requires your input, such as selecting an entity, Mastercamprovides brief directions in
a prompt. You can customize these prompts to change their size, text color, background color, and position on the
screen.

In this first exercise, you alter the size and appearance of the function prompts.
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1. Click File, New.

2. On theWireframe tab, select Point Position.

The Point Position function panel opens.

Notice the prompt displayed in the graphics window.

3. Right-click the prompt, and select Small font.

The prompt nowdisplays smaller as shown in the illustration below.
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4. Right-click the prompt, and select Background color.

The Colors dialog box opens.

5. Enter 167 in the Current color attribute box.

6. ClickOK to change the background color and exit the Colors dialog box.

The function prompt nowdisplays with a blue background.

7. Move the function prompt by clicking and dragging it to a new location on your screen.

8. Return the prompt to its default attributes for the remainder of this tutorial, by doing the following:

a. Set the font size to Large font.

b. Set the Background color to 15.

9. Click Cancel to close the Point Position function panel.
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Exercise 2: Changing Standard Views
In this exercise, you change your graphics view (Gview) using standard views.

1. Open ANGLEBLOCK-MM, which was provided with this tutorial. The part opens in Isometric (WCS) view.

2. Click the Show Axes drop-down on the View tab, and deselectWorld, Cplane, and Tplane, ensuring only
WCS remains selected.

The coordinate axes show the origin and the part orientation to help you visualize the part in 3D space.
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3. Click Show Axes on the View tab or press [F9] to toggle the display of the WCS axes.

4. Click the Show Gnomons drop-down on the View tab, and deselect Cplane and Tplane, ensuring onlyWCS is
selected.
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5. Click Show Gnomons or press [Alt+F9] to toggle the display of the on-screen gnomon.

6. On the View tab, click Top in the Graphics View group.

7. ClickUnzoom 80% on the View tab to reduce the size of the part on the screen.
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You are now viewing the part as if you were above it looking down.

8. You can also use the right-click menu to change the view. Practice switching to other views using thismenu.

9. When finished, return the part to Isometric view for the next lesson.

10. Click Show Gnomons to turn off the display of gnomons in the graphics window.

You have now completed Chapter 7 of the Mastercam Basics tutorial. In the next chapter, you learnmore about
viewing your part.
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CHAPTER 8
VIEWING YOUR PART

Mastercamprovides several tools andmethods for changing the appearance of the geometry and toolpaths in the
graphics window. In this lesson, you learn different ways of viewing your part, to hide portions of your part, and to
create and use Viewsheets.

Goals

l Fit all entities in the graphics window.

l Use zoom functions to magnify your view of selected entities.

l Dynamically rotate and pan entities in the graphics window.

l Create a Viewsheet.

l Blank and hide entities.

Exercise 1: Viewing All Entities
In this exercise, you set up your graphics window to view all entities in aMastercampart file.

1. If necessary, open the tutorial part ANGLEBLOCK-MM. Change your view to Isometric, and press [F9] to show
the axes.

2. Choose Fit on the View tab or press [Alt+F1].

Fit and several other Zoom commands are also available in the right-click menu.

The part now fills the entire graphics window.
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3. On the View tab, choose Unzoom 50% to decrease the size of the display to 50%. This creates free space
around the part.
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Exercise 2: Zooming In and Out
In this exercise, you practice different techniques for viewing specific areas of detail in aMastercampart.

1. Place your cursor in the upper left quadrant of the graphics window.

2. If your mouse has amiddle mouse wheel, spin it back and forth to dynamically zoom in and out. You can also
press the [Page Up] and [Page Down] keys on your keyboard to zoom in and out.

3. Click Fit or press [Alt+F1] to fit the part to the screen.

4. ChooseWindow.
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5. Click and drag a diagonal window around the upper section of the part as shown below.

6. Click to set the zoomwindow. Mastercam scales the selected area to fit the entire graphics window.

7. Right-click the graphics window and choose Fit.

94

Mastercam Basics Tutorial—8: Viewing Your Part



95

8. Select the circle on the front of the angle block as shown in the illustration.

9. Choose Selected from the Fit drop-down on the View tab.

The selected entity is scaled to fit the graphics window.
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10. Press [Esc] to clear the selection.

Exercise 3: Rotating Your Part View
This exercise shows how to set the preference for the action your middle mouse button or wheel performs in the
graphics window (rotate or pan). You also learn to dynamically rotate entities in the graphics window so that you can
see them fromany angle.

1. Select File, Configuration to open SystemConfiguration.

2. Expand the Screen group, and select View.

3. If necessary, setMiddle button/wheel to Rotate.

By choosing Rotate, Mastercam sets dynamic rotation as the primary function when you click and hold the
middle mouse button or mouse wheel.
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4. ClickOK to close the System Configuration dialog box.

5. Set up the part in the graphics window, as follows:

a. Set the Gview to Front.

b. ClickUnzoom 80%.

6. Middle-click in the graphics windowwhere indicated below and continue to hold down the middle mouse but-
ton or wheel as youmove the mouse slowly in a circular motion.

This action rotates the part in space about the selected position and lets you see it fromany angle.

7. Let go of the middle mouse button/wheel to finish rotating the part.

The axes symbol (gnomon) in the graphics window changes as you rotate the part. The Gview name in the
graphics windowno longer displays because you are not in a standard view.

8. Return the view to Isometric, and fit the part to the screen.

Note: You can also choose Dynamic Rotation from the right-click menu and follow the on-screen prompts to
rotate the part.

Exercise 4: Panning Your Part
In this exercise, you change your view in the graphics window as if you were moving a camera lens to the left or
right, and up and down over the part.
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1. Hold down the [Shift] key, middle-click in the graphics windowwhere indicated, and continue to hold down
the button/wheel while youmove the mouse up, down, side to side, and around.

It appears that you have picked up the part and are moving it in the direction of the mouse. However, the
entities are not physically moved in space, only the display changes. The Gview does not change as you pan
the entities.

2. Release the [Shift] key while still holding down the middle mouse button/wheel and you can rotate the part.
Press the [Shift] again to return to panning.

3. When you finish panning, release the [Shift] key and the middle mouse button/wheel at the same time to exit
the function.

Exercise 5: Using Viewsheets
Mastercamallows you to view your part in different orientations by using viewsheets. Viewsheetsmake viewing a
large part easier, as you can set upmultiple viewsheets with different views. Also, you can create a bookmark for
each viewsheet. A bookmark holds the settings for the view displayed in the viewsheet. When you save your part
file, Mastercam stores the viewsheet settings, including the bookmark, along with the part. Whenworking with your
part, you can restore the viewsheet to its saved view by restoring the bookmark.

In this exercise, you create a viewsheet.

At the bottomof the graphics window, notice a tab named Viewsheet 1. This is the main view of your part and can-
not be deleted.
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1. If necessary, fit the part to the graphics window, and set the view to Isometric.

2. Choose New in the Viewsheets group on the View tab. Alternately, you can right-click Viewsheet 1 and
selectNewViewsheet from the menu.

3. Press [Enter] to accept the default name.

Viewsheet 2 is created and displayed next to Viewsheet 1.

4. Right-click in the graphics window, and select Right (WCS) to view the part on its right side.
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5. Select Viewsheet 1 again.

Notice that the view did not change on Viewsheet 1. Each viewsheet can contain different views and planes.

6. Right-click Viewsheet 1 and select Settings from the menu.

The Viewsheet Settings dialog box opens.
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You can use the Viewsheet Settings dialog box to indicate which settings to save to the viewsheets. These
settings only apply to the selected viewsheet tab.

7. ClickOK to exit the Viewsheet Settings dialog box without making changes.

Exercise 6: Blanking and Hiding Entities
In larger andmore complicated parts, it can be difficult to select geometry for toolpaths or geometry manipulation.
Mastercamallows you to Blank entities, which removes selected entities (fromany level) to reduce screen clutter.

Similar to Blank is Hide. With Hide, you select the entities that will remain in the graphics window; all unselected entit-
ies are removed. Both functions have their benefits, but consider these differences:

l You can save the state of blanked entities; hidden entities' states are not saved.

l Choose Hide/Unhide to remove many entities from the display, or to quickly restore hidden entities.

l Choose Blank to selectively remove and restore a number of entities from the display. Choose Unblank to
restore blanked entities.

In this exercise, you first blank and unblank geometry, and then hide and unhide geometry.

1. Open BLANK_PART, which was provided with this tutorial.

If prompted to save ANGLEBLOCK-MM, choose Don’t Save.

2. On the Home tab, select Blank.

Mastercam then prompts you to select entities to blank.

3. Select the geometry shown below:
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4. Press [Enter] or choose End Selection located below the Selection Bar to accept the selections.

The selected geometry no longer displays in the graphics window.

Now, you unblank the geometry selected in the previous steps.

5. Select Unblank from the Blank drop-down.

The graphics window changes to display entities that have been blanked, so that you can select which ones to
unblank and which ones to keep hidden.

6. Select all of the blanked entities, and press [Enter]. The part should be whole again.

Next, you use the Hide/Unhide function.
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7. Select Hide/Unhide.

Mastercamprompts you to select which entities to keep.

8. Select the geometry shown below:

9. Press [Enter] or choose End Selection to accept the selection.

The graphics windowhides the unselected geometry.

Next, you unhide the geometry usingUnhide Some.
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10. Select Unhide Some.

Mastercam then prompts you to select entities to keep on the screen.

11. Select the geometry shown below:

12. Press [Enter] to accept the selections.

Mastercamunhides the selected geometry. Any geometry that was hidden and not selected remains hidden.

13. ClickHide/Unhide to show all entities.
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Exercise 7: Using Materials
In this exercise, you use Matercam'sMaterial display to make your partsmore realistic looking.

1. Load the file GPS Suction Mount, which is included with this tutorial.

2. Click the View tab, and find theMaterial button in the Appearance group.

3. If theMaterial button is not highlighted, click it. Changes to materials only show in the graphics windowwhen
this option is on.

4. In the graphics window, click the base of the part to select it.

5. Click the Home tab.
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6. Click the down arrownext to the Set Material button. The material gallery displays.

7. In theMetal group, click the fourth icon from the left. The part's base changes to the selectedmaterial, a
semi-reflective metal.
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8. Select the face of the device clamp, as shown in the following image.

9. In the Set Material drop-down, click the last icon in the Plastic group.

10. Select the casing behind the clamp face, and choose Glass Level 3 from the material gallery.
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11. Go back to the View tab, and toggle theMaterial button on and off to see how it controlsmaterial visibility.

Exercise 8: Managing Section Views
In this exercise, you use Mastercam's section views to show cross sections of a part.

1. Load the file Spool Body, which is included with this tutorial.

2. Click the View tab, and find the Section View button in the Graphics View group.

3. Click the Section View button to activate it. Section views only show in the graphics windowwhen the feature
is on.

4. InMastercam's lower-left corner, click the Planes tab to display the PlanesManager.
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5. In the row for the Top plane, click in the Section column. Mastercamdisplays the part in cross section, using
Top as the clipping plane, as shown in the second following image.

6. Click the down arrownext to the Section View button. A drop-downmenu displays. You can use thismenu to
select what types of geometry are affected in section view. You can also add "caps" to part sections, as you
see in the next step.
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7. From the Section View drop-downmenu, click Show Caps. Mastercamadds solid caps to the sectioned
areas, as shown in the following picture.

Note: You can also access Section View functionality fromPlane Manager's toolbar, as shown in the following image.

You have now completed Chapter 8 of the Mastercam Basics tutorial. In the next chapter, you learnmore about
levels.
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CHAPTER 9
WORKING WITH LEVELS

A Mastercam file can contain separate levels for wireframe, solids, surfaces, drafting entities, toolpaths, and other
part data. Organizing your file data by levels lets you control the areas of the drawing that are visible and the entit-
ies you can select in the graphics window.

This controlmakes it easier to work with the file and helps prevent you fromaffecting areas of the drawing you do
not want to change.

You can create and name asmany levels as you need and set any one to be the active, current working level. For
each level you create, you assign a unique number and, optionally, a name. Mastercam’s LevelsManager provides a
central location where you can view and create levels, and set their properties.

Goals

l Explore the LevelsManager.

l Modify the LevelsManager display options.

l Turn level displays off and on.

l Change the active level.

l Create a new level.

l Move selected entities to a different level.

Exercise 1: Exploring the Levels Manager
When first opening aMastercam file, youmight not be aware of all entities in the part because they might exist on
levels that are not displayed in the graphics window. In these instances, you can use the LevelsManager to view all
of the levels in the file and so get an overview of the geometry that makes up the part.

The LevelsManager ismovable and dockable. You can dock it to a fixed location on the interface, float it anywhere
on the workspace, or move it to another monitor. These settings are modal, whichmeans that Mastercam remem-
bers the settings even after you close the application.

In this exercise, you explore the LevelsManager andmodify some display options.
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1. Open LEVELS_PART, which was provided with the tutorial, and save it with a newname.

If prompted to save BLANK_PART-MM, choose Don’t Save.

2. Click the Levels tab, and drag and drop it anywhere on the workspace.

If the Levels tab does not show, select Levels in theManagers group of the View tab.

3. Resize the LevelsManager by clicking and dragging any of its edges.
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The LevelsManager shows all levels that exist in the current part file, their display status, and the number of
entities per level.

A. The checkmark in the Number column indicates the current active level.

B. Active level parameters display in this section.

C. Use any column heading to sort the levels grid. To sort, click the column heading. To change the sort
order (ascending or descending), click again.

D. Use these options to filter the levels grid.

4. ClickHide level properties to hide the property controls in the lower section of the LevelsManager andmax-
imize the space allotted to the levels grid.

5. ClickHide level properties again to show the controls at the bottomof the LevelsManager.
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6. ClickDisplay options, Contrast rows to apply shading to every other rowused in the grid.

7. Dock or locate the LevelsManager in a convenient location.

In the next exercise, you learn to turn level displays on and off.

Exercise 2: Showing or Hiding Levels
In this exercise, you change the graphics windowdisplay by turning level display on and off. To select or otherwise
work with an entity in the graphics window, its levelmust be visible.

1. In the Visible column for level 2: Solid, click once to turn off the display of that level.

The change is immediate in the graphics window.
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If necessary, drag the LevelsManager to a position that gives you a better view of the graphics window.

2. Click again in the Visible column for level 2: Solid to toggle the level display on.

3. Try turning off the display of level 1: Wireframe.

When Active level is always visible is selected inDisplay options, you cannot turn off the active level dis-
play in the graphics window.

Note: Turning off the display of the active level while you are working in that level is not recommended.
However, it may occasionally be necessary.

4. ClickDisplay options, and deselect Active level is always visible.

5. Use Turn all levels off and Turn all levels on to toggle the display of all levels on or off.

6. Select Active level is always visible again.

7. Make sure all levels are visible before continuing on to the next exercise.

Exercise 3: Changing the Active Level
Any geometry that you create is always placed on the active level. There can only be one active level at a time, but
you can change the active level as often as necessary to work with the part. In this exercise, you change the active
level using severalmethods.
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1. In the LevelsManager, click once in the Number column of level 2: Solid to set it as the active level. A check-
mark indicates that it is now the active level.

The level field located in the Organize group on the Home tab also shows that level 2: Solid is the active
level.

2. Select level number 1: Wireframe from the levels drop-down tomake it the active level.

A checkmark appears in the Number column for level 1.

3. In the LevelsManager, turn off the visibility of level 2: Solid.

4. Position the cursor anywhere in the row for level 2: Solid, right-click and chooseMake active.

A checkmark appears in the Number column for level 2.

Level 2: Solid is also visible because the LevelsManager display option Active level is always visible is selec-
ted.
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Exercise 4: Creating a Level and Assigning Entities
In this exercise, you create and name a level, and then assign entities to that level.

1. In the LevelsManager, click Add a new level.

Mastercamadds a new level to the LevelsManager grid and sets it as the active level.

2. In the Name field, type Tutorial.

The LevelsManager grid updates to show the newname. Although level names are optional, descriptive
names are helpful.

3. Make level 1: Wireframe the active level.
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4. Use the Display options in the lower section of the LevelsManager to control the visibility of levels. You can
showonly used levels (those assigned to entities), levels that are named (regardless of whether they are
used), either used or named levels, or limit the display to a range of level numbers.

5. ClickUsed and notice that level 3: Tutorial is no longer visible because there are no entities assigned to it.

6. ClickUsed or named to restore visibility of all levels.

7. Make level 3: Tutorial the active level.

8. Select Point Position on theWireframemenu.
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9. Click a few times in different places in the graphics window to create some points.

10. ClickOK on the Point Position function panel to exit the function.

11. Verify that the newgeometry was created on level 3: Tutorial. In the LevelsManager, the number of Entit-
ies is not 0.

Note: Your number of pointsmay be different than what is shown in the previous illustrations.

12. Practice turning level displays on and off and changing the main level.

When you are ready, turn on the visibility for all levels and continue with the next exercise.
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Exercise 5: Moving Entities to a Different Level
In this exercise, you create a new level using a different method than you used previously andmove entities from
one level to another. You can use the same basic procedure to copy entities to a different level.

1. In the LevelsManager, enter 4 in the Number field, and then enter Labels for the levelName.

The new level, 4: Labels becomes the active level.

2. Make level 1: Wireframe the active level.

3. On the Home tab, click Change Level.

4. Mastercamprompts you to select entities. Use the following steps to select all labels located on level 1: Wire-
frame.
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a. Choose the Quick Mask, Select all advanced.

The Select All dialog box displays.

b. In the Select All dialog box, create a selectionmask for all of the label entities.

A selectionmask is a defined set of criteria that you use to quickly select entities in the graphics window.

l Select the Entities checkbox.

l Expand the Drafting node and select Labels in the list.

l ClickOK.

In the graphics window, Mastercamhighlights all the notes, indicating that they are all selected.
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5. Press [Enter] or choose End Selection located below the Selection Bar.

6. The Change Levels dialog box displays.

Note: You can also use general selectionmethods to pre-select entities before choosing the Change Level
option. When you pre-select entities, Mastercamdoes not prompt you to select additional entities and you
advance directly to the Change Levels dialog box.

7. In the Change Levels dialog box complete the following steps:

a. ChooseMove.

b. Deselect the Use Active Level checkbox.

c. Type 4 inNumber.

d. ClickOK.
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8. In the LevelsManager, verify that level 4: Labels now contains the four label entities that were on level 1.

Level 1: Wireframe contains four fewer entities.

9. Save your part.

You have now completed Chapter 9 of the Mastercam Basics tutorial. In the next chapter, you learnmore about
views and planes.
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CHAPTER 10
UNDERSTANDING VIEWS AND PLANES

Mastercamuses a 3D Cartesian coordinate system to locate your work in three-dimensional space. Thismeans that
geometry and toolpath positions are expressed in terms of three coordinate axes: X, Y, and Z. Each axis is signed,
whichmeans it has a positive and negative direction.

In previous lessons, you learned about standard views and planes. In this lesson, you learnmore about creating
your own planes and using them for geometry creation.

Goals

l Understand views and planes.

l Customize the PlanesManager.

l Adjust follow rules.

l Create a customplane.

l Use a customplane for geometry creation.

l Create a newplane using the dynamic gnomon.

Exercise 1: Exploring the Planes Manager
You use views and planes inMastercam for many drawing andmachining purposes.

A plane is any two-dimensional slice of a 3D coordinate system. Examples of planes include the XY plane in a 3D
coordinate system, or a face of your part, nomatter its angle.

A view is a plane with an origin and orientation. For example, the Left side view and Right side view are both aligned
with the same plane; but a clockwise arc in one view is a counterclockwise arc in the other view.

Mastercam includes a number of pre-defined views, which you explored in Lesson 7. These include Top, Front,
Right, Isometric, and others.

The work coordinate system (WCS) refers to the alignment of the coordinate system itself. You can choose to align
the coordinate systemaxeswith any plane you wish. When this happens, youmap the XY plane to the plane of the
view. The origin of the view becomes your new (0,0,0) point. The view becomes the Top plane in the newworking
coordinate system.

Note: If you would like to learnmore about the work coordinate system, try the Mastercam Work Coordinate System
Tutorial located onwww.mastercam.com/en-us/Support/Tutorials.

This section introduces some ways planes are used and some ways to access them. You can use views and planes for
three main functions:

l Graphic views (Gviews)—A Gview determines the angle fromwhich you are looking at the part in the
graphics window.

l Construction planes (Cplanes)—When you drawgeometry, the Cplane is the plane in which the geometry
is created. This does not have to be the same as the Gview. For example, you can look at your part in Isomet-
ric Gview, while drawing geometry in the Front Cplane.
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l Tool planes (Tplanes)—This is the plane that is typically normal to the tool axis. Tplanes are only used when
creating toolpaths. Tool planes determine the tool orientation. In almost all cases, your Cplane will be the
same as your Tplane (the most common exceptions are mill/turn operations).

You use PlanesManager to select, edit, create, andmanage planes.

Some of the functions of the PlanesManager include:

l Creating newplanes

l Setting Cplanes, Tplanes, andWCS to selected planes

l Setting or changing the origin of planes

l Assigning work offsets to planes

In this exercise, you open the PlanesManager and experiment with display options and follow rules.

1. Open BRACE, which was provided with the tutorial. Save the file with a newname.

2. If necessary, clickOutline Shaded on the Status Bar to show the part as a solid.
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3. Select the Planes tab to bring the PlanesManager to the front. If the Planes tab is not displayed, select
Planes on the View tab.

4. ClickDisplay options, Always display gnomon.

The gnomon for the currently selected plane displays in the graphics windowwhether or not the PlanesMan-
ager has focus.

5. Choose Display options, Contrast Rows to customize the planes grid by shading every other used row.

6. Click the Follow rules drop-down to view the current settings as shown in the illustration. With the current
settings, when you change the Gview of a plane, the Cplane and Tplane follows.

Do not alter any settings.
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7. Click in the G column of the Bottom plane to set the Gview to bottom. Note that Cplane and Tplane follow the
Gview as directed by the follow rules.

8. Choose the Follow rules drop-down, and deselect Cplane follows Gview.

9. Click in the G column of the Top plane to set the Gview to top. Note that Cplane and Tplane no longer follow
the Gview, as directed by the new follow rules.

10. Click the Follow rules drop-down, and reselect Cplane follows Gview.
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11. Click in the G column of the Iso plane to return the Gview to Isometric. Note that Cplane and Tplane remain
in the Top plane as the follow rule, Cplane = Top in Iso Gviews is selected.

Exercise 2: Creating a Custom Plane
In this exercise, you create a customplane aligned with the slanted face of the part and add it to the list of system
planes.

1. Select From solid face in the Create a new plane drop-down.
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2. Select the slanted face of the part, shown below:

3. In the Select plane dialog box, click the arrows to cycle through the possible views. For most applications, it
make sense to have +Z pointing away from the part.
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4. Cycle to the view shown in the following illustration.

5. ClickOK in the Select plane dialog box.

The New Plane function panel opens.

6. Enter FACE OF PART as the Name of the newplane.

7. Select Cplane in the Set As group.

8. Click Reselect to choose a newpoint for the origin.
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9. Select the point at the lower-right corner of the face.

10. ClickOK to close the NewPlane function panel.

Your newplane, FACE OF PART displays in the planes grid.

Exercise 3: Using a Custom Plane for Drawing Geometry
In this exercise, you create geometry using the newCplane. You see that the newplane determines the orientation
of the geometry. You then set the Gview to the newplane.

1. Select Circle Center Point from theWireframe tab.
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2. Select Origin from the AutoCursor drop-down on the Selection Bar.

3. In the Circle Center Point function panel, enter a Radius of 80.0, and then clickOK.
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Mastercam creates a circle that is aligned with the face of the part. It is centered on the origin on the custom
plane not the systemorigin.

4. Click View, Show Axes and turn on all the axes.
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5. If necessary, press [F9] to display the XYZ axes. Each axes type displays in a different color. Since Cplane and
Tplane are the same, the axes display as dotted lines. Experiment by turning individual axes on and off.

6. In the PlanesManager, click in the G column of the FACE OF PART plane to set the Gview.
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You are now looking straight down into the face of the part. The Gview is aligned with the customplane that
you just created.

7. Save your part.

Exercise 4: Creating a New Plane Using the Dynamic Gnomon
In this exercise, you create a newplane using the on-screen dynamic gnomon. When creating a newplane using this
method, the gnomon is initially oriented to the current Gview.

1. In PlanesManager, click the G column in the Iso row to return the part to isometric view.

2. ClickWindow on the View tab.
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3. Draw a box around the area of the part shown in the following illustration to zoom in.

4. Hover over the on-screen, dynamic gnomon until it glows.
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5. Click and drag the gnomon to the position shown in the following illustration. Click to set the position.

The New Plane function panel opens.

6. To change the orientation of the dynamic gnomon, hover over the blue arc until the rotational compass
appears.
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7. Click the blue arc and rotate the gnomon fromwithin the compass until it is at 90 degrees. Click to set the loc-
ation. (Rotating within the compass snaps in angular increments.)

Alternatively, you can enter 90 in the on-screen edit field, and press [Enter] twice.
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8. In the New Plane function panel, type DYNAMIC PLANE as the Name of the plane.

9. ClickOK to close the New Plane function panel.

The Cplane and Tplane axes indicate the location of the newplane origin as shown in the following illustration.
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10. DYNAMIC PLANE appears in the PlanesManager designated as the Cplane and Tplane.
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CONCLUSION
Congratulations! You have completed the Mastercam Basics Tutorial! Now that you have mastered the skills in this
tutorial, explore Mastercam's other features and functions.

Youmay be interested in other tutorials that we offer. Mastercam tutorials are being constantly developed, and we
will addmore as we complete them. Visit our website, or select Help, Tutorials from the File tab.

Mastercam Resources
Enhance your Mastercamexperience by using the following resources:

l Mastercam Documentation—Mastercam installs a number of helpful documents for your version of software
in the Documentation folder of your Mastercam2019 installation.

l Mastercam Help—AccessMastercamHelp by selectingHelp, Contents fromMastercam's File tab or by press-
ing [Alt+H] on your keyboard.

l Mastercam Reseller—Your localMastercamReseller can help withmost questions about Mastercam.

l Technical Support—Our Technical Support department (+1 860-875-5006 or support@mastercam.com) is
openMonday through Friday from8:00 a.m. to 5:30 p.m. USA Eastern Standard Time.

l Mastercam Tutorials—We offer a series of tutorials to help registered users become familiar with basic
Mastercam features and functions. Visit our website, or select Help, Tutorials fromMastercam's File tab to
see the latest publications.

l Mastercam University—MastercamUniversity, an affordable online learning platform, gives you 24/7 access to
Mastercam trainingmaterials. Take advantage of more than 180 videos to master skills at your own pace and
help prepare for MastercamCertification. For more information onMastercamUniversity, please contact
your AuthorizedMastercamReseller, visit www.mastercamu.com, or email training@mastercam.com.

l Online Communities—You can find awealth of information at www.mastercam.com. For tech tips and the
latest Mastercamnews, follow us on Facebook (www.facebook.com/mastercam), Twitter
(www.twitter.com/mastercam), or Google+ (plus.google.com/+mastercam). Visit our YouTube channel to see
Mastercam in action (www.youtube.com/user/MastercamCadCam)! Registered users can search for inform-
ation or ask questions on the MastercamWeb forum, forum.mastercam.com, or use the knowledgebase at
kb.mastercam.com.

Contact Us

For questions about this or other Mastercamdocumentation, contact the Technical Documentation department by
email at techdocs@mastercam.com.
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