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INTRODUCTION
Welcome to the Mastercam Basics Tutorial. This tutorial helps you explore Mastercam’s interface and learn basic
concepts of the software. This tutorial includes the following:

l A broad look at the Mastercam interface.

l An introduction to Mastercam’s File menu, also known as the Backstage.

l An introduction to creating andmanaging levels and planes.

l An exploration of solid and wireframe chaining.

l An introduction to creating toolpaths.

Tutorial Goals

l Understand basicMastercam functions.

l Customize a configuration file andMastercam’s interface for your working style.

l Chain geometry and create toolpaths for your part.

l Manipulate Mastercam’s graphics window, levels, and planes to view your part.

WARNING
This tutorial is for educational purposes only. We have not verified the values and settings in this tutorial with our
machines or tools. Do not use the values in this tutorial to cut parts without proper verification and testing for
your environment.

Screen colors in the tutorial pictures were modified to enhance image quality; they may not match your Mastercam
settings or the tutorial results. These color differences do not affect the lesson or your results.

Estimated time to complete this tutorial: 6 hours

General Tutorial Requirements
All Mastercam 2022 tutorials have the following general requirements:

l Youmust be comfortable using the Windows® operating system.

l The tutorials cannot be used withMastercamDemo/Home Learning Edition. The Demo/HLE file format (emcam)
is different fromMastercam (mcam), and basicMastercam functions, such as file conversions and posting, are
unavailable.

l Each lesson in the tutorial builds on the mastery of the preceding lesson's skills. We recommend that you
complete them in order.

l Additional filesmay accompany a tutorial. Unless the tutorial provides specific instructions on where to place
these files, store them in a folder that can be accessed from the Mastercam 2022 workstation, either with the
tutorial or in any location that you prefer.
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l Youwill need an internet connection to view videos that are referenced in the tutorials. All videos can be found
on our YouTube channel:
www.youtube.com/user/MastercamTechDocs

l All Mastercam tutorials require you to configure Mastercam to work in a default Metric or Inch configuration.
The tutorial provides instructions for loading the appropriate configuration file.
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CHAPTER 1

MASTERCAM INTERFACE OVERVIEW
Mastercam’s ribbon interface is based on standardWindows design guidelines. The ribbon comprises familiar controls,
including aQuick Access Toolbar (QAT), tabs, contextual tab groups, galleries, buttons, and the Backstage. It also
features special on-screen controls, andmovable, dockable Managers and function panels.

This section briefly touches on the elements that make up the Mastercam interface to give you a better
understanding of how to use these elements to create andmachine your parts.

Goals

l Explore Mastercam's interface.

l Customize the Quick Access Toolbar.

l AccessMastercam resources.

l Configure entity attributes.

l Understand Selection Bar, AutoCursor, and Fast Point.

l Use Quick Masks.

l Explore the Status Bar.

Exercise 1: Exploring Mastercam’s Interface
Start Mastercamusing your preferredmethod:

l Double-click Mastercam's desktop icon.

Or,

l LaunchMastercam from the Windows Startmenu.
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The following image displays the elements that make up the Mastercam interface. The corresponding sections provide
brief descriptions of each element and its use.

1. Quick Access Toolbar (QAT): A customizable set of commonly used functions that are always available in the
interface. The QAT can be located above or below the ribbon.

2. Tab: Groupings of related controls. Tabs are organized in a simple-to-complex workflow from left to right.

3. Tab Group: A region of the tab that contains a set of related controls.

4. Contextual Tab: A tab that displays when youmake a specific selection inMastercam. A contextual tab
presents controls and commands relevant to your current activity.

5. Tooltip: A small windowwith descriptive text that displays when you hover over a command or control.

6. Selection Bar: A toolbar that combines AutoCursor controls and general selection tools used to select entities
in the graphics window. There are two selectionmodes, Standard Selection and Solid Selection, which are
activated based on the function you are using. AutoCursor controls allow you to detect and snap to locations as
youmove the cursor over geometry in the graphics window. AutoCursor becomes active whenever Mastercam
prompts you to select a position in the graphics window.

7. Quick Masks: A group of controls that helps you to select all entities of a certain type, or to select only entities
of certain type. Most Quick Mask controls are divided in half. Clicking the left or right side of the control toggles
between selectionmodes. When aQuick Mask control is selected it highlights to indicate the selectionmask is
on. You can toggle multiple Quick Masks at a time.

10
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8. Status Bar: A bar across the bottomof the workspace that shows the coordinate position of the cursor and
provides quick access to modify planes, constructionmode, and Z depth. The right side of the Status Bar has
wireframe, shading, and translucency controls that change the appearance of your part. The left side of the
Status bar indicates the number of selected entities and the status of Section View.

9. Dynamic Gnomon: The on-screen gnomon allows you to manipulate views and planes interactively. The
gnomon comprises three axes connected at the origin, with selection points that let you choose different types
of transformations.

10. Managers: Managers include controls for toolpaths, solids, planes, levels, recent functions, and Art. The
Managers can be rearranged to suit your workflow.

l Toolpaths Manager: Lists the toolpath groups andmachine types for the current file. Use the
ToolpathsManager to control your operations.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



l Solids Manager: Lists each solid in the current file along with its operation history and associated
toolpaths. Use the SolidsManager to edit solids and their operations.

l Planes Manager: Shows the planes in the current file. Use the PlanesManager to adjust planes and
work offsets.

l Levels Manager: Shows the levels in the current file. Use the LevelsManager to control your levels.

You can learnmore about Managers in "Moving and DockingManagers "on page 30.

11. Graphics window: The space in which you view, create, andmodify your parts. The graphics window also
displays information about the current units (inches or millimeters), and the coordinate axes for the current
view or plane.

12
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Common Interface Controls
The following table shows common controls used in the Mastercam interface. The iconsmay vary slightly depending
on their location inMastercam.

Icon Option Icon Option

OK and Create New Cancel

OK/Save Help

Apply About Mastercam

Exercise 2: Exploring Mastercam's Backstage
The File drop-down inMastercam is also known as the Backstage. Click File to open the Backstage view. The image
below shows the Info page of the Backstage with links on the left side to other pages and functions.

The following list provides brief descriptions of some of the functions and pages located in the Backstage. Click each
page to explore the Backstage.

l Info: Presents information and properties of the current Mastercam file. The Info page gives you access to
functions that take action on the currently open file, including: Project Manager, Change Recognition, Track
Changes, AutoSave, and Repair File.

l New: Opens a new file.

l Open: Accesses the Open page where you can select a recent document or browse for a file to open. You can
pin frequently used files or folders to the Recent Documents and Recent Folders sections.

l Open in Editor: Opens a file using a file editor of your choice.

l Merge: Imports andmerges entities froman existing part file into the current file.

l Save/Save As: Saves the current part file or saves the file with a newname. You can pin frequently used
folders to the Recent Folders section of the Save As page.

l Save Some: Saves only entities that you select in the graphics window.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



l Zip2Go: Creates a compressed *.ZIP, *.Z2G, or *.MCAM-CONTENT file of the current file that includes your
Mastercam configuration, machine definition, post files, tool andmaterial libraries and other necessary files. A
Zip2Go file is helpful when sharing file information with other users or Technical Support.

l Convert: Provides access to Import and Export functions, as well as the MigrationWizard so that you can update
older Mastercam files to the latest version.

l Print: Previews, configures, and prints the current Mastercam file.

l Help: Presents information about Mastercamand licensing. Includes links to the What’s New and ReadMe
documents, tutorials, and the Help system. Visit this page to check for software updates. Some functions
require an active Internet connection.

l Community: Links your account to Mastercam.com, MastercamUniversity, the MastercamCommunity App,
Mastercam Forums, MastercamKnowledge Base, the Customer Feedback Program, and satisfaction surveys.
These functions require an active internet connection.

l Configuration: Opens the System Configuration dialog box where you set systemdefaults for Mastercam.

l Options: Opens the Options dialog box where you customize the Mastercam interface.

Exercise 3: Customizing the Quick Access Toolbar
The Quick Access Toolbar (QAT) is a collection of frequently used functions. The QAT is always available and can be
displayed above or below the ribbon. You can add to or remove functions from the QAT.

In this exercise youmove and customize the QAT.

1. Click the Customize Quick Access Toolbar drop-down, and select Show Below the Ribbon.

14
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The QAT displays between the ribbon and the managers.

2. Click the drop-down again, and selectMore Commands.

The Options dialog box opens.

3. On the Quick Access Toolbar page, select View from the Choose commands from drop-down to see a list of
commands that appear in the View tab.

4. Select Redo in the right-hand pane. The command you add to the QATwill appear below this selection.
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5. Select Copy from the Commands list, and then click Add.

The command appears below the Redo command in the right-hand pane.

You can use the up and down arrows to rearrange the list.

16
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NOTE
The Commands list is in alphabetical order.

6. ClickOK, and the Copy command shows in the QAT.

Alternatively, you can add any command in the ribbon to the QAT by right-clicking the command in the ribbon
and selecting Add to Quick Access Toolbar.

7. Return the QAT to its placement above the ribbon.

Exercise 4: Using Mastercam Resources
Your Mastercam license gives you access to resources that can improve your project and advance your Mastercam
skills. Learn about usingMastercamand connect with the community to share ideas.

These resources include:

l My Mastercam: Connect to the Mastercam community to share ideas, get news, seek assistance, and
download the latest versions.

l Feedback: Give feedback about your Mastercamexperience.

l Help:Use Help to learn about Mastercam functions, gain information about parameters, and expand your
concept knowledge.
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l What's New and ReadMe documents: Read the What's New to learn about the latest features in a release and
the ReadMe to keep up-to-date on fulfilled enhancement requests.

l Tutorials: Bolster your Mastercam skills with step-by-step tutorials that lead you throughmany of Mastercam's
products.

In this exercise you visit each resource and explore the options available to you.

NOTE
Youmust have an internet connection to accessMy Mastercamand its associated links.

Using My Mastercam
1. ClickMy Mastercam to open the login dialog box.

2. Enter your credentials and click Login.

NOTE
If you do not have aMy Mastercamaccount, create one at https://users.mastercam.com/signup.

18
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Your My Mastercamaccount loads. Use this feature to quickly access the CAD/CAM community, Mastercam
downloads, and your personal account.

You can also use this feature to accessMastercam socialmedia sites.

3. Click outside of the account dialog box to close it.

Giving Feedback in Mastercam
1. Mastercamallows you to give feedback about your experience with the software. Select Feedback in the upper

right corner of Mastercam.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



The in-app feedback browser opens.

2. Follow the prompts to submit your feedback.

Using Mastercam Help
1. MastercamHelp is an excellent resource for learning about the software's functions. To access the Mastercam

Help Center, select the Help icon in the upper right corner of Mastercam.

NOTE
You can also access the MastercamHelp Center by selecting File, Help, Contents in Mastercam's
Backstage.

The MastercamHelp Center opens in your internet browser.

20

Mastercam Basics Tutorial—1: Mastercam Interface Overview



21

Use the MastercamHelp Center to access information about CAD/CAM topics and other Mastercam resources
such as the What's New, ReadMe, and tutorials. Click on each of the tiles to explore your options.

2. When you are done exploring the MastercamHelp Center, return to Mastercam.

3. Context-sensitive Help is related to the location in which you click the Help button. To view an example of
context-sensitive Help, click the Help icon in the Toolpaths Manager. Use context-sensitive Help topics to learn
about the purpose and options for the dialog box in which you clickHelp.

NOTE
If necessary, select the Toolpaths tab of the Managers.
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4. In the topic, select Toolbar buttons.

The expanded Helpmenu drops down to identify and describe Mastercam interface icons. Drop-down headings
in Help topicsmay also describe menu options and procedures.

When usingMastercam, context-sensitive help is an excellent resource for learningmore about interface
options.

22
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5. Scroll down to the bottomof the topic to review the links in the Learn more section. This section is located at
the bottomof each help topic with information about similar topics. Use these links to enhance your
understanding of CAD and CAM concepts.

6. When you are done exploring the Learn more links, return to Mastercam.

Exercise 5: Exploring the Ribbon Interface
The ribbon interface comprisesmultiple tabs that group together related functions and controls. Tabs are organized
in a simple-to-complex workflow from left to right.

Some tabs are contextual and only display when needed in the workflow. For instance, youmust select a piece of
wireframe geometry for theWireframe Selection contextual tab to display on the ribbon.

You can choose to show all available ribbon functions, or simplify your view by showing only the most commonly used
functions.

In this exercise you personalize the ribbon tabs.

1. Right-click the ribbon, and selectMinimize the Ribbon.

Only the tab names display in the interface.
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2. Click any tab to display it. Click in the graphics window to hide the tab again.

3. Right-click the ribbon and deselectMinimize the Ribbon to show the tabs again.

4. Open BLANK_PART.mcam, which was provided with this tutorial. If you see amessage for switching units from
inch to metric, clickOK to allow the change.

5. Select the geometry shown below.

6. TheWireframe Selection contextual tab displays. This tab containsMastercam functions relevant to your
selected wireframe geometry.

7. Press [Esc] to deselect the geometry in the graphics window.

TheWireframe Selection contextual tab disappears from the ribbon.

24
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8. Select the Drafting tab.

9. Click the Ribbon mode drop-down. Ribbon mode alters the number of functions displayed on the ribbon.

l Standard: All Ribbon functions display.

l Simplified: The most commonly used Ribbon functions display. Some of the more complex Analyze
functions, Drafting functions, Curve and Line functions, Delete functions, and View options are no
longer available. Wire andMill-Turn are not available in Simplifiedmode.

10. Select Simplified. The number of functions on the Drafting tab changes. Mastercam remembers your Ribbon
mode selection between sessions.

11. Return Ribbon mode to Standard.

Exercise 6: Customizing the Ribbon
You can create a new ribbon tab and customize it with functions of your choice. In this exercise, you create a new tab,
add several functions, and change the tab's position on the ribbon.
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1. Right-click the ribbon, and select Customize the Ribbon.

The Options dialog box opens.

2. If necessary, highlight View in the Customize the Ribbon list.
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3. ClickNew Tab.

New Tab (Custom) andNew Group (Custom) appear in theMain Tabs list.

4. SelectNew Tab (Custom) and then click Rename.
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5. EnterMy Tab for the Display Name and clickOK.

6. Right-clickNew Group (Custom) and select Rename from the context menu.

7. EnterMy Group in the Display Name field and clickOK.

8. Select Pan from the Commands Not in the Ribbon list, and then click Add.

NOTE
Type to jump to a command in the Choose commands from list box.

28
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The command is added toMy Group (Custom).

9. Select Zoom Target from the Commands Not in the Ribbon list, and then click Add.

The command is added toMy Group (Custom).

10. SelectMy Tab (Custom), and use the up arrowbutton to position the tab below the Home tab.

11. ClickOK to close the Options dialog box.

Mastercam Basics Tutorial—1: Mastercam Interface Overview



12. ChooseMy Tab to view your customized tab with the Pan and Zoom Target commands.

13. On your own, return to the Options dialog box to addmore commands to your tab, or rearrange the order of
the ribbon tabs.

Exercise 7: Moving and Docking Managers
Mastercamhas severalmovable, dockable managers that provide flexible access to frequently used functions
including toolpaths, solids, planes, levels, and recent functions.

You can toggle the display of the managers, as well asmove one or more managers to a new location. Docking
behavior follows standardWindows controls. Dock amanager to a fixed location on the interface, float it anywhere on
the workspace, or evenmove it to another monitor. Mastercam remembers the settings even after you close the
application.

In this exercise, you customize the Mastercam interface by hiding, displaying, andmoving the managers.

1. Select File, New to start with a newpart file. Select Don't Save if you are prompted to save changes to the
current Mastercampart file.

2. Click the Toolpaths tab to bring the ToolpathsManager to the front.

3. Hide the ToolpathsManager by clicking the Close button in its upper right corner.
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4. Re-display the ToolpathsManager by choosing Toolpaths in theManagers group on the View tab.

NOTE
The Recent Functions panel is not amanager, but it resides in the same location as the Managers for ease
of use. Recently used functions are recorded and can be repeated by selecting them from the Recent
Functions list.
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5. Select the title bar of the Toolpaths Manager, and drag the panel of managers into the graphics window.

The managers are now floating in the graphics window.

6. Click and drag the managers again. Drop themonto the blue docking icon on the right side of the interface.

NOTE
Docking icons snap the managers into alignment with the graphics interface. Hover the stack of managers
over a docking icon to see a preview of the new location.
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All of the managers are nowdocked in the new location.
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7. Click the Planes tab, and drag and drop it anywhere on the workspace (except on a docking icon).

8. Resize the PlanesManager by clicking and dragging any of its edges.

9. Double-click the PlanesManager's title bar to redock it on top of the stack of managers.

10. Click the title bar of the stack of managers, and drag it to the left side of the graphics window, where it was
docked at the beginning of this exercise.

If you work withmultiple monitors, you can position the managers onto the monitor that is not running
Mastercam to free the entire graphics window for drawing.

34
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Exercise 8: Setting Entity Attributes in the Current File
Entity attributes control point and line styles, as well as the colors associated with entity types you create in
Mastercam. You can change the attributes of selected entities in the graphics window two ways:

1. Use the controls on the Home tab.

2. Use the right-click mini-toolbar.

When nothing is selected in the graphics window, you can also set entity attributes for the current file using these
controls. To set entity attributes that persist between sessions, use the Colors and CAD pages of the System
Configuration dialog box.

In this exercise, you use the attributes controls located on the mini-toolbar.
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1. Select File, New to start with a newpart file. If prompted to save BLANK_PART.mcam, choose Don’t Save.

2. Right-click the graphics window to open the mini-toolbar and context menu.

3. Select Toggle Attributes Panel on the mini-toolbar.

The mini-toolbar nowdisplays independent of the right-click menu. You can resize and position the mini-toolbar
anywhere in the graphics windowor anywhere on your desktop.

4. With nothing selected in the graphics window, click the Line Style drop-down, and choose the style shown
below.

Any newgeometry you create uses the line style you select.

36
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5. Select the Line Width shown below.

Newgeometry you create uses the line width you select.

6. Click theWireframe Color drop-down, and select green as shown below.

7. On theWireframe tab, choose Rectangle.

The Rectangle function panel opens.
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8. Click in the graphics window and draw two rectangles of any size. Follow the prompts in the graphics window.

9. ClickOK.

Your rectangle wireframe geometry is created.

10. Hold down your left mouse button and drag to draw awindow around one rectangle in the graphics window.

38
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Mastercam selects the rectangle.

11. Click theWireframe Color drop-down and select purple.

Only the rectangle you selected changes to purple.

The default wireframe color does not change on the mini-toolbar. Any newwireframe geometry you create still
uses the default color, which is green.
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12. With nothing selected in the graphics window, set the Line Style to the option shown below. This resets it to
default.

13. Set the Line Width to the default option shown below.

14. Set theWireframe Color to the default blue shown below.

15. Select Toggle Attributes Panel to return the mini-toolbar to the right-click menu.

16. Click File, Save. Name your file ATTRIBUTES.mcam, and save it in the same location as the other tutorial files.

40
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Exercise 9: Understanding the Selection Bar and AutoCursor
The Selection Bar combines tools used to select entities in the graphics window and AutoCursor controls. The
Selection Bar is located across the top of the graphics window. It has twomodes, Standard Selection and Solid
Selection, which are activated based on the function you are using.

AutoCursor controls allow you to detect and snap to points as youmove the cursor over geometry in the graphics
window. AutoCursor becomes active whenever Mastercamprompts you to select a position in the graphics window.

In this exercise, you locate points and lines using AutoCursor and Fast Point mode. Use Fast Point Mode when
AutoCursor is active to input X, Y, Z coordinates to set an endpoint.

1. If necessary open the file, ATTRIBUTES.mcam, that you saved from the previous lesson.

2. On theWireframe tab, select Line Endpoints.

The Line Endpoints function panel opens, andMastercamprompts you to specify the first endpoint.

NOTE
If you are usingmultiple monitors, the prompt may appear on a different monitor.
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3. Click the AutoCursor drop-down and selectMidpoint.

4. Click anywhere on the top line of one of your rectangles and drag up to draw a line.

Mastercamuses the midpoint of the entity that you selected as the first endpoint.

5. Click to set the second endpoint.

42
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6. Select OK in the Line Endpoints function panel.

7. Press [F9] to show the coordinate axes in the graphics window.

8. On theWireframe tab, select Circle Center Point.

The Circle Center Point function panel opens, andMastercamprompts you to enter the center point.
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9. Select AutoCursor Fast Point on the Selection Bar to display the Fast Point field. You can enter numbers,
formulas, or X,Y,Z coordinates.

NOTE
You can also press the spacebar to display Fast Pointmode.

10. Type 0,0,0 to enter the coordinate location of the circle’s center point, and then press [Enter].

11. Drag and click to set the radius of the circle. The center point is 0,0,0.

44
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12. Choose OK in the Circle Center Point function panel.

13. If the entities are outside of the graphics window, right-click and choose Fit.

14. Press [F9] again to hide the coordinate axes.

15. Save your file.

Exercise 10: Using Quick Masks
Mastercam’sQuick Masks allow you to select all entities of a specific type, or to select only entities of a specific type.
Most controls are divided in half. Clicking the left or right side of the control toggles between all/only selectionmodes.
You can select multiple Quick Masks. Hover over each control to view the tooltip describing its function.

In this exercise, you select entities using severalQuick Mask functions.

1. If necessary click File, Open and open ATTRIBUTES.mcam, which you saved in the previous lesson.

2. Click Clear all masking.

3. Click Select all line entities.
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Mastercam selects the rectangles and line that you drew in the previous exercise.

4. Click Clear selection to deselect the line entities.

5. Click Select only arc entities.

46
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6. Click and drag to window select all entities in the graphics window.

Mastercam selects only the arc.

If there had been arcs outside of the selection window, Mastercamwould not have selected them. The Select
only side of quick mask buttons only selects geometry inside of the selection window.
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7. Click Clear selection.

8. Click Select all entities by color.

The Select All dialog box opens.

9. Select the blue color checkbox, and then clickOK.

NOTE
Notice that Select only arc entities and Select only wireframe entities remain selected from the
previous steps and affect the outcome.

48
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Mastercam selects only the circle because it is the only blue arc entity.

10. Select Clear all masking.

11. Save your file.

Exercise 11: Exploring the Status Bar
The Status Bar across the bottomof the Mastercamworkspace displays the XYZ coordinates of the cursor in the
workspace. It also provides quick access to the 2D/3D switch and lets youmodify the Cplane, Tplane, WCS, and Z Depth
of geometry and toolpaths in the graphics window. The right side of the Status Bar contains wireframe, shading, and
translucency controls.

In this exercise, you use the wireframe, shading, and translucency controls to change the appearance of a part.

1. Open BRACE.mcam, which was provided with the tutorial. If you see amessage for switching units from inch to
metric, clickOK to allow the change.
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2. ChooseWireframe on the Status Bar.

3. Choose No Hidden on the Status Bar.
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The part displays only the wireframe that is visible in the current view. No hidden wireframe is visible.

4. Choose Outline Shaded and Translucency on the Status Bar.
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The part displays as a translucent solid.

You can also alter how a part displays using the Appearance options located on the View tab.

5. Close Mastercamwithout saving your changes or leave the part open for the next exercise.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learnmore about
Mastercam configuration files.
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CHAPTER 2

WORKING WITH CONFIGURATION FILES
The System Configuration dialog box defines andmanages the configuration files that store Mastercam’s settings.
You can change your system configuration or create a new configuration at any time. It is easy to switch fromone
environment to another because each configuration is saved to a separate file.

In this chapter, you change options in the System Configuration dialog box to see the different kinds of settings that
are stored within one configuration file.

Goals

l Create a configuration file.

l Change system colors and CAD styles.

l Modify the size and opacity of on-screen controls.

l Set up AutoSave and Backup.

Exercise 1: Creating a Configuration File
In this exercise, you create a configuration file (.config).

1. Press [Ctrl + N] to create a new file.

If prompted to save your work from the last chapter, select Don't Save.

2. Select File, Configuration.
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The System Configuration dialog box opens.

3. If necessary, selectmcamxm.config <Metric> from the Current drop-down to enable the metric
configuration.

4. Click Save As in the lower left corner.

The Save As dialog box opens.

5. Enter Tutorialconfig for the File name.
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6. Click Save.

Mastercam creates a new .config file. You can create multiple .config files using the same method.

In the following exercises, you save system settings to this configuration file.

Exercise 2: Changing System Colors
In this exercise, you change some default colors to customize Mastercam’s interface and geometry colors.

1. In the System Configuration dialog box, select the Colors page.

2. SelectWireframe geometry from the list.

Wireframe geometry is assigned to color 1.

3. Type 163 for the Color value, and press [Enter].
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Wireframe geometry you create nowuses this color.

4. Select Background (gradient start) from the list.

Background (gradient start) is assigned to color 111.

5. Select white from the color options on the right side of the dialog box.

The start of the gradient background is nowwhite.

6. Deselect Use gradient background to remove the gradient from the background.

NOTE
The drop-down list next toDirection allows you to set gradient direction whenUse Gradient background
is selected.

7. Click Apply to save the settings on this page and leave the System Configuration dialog box open.
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8. Choose Yes to save all current settings to the Tutorialconfig.config file.

Choosing Yes preserves your changes. They are in effect every time you openMastercam. If you choose No,
the changes are in effect only until you close Mastercam.

Exercise 3: Changing CAD Settings
In this exercise, youmake changes to the CAD page. The CAD page specifies design defaults, such as default line and
spline attributes.

1. Select the CAD page.

2. In the Default attributes section, select the Line style shown below.

Wireframe geometry you create nowuses this line style.

Mastercam Basics Tutorial—2: Working with Configuration Files



3. Select the Line width shown below.

Wireframe geometry you create nowuses this line width.

4. ClickOK in the System Configuration dialog box.

5. Click Yes to save all current settings to the Tutorialconfig.config file.

6. On theWireframe tab, select Rectangle.

The Rectangle function panel opens.

7. Follow the prompts to create a rectangle, and then clickOK in the Rectangle function panel.

The line style and width of the geometry matches the selections in the CAD page, as well as the geometry color
set in the Colors page.
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Exercise 4: Changing the Size and Opacity of On-screen Controls
In this exercise, you set the size of the on-screen gnomons and text and change the opacity of the Selection Bar and
Quick Mask buttons.

1. Click File, Configuration to open the System Configuration dialog box.

2. Select the Screen page.

3. Enter 1.5 for Scale display gnomons and text and press [Enter].

The size of the elements in the graphics window is increased to 150%.

4. Move the Selection controls opacity slider from left to right.

This option adjusts the opacity of the Selection Bar andQuick Masks. Watch as the opacity changeswith the
slider movement, and choose an opacity setting you like. The first image below shows the slider set to 50%
opacity and the second image shows the slider set to 100% opacity.
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5. Click Apply to save the settings on this page.

6. Select Yes to save the settings to the configuration file.

Exercise 5: Setting up AutoSave and Backup
When you are working on a part, Mastercam can save your work automatically at intervals that you specify. You can
also save versions of your files as backups. In this exercise, you set up these functions.

1. Expand the Files category, and select the AutoSave / Backup page.

2. In the AutoSave / Backup page, do the following:

l Select AutoSave to activate the AutoSave options.

l Enter 10 for Interval (in minutes).

l SelectMastercam Backup Files to activate the backup options.

Mastercamwill save your work automatically every tenminutes and keep the tenmost recent versions
of your file.

3. Select the Files page to view the location of your backup files.
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4. Choose Backup files (Mastercam format) in the Data paths list. The path displays in the Selected item box
as shown below.

5. Selectmcamxm.config <Metric> from the Current drop-down to enable the metric configuration for the
remainder of this tutorial.

6. ClickOK.

NOTE
If you would like to learnmore about the individual settings on any System Configuration page, click the Help
button located in the lower right-hand corner of the dialog box.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learn how to
customize the Mastercamworkspace.
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CHAPTER 3

CUSTOMIZING MASTERCAM
In this chapter, you learn how to customize your Mastercamworkspace, including tab and interface options, the
graphics window context menu, and keyboard shortcuts. Your settings apply each time you openMastercamand are
not specific to a configuration file.

Goals

l Customize the graphics window context menu.

l MapMastercam functions to keyboard shortcuts.

l Set display options for tabs and interface colors.

Exercise 1: Customizing the Graphics Window Context Menu
In this exercise, you customize the graphics window context menu that displays when you right-click in the graphics
window. Customizing thismenu allows you quick access to your commonly used functions.

1. Select File, Options.

The Options dialog box opens.

2. Select the Context Menu page.

Categories of functions are displayed on the left side of the dialog box, while the right side contains the
functions currently in the context menu.
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3. Right-click the last item in the Context Menu list, and select Insert Separator to place a line of separation after
the item.

A separator line appears after the last item.

4. Select File from the Category drop-down list.
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5. Select the Save As function in the Category list and SEPARATOR in the Context Menu list.

6. Click Add to add the Save As function after the separator.

7. ClickOK to save these changes to the right-click menu.
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8. Right-click in the graphics window to see the updated context menu.

Save As has been added to the bottomof the menu.

Exercise 2: Mapping Functions to Keyboard Shortcuts
In this exercise, youmap aMastercam function to a shortcut key.

1. Select File, Options.

The Options dialog box opens.

2. On the Quick Access Toolbar page, select Customize next to Keyboard shortcuts.

The Customize Keyboard dialog box opens.
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3. Select Home from the Categories list.

The Commands list populates with functions from the Home tab.

4. Select Statistics from the Commands list.

Notice that the Current Keys list is blank. This is because there are no shortcut keys assigned to this function.

5. Click in the Press new shortcut key field, and press [Ctrl+Shift+H] to create a new shortcut key.

6. Select Assign to map this shortcut key to the Statistics function.

7. Select Close to exit the Customize Keyboard dialog box, and thenOK to close the Options dialog box.
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8. In the graphics window, press [Ctrl+Shift+H] to access the Statistics function.

The Statistics dialog box displays a summary of the entities in the current file, including total number of visible
entities by type, and the number of operations and tools. In this example, Statistics reports four lines because
of the rectangle created in the previous lesson.

9. ClickOK to close the dialog box.

Exercise 3: Setting Mastercam Display Options
In this exercise, you set some of Mastercam’s display options.

1. Select File, Options.

The Options dialog box opens.

2. Select the Options page.

3. Select Large icons.
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4. Set Theme to Colorful and Accent color to Green.

5. ClickOK to close Options. Mastercamuses the larger icons and green theme.

6. Click File, Options, and return the options to the original settings.

7. Close Mastercamwithout saving your changes or leave the file open for the next exercise.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learnmore about
working with files.
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CHAPTER 4

WORKING WITH FILES
Mastercamnot only saves and loads its own file types (.mcx-*, .mcam), but also many common file formats, including the
following:

l SOLIDWORKS

l AutoCAD

l ProE/Creo

For the full list of available formats, refer to the Mastercamwebsite (mastercam.com/support/technical-
support/translators/). Load and save native Mastercam files by selectingOpen, Save, Save As, or Save Some from
the Backstage menu or from the QAT.

You can also open files by:

l Dragging aMastercam file or third-party compatible file fromWindows Explorer and dropping it in Mastercam’s
graphics window.

l Dragging and dropping a file onto the Mastercamdesktop icon to open a new instance of Mastercam.

Goals

l Open a non-Mastercam file.

l Export aMastercam file.

l Use Zip2Go files.
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Exercise 1: Opening Non-Mastercam Part Files
Importing files fromother applications is similar to opening native Mastercam files. Depending on the file, youmight
need to specify howMastercam imports elements of the file. In this exercise, you convert a SOLIDWORKS (.sldprt) file
to aMastercampart. You do not need SOLIDWORKS to open or convert a SOLIDWORKS file.

1. Select File, Open. Select Computer, then Browse.

The Open dialog box displays. Browse to the tutorial parts folder.

2. In the Open dialog box, select SOLIDWORKS Files ("*.sldprt"; "*sldasm"; "*slddrw") from the drop-down.

The dialog nowdisplays only SOLIDWORKS parts.

3. Navigate to SW_PART.sldprt, which was provided with this tutorial.

4. Select Options.

The SOLIDWORKS File Parameters dialog box opens.
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You can use these options, which change based on the file type, to control how files are read into the
Mastercamdatabase.

5. Select OK without making changes.

6. Select Open in the Open dialog box.

Select Don’t Save if you are asked to save changes to the current Mastercam file.

Mastercam converts and opens the part.

7. ClickOutline Shaded and toggle Translucency off to view the part as a solid.
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The part displays as shown below.

You learnmore about the graphics window and views in later sections of the tutorial.
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NOTE
To learn about convertingmultiple non-Mastercam files at the same time, click File, Convert, Import
Folder. Select the help button in the Import Folder dialog box.

Exercise 2: Exporting a Single File
When exporting, youmight need to set a few options to guarantee a successful conversion of the file data for your
purposes. Inmost cases, you need only select the software package to which you are exporting the file. In this
exercise, you learn to convert aMastercam file to a different format.

1. Open 2D_CHAMFER_MM.mcam, which was provided with this tutorial. If prompted to save changes to the current
Mastercam file, select Don't Save.
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2. Select File, Save As, and then click Browse.

The Save As dialog box opens.

3. Select StereoLithography Files ("*.stl") from the Save as type drop-down list.

4. Select Options.

The Save as an STL File dialog box opens.
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5. Select the ASCII option.

6. ClickOK to close the Save as an STL File dialog box.

7. Click Save in the Save As dialog box.

8. Mastercam saves the file in ASCII StereoLithography format, which allows you to view it with any text editor,
such as Notepad, as shown below.
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NOTE
To learnmore about exportingmultiple Mastercam files at the same time, click File, Convert, Export
Folder. Select the help button in the Export Folder dialog box.

Exercise 3: Using Zip2Go
The Zip2Go utility gathers and compresses the current Mastercampart data into a .MCAM-CONTENT, .Z2G, or .ZIP file.
The Zip2Go utility scans the machine groups in your current file and captures information such as your Mastercam
configuration, machine definition, post files, tool andmaterial libraries, and other files associated with your part. This is
useful if you are trying to share information with other users or Technical Support.

For information about each file type, see the following table.

File Type Benefits

.MCAM-CONTENT
Can be dragged and dropped into Mastercam. This unzips the files to their proper location within
the default folder structure. To view the files inside, rename it to a .zip.

.Z2G and .ZIP
Can be unzipped by anyone to view contents. These maintain the original file structure inside the
compressed file.

In this exercise, you run Zip2Go to compress a file.

1. Open BRACE.mcam, which was provided with this tutorial.

If prompted to save changes to 2D_CHAMFER_MM.mcam, choose Don't Save.
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2. If necessary, clickOutline Shaded on the Status Bar to view the part as a solid.

3. Select File, Zip2Go.

Mastercam Basics Tutorial—4: Working with Files



The Zip2Go dialog box opens.

The file list displays information about the files that will be saved in the Zip2Go archive. You can also select files
that you want, and deselect files that you do not want to include in the compressed file. For this tutorial, keep
the default settings.

4. Select File, Options in the Zip2Go dialog box.
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The Options dialog box opens.

Use this dialog box to configure the default settings for Zip2Go.

5. Set the Default output folder to your \Documents folder if it is not already set.

6. ClickOK to accept the defaults and close the Options dialog box.

7. Select Create File.

The Save file dialog box opens.

8. By default, Mastercam creates a zipped file with a .ZIP extension in the selected folder. Change the file type to
.Z2G in the Save as type drop-down.

9. Select Save.
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The Zip2Go file list displays the files included in the Zip2Go file.

10. ClickOK to close the Zip2Go dialog box.

11. Close Mastercamwithout saving your changes or leave the file open for the next exercise.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learnmore about
viewing your part.
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CHAPTER 5

VIEWING YOUR PART
Mastercamprovides several tools andmethods for changing the appearance of the geometry and toolpaths in the
graphics window. In this chapter, you learn to view your part, use materials, analyze your part, and create and use
Viewsheets.

Goals

l Fit all entities in the graphics window.

l Use zoom functions to magnify your view of selected entities.

l Dynamically rotate and pan entities in the graphics window.

l Create a Viewsheet.

l Select materials.

l Analyze your part.

Exercise 1: Changing Standard Views
In this exercise, you learn how to look at your part fromdifferent sides and fit it to the graphics window.

1. Open ANGLEBLOCK-MM.mcam, which was provided with this tutorial. The part opens in Isometric (WCS) view.
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2. On the View tab, select the Show Axes drop-down. If necessary, deselectWorld, Cplane, and Tplane. Only
WCS remains selected.

3. On the View tab, select Show Axes or press [F9] to toggle the display of the WCS axes.

The coordinate axes show the origin and the part orientation to help you visualize the part in 3D space.

4. On the View tab, select the Show Gnomons drop-down and deselect Cplane and Tplane. OnlyWCS remains
selected.
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5. On the View tab, select Show Gnomons. The WCS gnomon displays. The text indicates that the WCS is set to the
Top plane, and the Cplane and Tplane are also set to Top.

6. On the View tab, select Top.

The part changes to show the Top WCS view.
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7. You can also use the right-click menu to change the view. Practice switching to other views using thismenu.

8. When finished, return the part to Isometric (WCS) view.

9. Click Show Gnomons to turn off the display of gnomons in the graphics window.

10. On the View tab, select Unzoom 80% to reduce the size of the part on the screen.

11. On the View tab, select Fit. You can also press [Alt+F1].
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The part now fills the entire graphics window.

NOTE
Fit and several other Zoom commands are also available in the right-click menu.

Exercise 2: Zooming In and Out
In this exercise, you practice different techniques for viewing areas of detail in your part.

1. Place your cursor in the upper left quadrant of the graphics window.

2. If your mouse has amiddle mouse wheel, spin it back and forth to dynamically zoom in and out. You can also
press the [Page Up] and [Page Down] keys on your keyboard to zoom in and out.

3. Click Fit or press [Alt+F1] to fit the part to the screen.
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4. On the View tab, selectWindow.

5. Click and drag awindow around the upper section of the part as shown below.

6. Click to set the zoomwindow. Mastercam scales the selected area to fit the entire graphics window.

7. Right-click the graphics window and choose Fit.
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8. Select the circle on the front of the angle block.

9. On the View tab, choose Selected from the Fit drop-downmenu.

The selected entity is scaled to fit the graphics window.

10. Press [Esc] to clear the selection.

11. Right-click in the graphics window and select Fit.
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Exercise 3: Rotating Your Part View
This exercise shows how to set the preference for the action that your middle mouse button or wheel performs in the
graphics window (rotate or pan). You also learn to dynamically rotate entities in the graphics window so that you can
see them fromany angle.

1. Select File, Configuration.

The System Configuration dialog box opens.

2. Expand the Screen group, and select View.

3. If necessary, setMiddle button/wheel to Rotate.

By choosing Rotate, Mastercam sets dynamic rotation as the primary function when you click and hold the
middle mouse button or mouse wheel.

4. ClickOK to close the System Configuration dialog box. If prompted to save the current settings to
configuration file, clickNo.

5. Set up the part in the graphics window, as follows:

a. Set the Gview to Front.

b. ClickUnzoom 80%.
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6. Middle-click in the graphics windowwhere indicated below and continue to hold down the middle mouse button
or wheel as youmove the mouse slowly in a circular motion.

This action rotates the part in space about the selected position and lets you see it fromany angle.

7. Let go of the middle mouse button/wheel to finish rotating the part.

The axes symbol (gnomon) in the graphics window changes as you rotate the part. The Gview name in the
graphics windowno longer displays because you are not in a standard view.

8. Return the view to Isometric, and fit the part to the screen.

You can also select Dynamic Rotation from the right-click menu and follow the on-screen prompts to rotate
the part.

Exercise 4: Panning Your Part
In this exercise, you change your view in the graphics windowby using shortcut keys.

1. Hold down the [Shift] key, middle-click in the graphics windowwhere indicated, and continue to hold down the
button/wheel while youmove the mouse up, down, side to side, and around.
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It appears that you have picked up the part and are moving it in the direction of the mouse. However, the
entities are not physically moved in space, only the display changes. The GView does not change as you pan the
entities.

2. Release the [Shift] key while still holding down the middle mouse button/wheel and you can rotate the part.
Press the [Shift] key again to return to panning.

3. When you finish panning, release the [Shift] key and the middle mouse button/wheel at the same time to exit
the function.

Exercise 5: Analyzing Your Part
Mastercam'sAnalyze functions allow you tomeasure distances between lines, arcs, points, angles, andmore.
Depending on the type of entity you analyze, these functions can provide information about the following:

l Entity type

l Coordinates

l Operations

l Measurements

l Associated toolpaths

The Analyze functions also allow you to edit features, such as the entity's name, measurement units, and levels.

In this exercise, you use the Analyze functions to view and edit the properties of your wireframe.
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1. Set your view to Isometric and press [Alt + F9] to showgnomons.

2. On the Home tab, select Analyze Entity.
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3. In the graphics window, select the line shown in the following image.

The Line Properties dialog box opens. Analyze Entity recognizes you have selected a line and shows
information such as the X / Y / Z endpoint coordinates, the angle, and the level.

NOTE
Analyze functions report position coordinates in relation to the Cplane origin.

4. Enter -1.0 in the Y position field for the start and end points.

5. Press [Enter].
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The line moves -1 units on the Y axis.

NOTE
Top-Level Editing allows you to adjust the geometry of your part fromwithin the graphics window. To learn
more about Top-Level Editing, visit the MastercamHelp Center.

6. From the Style drop-down, select the option shown below.

The selected line changes to dashed. You can also change its level, color, and width. Use this function to adjust
units and precision as well.

7. Click Cancel or press [Esc] to exit the Analyze Entity function. If you select OK, the changes are applied.
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8. On the Home tab, expand the Analyze Distance drop-down and select Analyze Distance Along Curve.

The Analyze Distance Along Curve dialog box appears.

9. Select the circle shown below.

The Analyze Distance Along Curve dialog box updates to show information about your selection. It lists the
distance along the curve and the angle information.
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You can use the Units and Precision drop-downs to adjust the measurements.

10. Press [Esc] to exit the function.

11. Press [Alt + F9] to turn off the gnomons.

Exercise 6: Using viewsheets
Mastercamallows you to view your part in different orientations by using viewsheets. Viewsheetsmake viewing a
large part easier, as you can set upmultiple viewsheets with different views. You can also create a bookmark for each
viewsheet.

A bookmark holds the settings for the view displayed in the viewsheet. When you save your part file, Mastercam
stores the viewsheet settings, including the bookmark, along with the part. Whenworking with your part, you can
restore the viewsheet to its saved view by restoring the bookmark.

In this exercise, you create a viewsheet.

1. If necessary, fit the part to the graphics window, and set the view to Isometric.

2. On the View tab, select On/Off to toggle viewsheets on.

Mastercam Basics Tutorial—5: Viewing Your Part



At the bottomof the graphics window, there is now a tab named Viewsheet #1. This is the main view of your
part and cannot be deleted.

3. On the View tab, selectNew from the New drop-down.

NOTE
You can also right-click Viewsheet #1 and selectNew Viewsheet from the menu.

4. Enter Viewsheet #2 and press [Enter] to accept the name.

Viewsheet #2 is created and displayed next to Viewsheet #1.
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5. Right-click in the graphics window, and select Right (WCS) to view the part from the right.

6. Select Viewsheet #1 again.

Notice that the view did not change on Viewsheet #1. Each viewsheet can contain different views and planes.

7. Right-click Viewsheet #1 and select Settings.
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The Viewsheet dialog box opens.

Use the Viewsheet dialog box to indicate which settings to save to the viewsheets. You can also access the
viewsheet settings on the Viewsheet page of System Configuration.

8. ClickOK to exit the Viewsheet dialog box without making changes.

Exercise 7: Using Materials
In this exercise, you use Mastercam'smaterial options to make your parts lookmore realistic.

1. Open the GPS SUCTION MOUNT.mcam file, which is included with this tutorial.

2. Press [F9] to hide the gnomon axes.

3. On the View tab, selectMaterial.
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4. In the graphics window, click the base of the part to select it.

5. On the Home tab, select the Set Material drop-down to display the material type gallery.
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6. In theMetal group, select theMetal Level 4 from the gallery.

The part's base changes to the selectedmaterial, a semi-reflective metal.
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7. Select the face of the clamp, as shown below.

8. On the Home tab, select the Set Material drop-down and select Plastic Level 7.
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9. Select the casing behind the clamp face, and choose Glass Level 3 from the Set Material drop-down.

10. Rotate and zoom in on the part to view the different types of material.

11. On the View tab, toggleMaterial on and off to see how the material options affect the part.

12. Before moving to the next exercise, ensure thatMaterial is toggled off.

Exercise 8: Managing Section Views
In this exercise, you use Mastercam's section views to show cross sections of a part.
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1. Load the file SPOOL BODY.mcam, which is included with this tutorial. If prompted to save
GPS SUCTION MOUNT.mcam choose Don't Save. If you see amessage for switching units, clickOK to allow the
change.

2. On the View tab, select Section View to toggle section views on.

Section views only show in the graphics windowwhen the feature is on.

3. Select the Planes tab to bring the PlanesManager to the front.

4. In the Top plane row, click in the Section column. An X indicates that a section view is created from the plane
when the Section View is on.
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Mastercamdisplays a cross section of the part, using Top as the clipping plane, as shown below.

5. On the View tab, click the Section View drop-down.

Use thismenu to select what types of entities are affected when using section views.
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6. From the Section View drop-downmenu, select Show Caps. Mastercamadds solid caps to the sectioned areas,
as shown below.

You can also access Section View from the PlanesManager's toolbar.

7. Close Mastercamwithout saving your changes or leave the file open for the next exercise.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learnmore about
levels.
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CHAPTER 6

WORKING WITH LEVELS
A Mastercam file can contain separate levels that include wireframe, solids, surfaces, drafting entities, and other part
data. Organizing your geometry by levels lets you control which areas of the part are visible and which entities you can
select in the graphics window.

This controlmakes it easier to work with the file and helps prevent you fromaffecting areas of the drawing you do not
want to change.

You can create and name asmany levels as you need and set any one to be the active, current working level. For each
level you create, you assign a unique number and, optionally, a name. Mastercam’s LevelsManager provides a central
location where you can view and create levels, and set their properties.

Goals

l Explore the LevelsManager.

l Modify the LevelsManager display options.

l Turn level displays off and on.

l Change the active level.

l Create a new level.

l Move selected entities to a different level.

Exercise 1: Exploring the Levels Manager
In this exercise, you explore the LevelsManager andmodify some display options.

1. Open LEVELS_PART.mcam, which was provided with the tutorial, and save it with a newname. If prompted to
save SPOOL BODY.mcam choose Don’t Save. If you see amessage for switching units, clickOK to allow the
change.
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2. Click the Levels tab.

If the Levels tab is not displayed, select Levels on the View tab to toggle the display.
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The LevelsManager shows all levels that are in the current part file, their display status, and the number of
entities per level.

A. The checkmark in the Number column indicates the current active level.

B. Settings for the active level display in this section.

C. Click any column heading to sort the levels grid. Click again to change the sort order.

D. Use these options to choose which levels are displayed in the grid.

3. Select Hide level properties to hide the property controls in the lower section of the LevelsManager and
maximize the space allotted to the levels grid.

4. Select Hide level properties again to show the controls at the bottomof the LevelsManager.
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5. Select Display options, Contrast rows to apply shading to every other rowused in the grid.

6. Select Display options and deselect Contrast rows to remove shading from the levels grid.

In the next exercise, you learn to toggle the display of different levels.

Exercise 2: Showing or Hiding Levels
In this exercise, you change the graphics windowdisplay by hiding and showing the levels. To select or otherwise work
with an entity in the graphics window, the level it occupiesmust be visible.

1. In the Visible column for the 2: Solid level, click once to hide the level.

The part display in the graphics windowupdates accordingly.

2. Click again in the Visible column to display the solid.
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3. Try turning off the display of level 1: Wireframe.

When Active level is always visible is selected inDisplay options, you cannot hide the active level.

Turning off the display of the active level while you are working in that level is not recommended. However, it
may occasionally be necessary.

4. Select Display options, and deselect Active level is always visible.

5. Use Turn all levels off and Turn all levels on to toggle the display of all levels.

6. Select Active level is always visible again.

7. Make sure all levels are visible before continuing on to the next exercise.

Exercise 3: Changing the Active Level
Any geometry that you create is always placed on the active level. There can only be one active level at a time, but you
can change the active level as often as necessary to work with the part. In this exercise, you change the active level
using severalmethods.
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1. In the Levels Manager, click once in the Number column of level 2: Solid to set it as the active level. A
checkmark indicates that it is now the active level.

NOTE
The level field located on the Home tab also shows that level 2: Solid is the active level.

2. On the Home tab, select the Level drop-down and select 1 : Wireframe to make it the active level.

In the LevelsManager, a checkmark appears in the Number column for level 1.

3. In the LevelsManager, turn off the visibility of level 2: Solid.
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4. Position the cursor anywhere in the row for level 2: Solid, right-click and chooseMake active.

A checkmark appears in the Number column for level 2.

Level 2: Solid is also visible because the LevelsManager display option Active level is always visible is
selected.

Exercise 4: Creating a Level and Assigning Entities
In this exercise, you create and name a level, and then assign entities to that level.

1. In the LevelsManager, select Add a new level.

Mastercamadds a new level to the LevelsManager grid and sets it as the active level.
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2. Enter Tutorial for the Name.

The LevelsManager grid updates to show the newname. Although level names are optional, descriptive names
are helpful.

3. Make level 1: Wireframe the active level.

4. Use the Display options in the lower section of the Levels Manager to control the visibility of levels.

l ClickUsed and notice that level 3: Tutorial is no longer visible because there are no entities assigned to
it.

l ClickUsed or named to restore visibility of all levels.

5. Make level 3: Tutorial the active level.
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6. On theWireframe tab, select Point Position.

The Point Position function panel opens.

7. Click a few times in different places in the graphics window to create points.

8. ClickOK in the Point Position function panel to exit the function.

9. In the LevelsManager, verify that the newgeometry was created on level 3: Tutorial. The number of entities
is not 0.
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Your number of pointsmay be different than what is shown.

10. Practice turning level displays on and off and changing the main level.

When you are ready, turn on the visibility for all levels and continue with the next exercise.

Exercise 5: Moving Entities to a Different Level
In this exercise, you create a new level by moving entities fromone level to another. You can use the same basic
procedure to copy entities to a different level.

1. In the LevelsManager, enter 4 in the Number field, and then enter Labels for the Name.

The new level, 4: Labels becomes the active level.

2. Make level 1: Wireframe the active level.

3. On the Home tab, select Change Level.

Mastercamprompts you to select which entities to move.
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4. In the graphics window, choose the Select all advanced Quick Mask.

The Select All dialog box displays.

5. In the Select All dialog box, do the following:

a. Select the Entities checkbox.

b. ExpandDrafting and select Labels.
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6. ClickOK.

In the graphics window, Mastercamhighlights all of the labels, indicating that they are selected.

7. Press [Enter] or choose End Selection.

The Change Levels dialog box opens.

NOTE
You can also use general selectionmethods to pre-select entities before choosing the Change Level
option. When you pre-select entities, Mastercamdoes not prompt you to select additional entities and you
advance directly to the Change Levels dialog box.

8. In the Change Levels dialog box, do the following:

a. SelectMove.

b. Deselect Use Active Level to allow the entities to be moved to any level.
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c. Enter 4 for Number.

9. Press [Enter].

10. In the LevelsManager, verify that level 4: Labels now contains the four label entities that were on level 1. Level
1: Wireframe contains four fewer entities.

11. Save your part.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learnmore about
views and planes.
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CHAPTER 7

UNDERSTANDING VIEWS AND PLANES
Mastercam locates your work in three-dimensional space. Thismeans that geometry and toolpath positions are
expressed in terms of three coordinate axes: X, Y, and Z. Each axis has a positive and negative direction.

In previous chapters, you learned about standard views and planes. In this chapter, you learnmore about creating
your own planes and using them for geometry creation.

Goals

l Understand views and planes.

l Customize the PlanesManager.

l Adjust follow rules.

l Create a newplane using the dynamic gnomon.

l Create a newplane using the PlanesManager.

l Use a newplane for geometry creation.

Views and Planes
You use views and planes inMastercam for many drawing andmachining purposes.

A plane is any two-dimensional slice of a 3D coordinate system. Examples of planes include the XY plane in a 3D
coordinate system, or a face of your part, no matter its angle.

A view is a plane with an origin and orientation. For example, the Left side view and Right side view are both aligned
with the same plane; but a clockwise arc in one view is a counterclockwise arc in the other view.

Mastercam includes a number of pre-defined views, which you explored in "Understanding Views and Planes"above.
These include Top, Front, Right, Isometric, and others.

The work coordinate system (WCS) refers to the alignment of the coordinate system itself. You can choose to align the
coordinate systemaxeswith any plane you wish. When this happens, youmap the XY plane to the plane of the view.
The origin of the view becomes your new (0,0,0) point. The view becomes the Top plane in the newworking
coordinate system.

If you would like to learnmore about the work coordinate system, try the Mastercam Work Coordinate System Tutorial
located onwww.mastercam.com/en-us/Support/Tutorials.

This section introduces some ways planes are used and some ways to access them. You can use views and planes for
three main functions:

l Graphic views (Gviews)—A Gview determines the angle fromwhich you are looking at the part in the
graphics window.

l Construction planes (Cplanes)—When you drawgeometry, the Cplane is the plane in which the geometry is
created. This does not have to be the same as the Gview. For example, you can look at your part in Isometric
Gview, while drawing geometry in the Front Cplane.
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l Tool planes (Tplanes)—This is the plane that is typically normal to the tool axis. Tplanes are only used when
creating toolpaths. Tool planes determine the tool orientation. In almost all cases, your Cplane will be the same
as your Tplane (the most common exceptions are mill/turn operations).

You use the PlanesManager to select, edit, create, andmanage planes.

Exercise 1: Exploring the Planes Manager
In this exercise, you open the PlanesManager and experiment with display options.

1. Open BRACE.mcam, which was provided with the tutorial. Save the file with a newname.

2. Select the Planes tab to bring the PlanesManager to the front.

If the Planes tab is not displayed, select Planes on the View tab to toggle the display.

3. In the PlanesManager, select Show Gnomons.

The gnomon for the currently selected plane displays in the graphics windowwhether or not the Planes
Manager has focus. Additionally, if the Display column is selected for a particular plane, the gnomonwill also
display.
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4. Click the Follow rules drop-down and select the options shown in the following image. With these settings,
when you change the Gview of a plane, the Cplane and Tplane follows.

5. Click in the G column of the Bottom plane to set the Gview to bottom. Note that Cplane and Tplane follow the
Gview as directed by the follow rules.

6. From the Follow rules drop-down, deselect Cplane follows Gview.
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7. Click in the G column of the Top plane to set the Gview to Top. Note that Cplane and Tplane no longer follow the
Gview, as directed by the new follow rules.

8. Click the Follow rules drop-down, and reselect Cplane follows Gview.

9. Click in the G column of the Iso plane to return the Gview to Isometric. Note that Cplane and Tplane remain in
the Top plane as the follow rule, Cplane = Top in Iso Gviews is selected.

10. Select Show Gnomons to toggle it off.

Exercise 2: Creating a New Plane Using the Dynamic Gnomon
In this exercise, you create a newplane using the dynamic gnomon. When creating a newplane using thismethod, the
gnomon is initially oriented to the current Gview.

1. On the View tab, select the Show Axes drop-down and selectWCS, Cplane and Tplane.

2. Toggle Show Axes on.

3. On the View tab, selectWindow.
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4. Draw a box around the area of the part shown below and click to zoom into the window.

5. In the lower left corner of the graphics window, hover over the Dynamic Gnomon.
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6. Click and drag the gnomon so that it matches the orientation shown below. Click to set the position.

The New Plane function panel opens.

7. To change the orientation of the Dynamic Gnomon, hover over the blue arc until the dial appears.
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8. Click the blue arc and rotate the gnomon fromwithin the dial until it is at 90 degrees. Click to set the location.
(Rotating within the compass snaps in angular increments.)

Or, you can enter 90 in the on-screen edit field, and press [Enter] twice.

9. In the New Plane function panel, enter DYNAMIC PLANE for the Name.

10. ClickOK to close the New Plane function panel.

11. DYNAMIC PLANE appears in the PlanesManager. Click in the CPlane column of DYNAMIC PLANE.
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The Cplane and Tplane axes indicate the location of the newplane origin as shown below.

Exercise 3: Creating a New Plane Using Planes Manager
In this exercise, you used PlanesManager to create a newplane aligned with the slanted face of the part. You add it to
the list of systemplanes.

1. Press [F9] to turn off the axes.

2. Press [Alt + F1] to fit your part to the graphics window.

3. In the PlanesManager, select Create a new plane, From solid face.
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4. Select the slanted face of the part, shown below:

The Select plane dialog box opens.

5. In the Select plane dialog box, click the arrows to cycle through the possible planes. For most applications, it
make sense to have +Z pointing away from the part.
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6. Cycle to the plane shown below.

7. Click Save this plane and exit in the Select plane dialog box.

The New Plane function panel opens.

8. In the New Plane function panel, enter the following:

a. Enter FACE OF PART for Name.

b. Select Cplane for Set As.
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9. Under the Origin group, click Reselect to return to the graphics window to choose a newpoint for the origin.

10. Select the point at the lower-right corner of the face.

11. ClickOK in the New Plane function panel to create a plane. Your newplane, FACE OF PART, displays in the
planes grid.
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Exercise 4: Using a Custom Plane for Drawing Geometry
In this exercise, you create geometry using the newCplane. You see that the newplane determines the orientation of
the geometry. You then set the Gview to the newplane.

1. In the Planes Manager, click in theWCS column for the FACE OF PART plane.

2. On theWireframe tab, select Circle Center Point.

3. The Circle Center Point function panel opens.
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4. On the Selection Bar, select Origin from the AutoCursor drop-down.

5. In the Circle Center Point function panel, enter 80.0 for Radius and then clickOK.

6. On the View tab, select Show Axes. If necessary, click the drop-down and ensure that all options are selected.
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7. The axes that define each view display in a different color. Since Cplane and Tplane are the same, the axes
display as dotted lines. Experiment by turning individual sets of axes on and off.
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8. In the PlanesManager, click in the G column of the FACE OF PART plane to set the Gview.

You are now looking straight down into the face of the part. The Gview is aligned with the customplane that you
just created.

9. Press [F9] to turn off the axes.

10. Save your part.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learnmore about
working with chain selection.
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CHAPTER 8

WORKING WITH CHAIN SELECTION
Chaining is the process of selecting and linking pieces of geometry. Use chains to create a toolpath, surface, or solid.
Chains are a subset of selection. However, chains are directional. Cutting tools follow the direction of the chain. The
following image shows a clockwise wireframe chain. The tool will move in the direction of the green arrow.

There are twomodes for chaining: wireframe and solid. The mode determines the selection options that are available
to you. Wireframe chains are typically used when youwish to create a toolpath without first creating the associated
solid. Solid chains are used on solidmodels.

Goals

l Use curve all edges to create wireframe froma solid.

l Explore wireframe chaining.

l Create andmodify solid chains.

NOTE
This chapter requires aMill machine. If your Mastercam license does not allow access to Mill, you can either:

l DownloadMastercamDemo/HLE and use it to complete the exercise:
https://signup.mastercam.com/demo-hle. Note that you will not be able to complete Exercise 5 with
Demo/HLE.

l Read through the exercise.

Exercise 1: Creating Wireframe from a Solid
In this exercise, you use curve all edges to create wireframe for a solid.

1. Open the file SOLID CHAINS.mcam, which is included with this tutorial, and use Save As to save it with a newname.
If you see amessage for switching units, clickOK to allow the change.
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2. In the Levels Manager, select Add a new level.

Level 2 appears and becomes the active level. Note that it has 0 entities. The solid body has remained on level 1.

3. On theWireframe tab, select Curve All Edges.

The Curve On All Edges function panel opens.

4. Window select your entire part.

5. Click End Selection.

6. ClickOK in the Curve On All Edges function panel.
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The solid body has awireframe outline.

7. In the Levels Manager, hide level 1.

The solid body is no longer visible. The wireframe remains.
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8. Save your part.
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Exercise 2: Exploring Wireframe Chaining
In this exercise, you explore wireframe chainingmethods.

1. On theMachine tab, selectMill, Default.

This sets your machine type, which is the first step in creating a toolpath. You will create a complete toolpath in
the next chapter. For this chapter, you will follow the first steps of toolpath creation in order to practice
chaining.

2. On the Toolpaths contextual tab, select Contour from the 2D gallery. If you are not using aMill, select any
toolpath available to your machine that brings up theWireframe Chaining dialog box.
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TheWireframe Chaining dialog box opens.

3. Check thatWireframe and 3D are selected beneathMode. These options allow you to select wireframe entities
defined in the X,Y, and Z axes.

4. Be sure that Chain is selected under Selection Method.
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Selectionmethodsmake it easier to select the desired geometry. For example, when Chain is selected in 3D
mode, Mastercampauses chaining at all branches and prompts you to select the next entity.

5. Click the line shown below.

A chain appears with three arrows:

l Green appears at the start of the chain and shows the direction of the cutting tool.

l Red shows the default chaining direction.

l Blue shows alternate chaining directions.

These arrows allow for guided chaining. Guided chaining uses the Next, Previous, and Adjust buttons to
control your chain.

NOTE
You can customize your chain-related colors in the Colors page of the System Configuration dialog box.

Mastercam Basics Tutorial—8: Working With Chain Selection



6. Click the Next button twice to continue your chain around the base of the wireframe.

Each time you clickNext, the chain continues in the default direction indicated by the red arrow.

7. In theWireframe Chaining dialog box, click Adjust.

Adjust changes your default chaining direction. The red arrow of your chain switches direction.
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8. ClickNext. Your chain continues up the corner edge of the wireframe.

9. To undo the most recent addition to the chain, click Previous.

10. Click Reverse to switch the direction of your chain, as well as the start and end points.

NOTE
When chaining to create a toolpath, clicking Reverse changes the start point of your toolpath and direction
of your cutting tool.
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11. Press [Esc] and clickNo to exit the toolpath function.

Exercise 3: Exploring Solid Chaining
In this exercise, you create and edit a solid chain.

1. On the Levels tab, make level 1 active and visible. Click in the Visible column of 2 to make the level not visible.

2. On the Toolpaths contextual tab, select Contour from the 2D gallery. If you are not using aMill, select any
toolpath available to your machine that brings up the Solid Chaining dialog box.

148

Mastercam Basics Tutorial—8: Working With Chain Selection



149

The Solid Chaining dialog box opens. It sharesmany similarities with theWireframe Chaining dialog box.

The default selectionmodes for solid chaining are Loop and Face.

3. Deselect Loop so that only Face is active.
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4. Select the four faces in the following image.

The green arrow appears on the last chain created.

5. ClickDisplay all selection arrows.

A green arrow appears to indicate the direction of each chain.

6. Select Reverse to reverse the direction of all selected chains.
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7. ClickUnselect to get rid of the selected chains.

8. Change the selectionmethod to Loop. Be sure to deselect Face.

9. Hold down [Ctrl] and click on the edge shown below.

[Ctrl + click] allows you to select matching holes or fillets on a part. All circles on the same face as the original
selection become chained.
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10. ClickOK to accept the chains.

The 2D Toolpaths - Contour dialog box opens. This is where you programa toolpath. You can also edit chains
here.

11. Click Select chains under Chain geometry.

Chain Manager opens.
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12. Expand Solid Chain 1 and select the first Loop. Yellow arrows identify the loop on the part.

13. Right-click the first Loop and select Reverse.

The first loop is reversed. The othersmaintain their original chaining direction.
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Use the right-click drop-down in Chain Managerwhen youwant to analyze, edit, name, andmake other
changes to your chains.

14. ClickOK to accept the new chains.

You return to the 2D Toolpaths - Contour dialog box. After chaining, the next step in toolpath creation is to
set parameters. You will do this in the next chapter.

15. Click Cancel to exit the dialog box.

16. SelectNo to discard your toolpath.

17. Save your part.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learnmore about the
creating toolpaths.
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CHAPTER 9

INTRODUCTION TO TOOLPATHS
As a CAD/CAM program, Mastercamallows you to create both the geometry and toolpaths needed tomachine your
part and achieve your project goals. Toolpaths are the routes along which the cutting tool is instructed to travel. To
effectively meet the needs of users, Mastercam is capable of creating toolpaths that range from simple to complex.

For example, the following image shows a 2D milling toolpath.

One of the most important features of Mastercam is associativity. Associativity is the link between the part and the
toolpath. When the part changes shape or moves, the associated toolpaths adapt and change aswell. If there is a
design change with the part, associativity makes it so the toolpaths just need to be recalculated, as opposed to
completely reprogrammed.

To create toolpaths, input specific information such as the machine type, tool specifications, and size and shape of your
material. You also select a toolpath type and set the feeds and speeds at which your part will be machined.

Mastercam takes this information and post processes it. This turns it into G-code (sometimes known as NC-code) to be
read by a CNCmachine. Depending on the type of machine and your part, this processmay be entirely automated or
may require occasional assistance from the machine operator.

Goals

l Choose amachine and set up stock.

l Select a toolpath and geometry.

l Set parameters.
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l Backplot and verify.

l Post the part file.

NOTE
This chapter requires aMill machine. If your Mastercam license does not allow access to Mill, you can either:

l DownloadMastercamDemo/HLE and use it to complete the exercise:
https://signup.mastercam.com/demo-hle. Note that you will not be able to complete Exercise 5 with
Demo/HLE.

l Read through the exercise.

Exercise 1: Selecting a Machine and Setting Up Stock
In this exercise, you select amachine type and set up your stock.

Eachmachine type allows access to toolpaths specific to that machine. Selecting amachine is the first step in setting up
a toolpath. Once amachine is selected, you set up the stockmaterial boundaries. Setting up stock enters the
dimensions and location of your initial material.

1. If necessary, open the part you created in "WorkingWith Chain Selection"on page 139.

2. Go to the Toolpaths Manager.Machine Group-1 is present because you selected aMill machine during the
chapter on selection. Machine groups organize your cutting operations by machine.

3. Expand Properties - Mill Default.

4. Click Stock setup.

Stock is the material fromwhich your part will be cut.

TheMachine Group Properties dialog box opens.
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When creating a toolpath, use the tabs in this dialog box to:

l Select machine files, tool and operations libraries, and operation defaults.

l Set feed calculation, material type, and toolpath numbering.

l Configure stock shape, origin, and wireframe.

5. Click Bounding box. This function creates a boundary around selected entities in the graphics window.

The Bounding Box function panel opens.
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6. Select the part and click End Selection.

7. In the Size section of the Bounding Box function panel, change X to 12.1 and Y to 8.1.

This adds a small amount of material to your stock in the X and Y directions. Although your stock values would
ultimately be defined based on the actual stock that you have available, for the purposes of this exercise we
only want to skim off a small amount of material.

8. ClickOK in the Bounding Box function panel.

9. ClickOK in theMachine Group Properties dialog box.

The outline of the stock displays in the graphics windowby default.
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Exercise 2: Choosing a Toolpath and Geometry
In this exercise, you choose a toolpath and chain associated geometry.

1. On theMill Toolpaths contextual tab, select Contour from the 2D group.

The Solid Chaining dialog box opens.

2. In the Solid Chaining dialog box, check that Solids and 3D are selected in theMode group. In the Selection
Method group, check that Loop and Face are selected. These options allow you to chain the desired geometry.
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3. Select the chain shown in the following image.

A green directional arrow appears. This arrow shows the direction the tool will follow. Typically, you want the
cutter to move in a clockwise direction so that it will be on the left side of the chain. This is not the case in the
following image.

4. If necessary, select Reverse to reverse the direction of the arrow so that the part is to the right side of the
green arrow.

Your part is now to the right of the green arrow. Your cutter will be on the left side of the chain.
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5. ClickOK in the Solid Chaining dialog box.

The 2D Toolpaths - Contour dialog box opens. This is where you program your toolpath.
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Exercise 3: Programming a Toolpath
In this exercise, you program your toolpath by selecting a tool and setting parameters.

1. Click the Tool page in the 2D Toolpaths - Contour dialog box.

2. Click Filter.

The Tool List Filter dialog box opens. Use this to filter your tools by type.

3. SelectNone to clear filters. Choose Endmill1 Flat from Tool Types.

4. ClickOK.
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5. Click Select library tool.

The Tool Selection dialog box opens. All tools listed are endmills because they are filtered. Use the row
headers to sort tools by characteristics such as name, diameter, or flutes.

6. Select 1/2 Flat Endmill and clickOK.

You return to the 2D Toolpaths - Contour dialog box.

7. Select the Depth Cuts page.
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8. Select Depth cuts.

Depth cuts divide the total depth into separate depth cuts.

9. ChangeMax rough step to 0.2. This is the maximumamount of material removed with each rough cut.

10. Select the Linking Parameters page.

The Linking Parameters page defines howMastercam calculates heights and depths. These can be measured
in absolute, incremental, or associative values.

11. Select the check box next to Clearance. Clearance sets the height at which the toolmoves to and from the part.

12. Enter 2.00 and select Absolute for Clearance.
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13. Enter the following, as necessary, on the Linking Parameters page.

l Retract: Enter 0.25 and select Incremental to set the height that the toolmoves up before the next
tool pass. Incremental values are relative to other parameters of chained geometry.

l Feed plane: Enter 0.2 and select Incremental to set the height to which the tool rapids before
changing to the plunge rate to enter the part.

l Top of stock: The bounding box you created has pre-populated the Top of stock value to set the
height of the material in the Z axis. Select Absolute to measure from the origin 0,0,0.

l Depth: Enter 0 and select Incremental to set the finalmachining depth and the lowest depth that the
tool descends into the stock.

NOTE
You can explore the other pages, such asHolder, Lead In/Out, and Break Through. For this tutorial
those settings remain at default.

14. ClickOK. The toolpath information appears in the ToolpathsManager. Your 2D Contour toolpath appears in the
graphics window.
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NOTE
To edit your toolpath, click on Parameters. The 2D Toolpaths - Contour dialog box will re-open.

Exercise 4: Backplotting and Verifying
In this exercise, you use Classic Backplot to backplot a toolpath and use Mastercam Simulator to verify the toolpath.

Classic Backplot allows you to see a quick simulation of your toolpaths. Verify allows you to see amore detailed view of
your operations, including simulatedmaterial removal.

1. In the Toolpaths Manager, check that your 2D Contour operation is selected.

2. Click Backplot selected operations.

The following appear in the graphics window:

l Backplot dialog box: Controls the backplot display and allows you to save geometry or settings.

l Play bar: Adjusts the speed of the simulation and allows you to pause, play, and set stops.

l Tool and holder: Simulate the selected tool and holder.

NOTE
If you do not see the tool and holder, right-click in the graphics window and select Fit.

3. Click the Play button or press [R].
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The tool and holder follow the toolpath.

4. When the simulation has finished, change the simulation speed by adjusting the run speed slider.

5. Press [R] to view the adjusted simulation.

6. While the simulation is running, rotate your part. View the tool as it moves along the toolpath.
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ClickOK in the Backplot dialog box.

7. Reset your view to Isometric and Fit.

8. Select Verify selected operations.

Mastercam Simulator opens. Your tool, toolholder, and stock are visible in the graphics window.

9. Click Play.

Mastercam Simulator shows the path of your tool and holder. The stock updates asmaterial is removed from
the part.

10. Reset the simulation by clicking Start.
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11. Click Play and observe the information in theMove Info pane. One of the benefits of Mastercam Simulator is
that it gives youmore in-depth information about your operation.

12. Exit Mastercam Simulator.

Exercise 5: Post Processing
In this chapter you post process your part file.

Post processing, or posting, refers to the process by which the toolpaths in your part file are converted to a format
that can be understood by your machine tool's control (for example, G-codes). A program called a post processor, or
post, reads your part file and writes the appropriate NC code.

1. Click Select all operations.

2. Click Post selected operations to post the toolpaths for the selected operations. The post processor creates a
machine-readable NC program from the Mastercam file.
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The Post processing dialog box displays. The name of the post processor for the machine you have chosen
displays as the Active post field in read-only mode.

3. ClickOK. The Save As dialog box opens.

4. Name your NC file and click Save.

The file opens inMastercamCode Expert.
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The NC code specifies information such as stops, cutting coordinates, and tool changes. Block numbers appear
in front of each command. Code Expert allows you to sync operations, manually edit code, and switch NC
Configurations.

5. Exit Code Expert.

6. Save your part.
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CONCLUSION
Congratulations!You have completed the Mastercam Basics Tutorial!Now that you have mastered the skills in this
tutorial, explore Mastercam's other features and functions.

Youmay be interested in other tutorials that we offer. Mastercam tutorials are being constantly developed, and we
will addmore as we complete them. Visit our website, or select Help, Tutorials from the File tab.

Mastercam Resources
Enhance your Mastercamexperience by using the following resources:

l Mastercam Documentation—Mastercam installs a number of helpful documents for your version of software in
the Documentation folder of your Mastercam 2022 installation.

l Mastercam Help—AccessMastercamHelp by selectingHelp, Contents fromMastercam's File tab or by
pressing [Alt+H] on your keyboard.

l Mastercam Reseller—Your localMastercamReseller can help withmost questions about Mastercam.

l Technical Support—Our Technical Support department (+1 860-875-5006 or support@mastercam.com) is open
Monday through Friday from8:00 a.m. to 5:30 p.m. USA Eastern Standard Time.

l Mastercam Tutorials—We offer a series of tutorials to help registered users become familiar with basic
Mastercam features and functions. Visit our website, or select Help, Tutorials fromMastercam's File tab to see
the latest publications.

l Mastercam University—MastercamUniversity, an affordable online learning platform, gives you 24/7 access to
Mastercam trainingmaterials. Take advantage of more than 180 videos to master skills at your own pace and
help prepare for MastercamCertification. For more information onMastercamUniversity, please contact your
AuthorizedMastercamReseller, visit university.mastercam.com/, or email training@mastercam.com.

l Online Communities—You can find awealth of information at www.mastercam.com.

l Follow us on Facebook (www.facebook.com/Mastercam), Twitter (twitter.com/Mastercam), and
Instagram (www.instagram.com/mastercamcadcam/) for the latest tech tips andMastercamnews.

l See Mastercam in action on YouTube (www.youtube.com/user/MastercamCadCam).

l For more information on CNC Software, Inc., to find and apply to jobs, and connect with people using
Mastercam, visit us on LinkedIn (www.linkedin.com/company/cnc-software/).

l Registered users can search for information or ask questions on the MastercamWeb forum,
forum.mastercam.com, or use the MastercamKnowledgebase at kb.mastercam.com.

Contact Us
For questions about this or other Mastercamdocumentation, contact the Technical Documentation department by
email at techdocs@mastercam.com.
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