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Introduction
Welcome to the Mastercam Basics Tutorial. This tutorial helps you explore Mastercam’s interface and learn basic
concepts of the software. This tutorial includes the following:

l A broad look at the Mastercam interface

l An introduction to Mastercam’s File menu, also known as the Backstage

l An introduction to creating and managing levels and planes

l An exploration of solid and wireframe chaining

l An introduction to creating toolpaths

Tutorial Goals

l Understand basic Mastercam functions

l Customize a configuration file and Mastercam’s interface for your working style

l Chain geometry and create toolpaths for your part

l Manipulate Mastercam’s graphics window, levels, and planes to view your part

General Tutorial Requirements

WARNING:
This tutorial is for educational purposes only. We have not verified the values and settings in this tutorial
with our machines or tools. Do not use the values in this tutorial to cut parts without proper verification
and testing for your environment.

NOTE:
Screen colors in the tutorial pictures were modified to enhance image quality; they may not match your
Mastercam 2025 settings or the tutorial results. These color differences do not affect the exercises or your
results.

Estimated time to complete this tutorial: 5 hours

All Mastercam 2025 tutorials have the following general requirements:

l You must be comfortable using the Windows® operating system.

l If you are completing this tutorial using Mastercam Learning Edition, you will be unable to post code.

l Each lesson in the tutorial builds on the mastery of the preceding lesson's skills. We recommend that you
complete them in order.

l Additional files may accompany a tutorial. Unless the tutorial provides specific instructions on where to place
these files, store them in a folder that can be accessed from the Mastercam 2025 workstation, either with the
tutorial or in any location that you prefer.



l You will need an internet connection to view videos that are referenced in the tutorials. All videos can be
found on our YouTube channel: www.youtube.com/user/MastercamTechDocs

l All Mastercam tutorials require you to configure Mastercam to work in a default Metric or Inch configuration.
The tutorial provides instructions for loading the appropriate configuration file.

Mastercam 2025 •Mastercam Basics Tutorial
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Chapter 1

Mastercam Interface Overview
Mastercam’s ribbon interface is based on standard Windows design guidelines. The ribbon comprises familiar
controls, including a Quick Access Toolbar (QAT), tabs, contextual tab groups, galleries, buttons, and the Backstage.
It also features special on-screen controls, and movable, dockable Managers and function panels.

This section briefly touches on the elements that make up the Mastercam interface to give you a better
understanding of how to use these elements to create and machine your parts.

Goals

l Explore Mastercam's interface.

l Customize the Quick Access Toolbar.

l Access Mastercam resources.

l Configure entity attributes.

l Understand Selection Bar, AutoCursor, and Fast Point.

l Use Quick Masks.

l Explore the Status Bar.

Exercise 1: Exploring Mastercam’s Interface
Start Mastercam using your preferred method:

l Double-click Mastercam's desktop icon.

Or,

l Launch Mastercam from the Windows Startmenu.



The following image displays the elements that make up the Mastercam interface. The corresponding sections
provide brief descriptions of each element and its use.

1. Quick Access Toolbar (QAT): A customizable set of commonly used functions that are always available in the
interface. The QAT can be located above or below the ribbon.

2. Tab: Groupings of related controls. Tabs are organized in a simple-to-complex workflow from left to right.

3. Tab Group: A region of the tab that contains a set of related controls.

4. Contextual Tab: A tab that displays when you make a specific selection in Mastercam. A contextual tab
presents controls and commands relevant to your current activity.

5. Tooltip: A small window with descriptive text that displays when you hover over a command or control.

6. Selection Bar: A toolbar that combines AutoCursor controls and general selection tools used to select
entities in the graphics window. There are two selection modes, Standard Selection and Solid Selection, that
are activated based on the function you are using. AutoCursor controls allow you to detect and snap to
locations as you move the cursor over geometry in the graphics window. AutoCursor becomes active
whenever Mastercam prompts you to select a position in the graphics window.

7. Quick Masks: A group of controls that helps you to select all entities of a certain type, or to select only
entities of certain type. Most Quick Mask controls are divided in half. Clicking the left or right side of the
control toggles between selection modes. When a Quick Mask control is selected it highlights to indicate the
selection mask is on. You can toggle multiple Quick Masks at a time.

8. Status Bar: A bar across the bottom of the workspace that shows the coordinate position of the cursor and
provides quick access to modify planes, construction mode, and Z depth. The right side of the Status Bar has
wireframe, shading, and translucency controls that change the appearance of your part. The left side of the
Status bar indicates the number of selected entities and the status of Section View.

Mastercam 2025 •Mastercam Basics Tutorial
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9. GView Cube: An augmented and more graphical way to show part and plane orientation. Click directly on the
different faces and sides of the cube to control the view and on-screen orientation of your part. The Gview
cube is relative to the WCS by default.

10. Managers: Managers include controls for toolpaths, solids, planes, levels, recent functions, and Art. The
Managers can be rearranged to suit your workflow.

l Toolpaths Manager: Lists the toolpath groups and machine types for the current file. Use the
Toolpaths Manager to control your operations.

l Solids Manager: Lists each solid in the current file along with its operation history and associated
toolpaths. Use the Solids Manager to edit solids and their operations.

Chapter 1: Mastercam Interface Overview



l Planes Manager: Shows the planes in the current file. Use the Planes Manager to adjust planes and
work offsets.

l Levels Manager: Shows the levels in the current file. Use the Levels Manager to control your levels.

You can learn more about Managers in "Moving and Docking Managers" on page 30.

11. Graphics window: The space in which you view, create, and modify your parts. The graphics window also
displays information about the current units (inches or millimeters), and the coordinate axes for the current
view or plane.

Mastercam 2025 •Mastercam Basics Tutorial
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Common Interface Controls
The following table shows common controls used in the Mastercam interface. The icons may vary slightly
depending on their location in Mastercam.

Icon Option Icon Option

OK and Create New Cancel

OK/Save Help

Apply About Mastercam

Exercise 2: Exploring Mastercam's Backstage
The File drop-down in Mastercam is also known as the Backstage. Click File to open the Backstage view. The image
below shows the Info page of the Backstage with links on the left side to other pages and functions.

The following list provides brief descriptions of some of the functions and pages located in the Backstage. Click each
page to explore the Backstage.

l Info: Presents information and properties of the current Mastercam file. The Info page gives you access to
functions that take action on the currently open file, including: Project Manager, Change Recognition, Track
Changes, AutoSave, and Repair File.

l New: Opens a new file.

l Open: Accesses the Open page where you can select a recent document or browse for a file to open. You can
pin frequently used files or folders to the Recent Documents and Recent Folders sections.

l Open in Editor: Opens a file using a file editor of your choice.

l Merge: Imports and merges entities from an existing part file into the current file.

l Save/Save As: Saves the current part file or saves the file with a new name. You can pin frequently used
folders to the Recent Folders section of the Save As page.

Chapter 1: Mastercam Interface Overview



l Save Some: Saves only entities that you select in the graphics window.

l Zip2Go: Opens the Zip2Go Wizard. The Zip2Go Wizard compresses the currently open Mastercam part and its
associated files (configuration, machine definition, post files, tool libraries, etc.) into a .Z2G, .ZIP, or .MCAM-
CONTENT file. A Zip2Go file is helpful when sharing file information with other users or Technical Support.

l Convert: Provides access to import and export functions, as well as the Migration Wizard so that you can
update older Mastercam files to the latest version.

l Print: Previews, configures, and prints the current Mastercam file.

l Help: Presents information about Mastercam and licensing. Includes links to the latest What’s New and
Resolved Issues, tutorials, and the Help system. Visit this page to check for software updates. Access to some
of these resources requires an active Internet connection.

l Community: Links your account to Mastercam.com, Mastercam University, Mastercam Forums, Mastercam
Knowledge Base, and the Customer Feedback Program. These resources require an active internet
connection.

l Configuration: Opens the System Configuration dialog box where you set system defaults for Mastercam.

l Options: Opens the Options dialog box where you customize the Mastercam interface.

Exercise 3: Customizing the Quick Access Toolbar
The Quick Access Toolbar (QAT) is a collection of frequently used functions. The QAT is always available and can be
displayed above or below the ribbon. You can add to or remove functions from the QAT.

In this exercise you move and customize the QAT.

1. Click the Customize Quick Access Toolbar drop-down, and select Show Below the Ribbon.

Mastercam 2025 •Mastercam Basics Tutorial
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The QAT displays between the ribbon and the managers.

2. Click the drop-down again, and selectMore Commands.

The Options dialog box opens.

3. On the Quick Access Toolbar page, select View from the Choose commands from drop-down to see a list
of commands that appear in the View tab.

4. Select Redo in the right-hand pane. The command you add to the QAT will appear below this selection.

Chapter 1: Mastercam Interface Overview



5. Select Copy from the Commands list, and then click Add.

The command appears below the Redo command in the right-hand pane.

You can use the up and down arrows to rearrange the list.

Mastercam 2025 •Mastercam Basics Tutorial
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NOTE:
The Commands list is in alphabetical order.

6. Click OK, and the Copy command shows in the QAT.

Alternatively, you can add any command in the ribbon to the QAT by right-clicking the command in the ribbon
and selecting Add to Quick Access Toolbar.

7. Return the QAT to its placement above the ribbon.

Exercise 4: Using Mastercam Resources
Your Mastercam license gives you access to resources that can improve your project and advance your Mastercam
skills. Learn about using Mastercam and connect with the community to share ideas.

These resources include:

l myMastercam: Connect to the Mastercam community to share ideas, get news, seek assistance, and
download the latest versions.

l Feedback: Give feedback about your Mastercam experience.

Chapter 1: Mastercam Interface Overview



l Help: Use Help to learn about Mastercam functions, gain information about parameters, and expand your
concept knowledge.

l What's New and Resolved Issues: Read the What's New to learn about the latest features in a release and
the Resolved Issues to keep up-to-date on fulfilled enhancement requests.

l Tutorials: Bolster your Mastercam skills with step-by-step tutorials that lead you through many of
Mastercam's products.

In this exercise you visit each resource and explore the options available to you.

NOTE:
You must have an internet connection to access myMastercam and its associated links.

Using myMastercam
1. ClickmyMastercam to open the login dialog box.

2. Enter your credentials and click Login.

NOTE:
If you do not have a myMastercam account, create one at https://users.mastercam.com/signup.

Mastercam 2025 •Mastercam Basics Tutorial
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Your myMastercam account loads. Use this feature to quickly access the CAD/CAM community, Mastercam
downloads, and your personal account.

You can also use this feature to access Mastercam social media sites.

3. Click outside of the account dialog box to close it.

Giving Feedback in Mastercam
1. Mastercam allows you to give feedback about your experience with the software. Select Feedback in the

upper right corner of Mastercam.

Chapter 1: Mastercam Interface Overview



The in-app feedback browser opens.

2. Follow the prompts to submit your feedback.

Using Mastercam Help
1. Mastercam Help is an excellent resource for learning about the software's functions. To access the

Mastercam Help Center, select the Help icon in the upper right corner of Mastercam.

NOTE:
You can also access the Mastercam Help Center by selecting File, Help, Contents in Mastercam's
Backstage.

The Mastercam Help Center opens in your internet browser.

Mastercam 2025 •Mastercam Basics Tutorial
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Use the Mastercam Help Center to access information about CAD/CAM topics and other Mastercam
resources such as the What's New, Resolved Issues, and tutorials. Click on each of the tiles to explore your
options.

2. After exploring the Mastercam Help Center, return to Mastercam.

3. Context-sensitive Help is related to the location in which you click the Help button. To view an example of
context-sensitive Help, click the Help icon in the Toolpaths Manager. Use context-sensitive Help topics to
learn about the purpose and options for the dialog box in which you click Help.

NOTE:
If necessary, select the Toolpaths tab of the Managers.

Chapter 1: Mastercam Interface Overview



4. In the topic, select Toolbar buttons.

Mastercam 2025 •Mastercam Basics Tutorial
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The expanded Help menu drops down to identify and describe Mastercam interface icons. Drop-down
headings in Help topics may also describe menu options and procedures.

When using Mastercam, context-sensitive help is an excellent resource for learning more about interface
options.

5. Scroll down to the bottom of the topic to review the links in the Learn more section. This section is located at
the bottom of each help topic with information about similar topics. Use these links to enhance your
understanding of CAD/CAM concepts.

6. After exploring the Learn more links, return to Mastercam.

Exercise 5: Exploring the Ribbon Interface
The ribbon interface comprises multiple tabs that group together related functions and controls. Tabs are
organized in a simple-to-complex workflow from left to right.

Some tabs are contextual and only display when needed in the workflow. For instance, you must select a piece of
wireframe geometry for theWireframe Selection contextual tab to display on the ribbon.

You can choose to show all available ribbon functions or simplify your view by showing only the most commonly
used functions.

In this exercise you personalize the ribbon tabs.
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1. Right-click the ribbon, and selectMinimize the Ribbon.

Only the tab names display in the interface.

2. Click any tab to display it. Click in the graphics window to hide the tab again.

3. To redisplay the full-sized tabs, simply double-click any tab or right-click the ribbon and deselectMinimize
the Ribbon.

4. Open BLANK_PART.mcam, which was provided with this tutorial. If you see a message for switching units from
inch to metric, click OK to allow the change.

5. Select the geometry shown below.

Mastercam 2025 •Mastercam Basics Tutorial
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6. TheWireframe Selection contextual tab displays. This tab contains Mastercam functions relevant to your
selected wireframe geometry.

7. Press [Esc] to deselect the geometry in the graphics window.

TheWireframe Selection contextual tab disappears from the ribbon.

8. Select the Drafting tab.

9. Click the Ribbon mode drop-down. Ribbon mode alters the number of functions displayed on the ribbon.

l Standard: All Ribbon functions display.

l Simplified: The most commonly used Ribbon functions display. Some of the more complex Analyze
functions, Drafting functions, Curve and Line functions, Delete functions, and View options are no
longer available. Wire and Mill-Turn are not available in Simplified mode.

10. Select Simplified. The number of functions on the Drafting tab changes. Mastercam remembers your Ribbon
mode selection between sessions.
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11. Return Ribbon mode to Standard.

Exercise 6: Customizing the Ribbon
You can create a new ribbon tab and customize it with functions of your choice. In this exercise, you create a new
tab, add several functions, and change the tab's position on the ribbon.

1. Right-click the ribbon, and select Customize the Ribbon.

The Options dialog box opens.

2. Highlight View in the Customize the Ribbon list.

Mastercam 2025 •Mastercam Basics Tutorial
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3. Click New Tab.

New Tab (Custom) and New Group (Custom) appear in theMain Tabs list.

4. Select New Tab (Custom) and then click Rename.

Chapter 1: Mastercam Interface Overview



5. EnterMy Tab for the Display Name and click OK.

6. Right-click New Group (Custom) and select Rename from the context menu.

7. EnterMy Group in the Display Name field and click OK.

8. Select Pan from the Commands Not in the Ribbon list, and then click Add.

NOTE:
Type the first letter of the command to jump closer to it in the Choose commands from list box.

Mastercam 2025 •Mastercam Basics Tutorial
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The command is added toMy Group (Custom).

9. Select Zoom Target from the Commands Not in the Ribbon list, and then click Add.

The command is added toMy Group (Custom).

10. SelectMy Tab (Custom), and use the up arrow button to position the tab below the Home tab.

11. Click OK to close the Options dialog box.

Chapter 1: Mastercam Interface Overview



12. ChooseMy Tab to view your customized tab with the Pan and Zoom Target commands.

13. On your own, return to the Options dialog box to add more commands to your tab, or rearrange the order of
the ribbon tabs.

Exercise 7: Moving and Docking Managers
Mastercam has several movable, dockable managers that provide flexible access to frequently used functions
including toolpaths, solids, planes, levels, and recent functions.

You can toggle the display of the managers, as well as move one or more managers to a new location. Docking
behavior follows standard Windows controls. Dock a manager to a fixed location on the interface, float it anywhere
on the workspace, or even move it to another monitor. Mastercam remembers the settings even after you close the
application.

In this exercise, you customize the Mastercam interface by hiding, displaying, and moving the managers.

1. Select File, New to start with a new part file. Select Don't Save if you are prompted to save changes to the
current Mastercam part file.

2. Click the Toolpaths tab to bring the Toolpaths Manager to the front.

3. Hide the Toolpaths Manager by clicking the Close button in its upper right corner.

4. Re-display the Toolpaths Manager by choosing Toolpaths in theManagers group on the View tab.

Mastercam 2025 •Mastercam Basics Tutorial
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NOTE:
The Recent Functions panel is not a manager, but it resides in the same location as the Managers
for ease of use. Recently used functions are recorded and can be repeated by selecting them from
the Recent Functions list.
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5. Select the title bar of the Toolpaths Manager, and drag the panel of managers into the graphics window.

The managers are now floating in the graphics window.

6. Click and drag the managers again. Drop them onto the blue docking icon on the right side of the interface.

NOTE:
Docking icons snap the managers into alignment with the graphics interface. Hover the stack of
managers over a docking icon to see a preview of the new location.

Mastercam 2025 •Mastercam Basics Tutorial
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All of the managers are now docked in the new location.
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7. Click the Planes tab, and drag and drop it anywhere on the workspace (except on a docking icon).

8. Resize the Planes Manager by clicking and dragging any of its edges.

9. Double-click the Planes Manager's title bar to redock it on top of the stack of managers.

10. Click the title bar of the stack of managers, and drag it to the left side of the graphics window, where it was
docked at the beginning of this exercise.

If you work with multiple monitors, you can position the managers onto the monitor that is not running
Mastercam to free the entire graphics window for drawing.

Mastercam 2025 •Mastercam Basics Tutorial
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Exercise 8: Setting Entity Attributes in the Current File
Entity attributes determine point and line styles, as well as the colors associated with entity types you create in
Mastercam. You can change the attributes of selected entities in the graphics window two ways:

1. Use the controls on the Home tab.

2. Use the right-click mini-toolbar.

When nothing is selected in the graphics window, you can also set entity attributes for the current file using these
controls. To set entity attributes that persist between sessions, use the Colors and CAD pages of the System
Configuration dialog box.

In this exercise, you use the attribute controls located on the mini-toolbar.
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1. Select File, New to start with a new part file. If prompted to save BLANK_PART.mcam, choose Don’t Save.

2. Right-click the graphics window to open the mini-toolbar and context menu.

3. Select Toggle Attributes Panel on the mini-toolbar.

The mini-toolbar now displays independent of the right-click menu. You can size and position the mini-
toolbar anywhere in the graphics window or anywhere on your desktop.

4. With nothing selected in the graphics window, click the Line Style drop-down, and choose the style shown
below.

Any new geometry you create uses the line style you select.

Mastercam 2025 •Mastercam Basics Tutorial
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5. Select the Line Width shown below.

New geometry you create uses the line width you select.

6. Click theWireframe Color drop-down, and select green as shown below.

7. On theWireframe tab, choose Rectangle.

The Rectangle function panel opens.
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8. Click in the graphics window and draw two rectangles of any size. Follow the prompts in the graphics window.

9. Click OK.

Your rectangle wireframe geometry is created.

10. Hold down your left mouse button and drag to draw a window around one rectangle in the graphics window.

Mastercam 2025 •Mastercam Basics Tutorial
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Mastercam selects the rectangle.

11. Click theWireframe Color drop-down and select purple.

Only the rectangle you selected changes to purple.

The default wireframe color does not change on the mini-toolbar. Any new wireframe geometry you create
still uses the default color, which is green.
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12. With nothing selected in the graphics window, set the Line Style to the option shown below. This resets it to
default.

13. Set the Line Width to the default option shown below.

14. Set theWireframe Color to the default blue shown below.

15. Select Toggle Attributes Panel to return the mini-toolbar to the right-click menu.

16. Click File, Save. Name your file ATTRIBUTES.mcam, and save it in the same location as the other tutorial files.

Mastercam 2025 •Mastercam Basics Tutorial
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Exercise 9: Understanding the Selection Bar and AutoCursor
The Selection Bar combines tools used to select entities in the graphics window and AutoCursor controls. The
Selection Bar is located across the top of the graphics window and has two modes, Standard Selection and Solid
Selection, that are activated based on the function you are using.

AutoCursor controls detect and snap to points as you move the cursor over geometry in the graphics window.
AutoCursor becomes active whenever Mastercam prompts you to select a position in the graphics window.

In this exercise, you locate points and lines using AutoCursor and Fast Point mode. Use Fast Point Mode when
AutoCursor is active to input X, Y, Z coordinates to set an endpoint.

1. If necessary open the file, ATTRIBUTES.mcam, that you saved from the previous lesson.

2. On theWireframe tab, select Line Endpoints.

The Line Endpoints function panel opens, and Mastercam prompts you to specify the first endpoint.

NOTE:
If you are using multiple monitors, the prompt may appear on a different monitor.
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3. Click the AutoCursor drop-down and selectMidpoint.

4. Click anywhere on the top line of one of your rectangles and drag up to draw a line.

Mastercam uses the midpoint of the entity that you selected as the first endpoint.

5. Click to set the second endpoint.
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6. Select OK in the Line Endpoints function panel.

7. Press [F9] to show the coordinate axes in the graphics window.

8. On theWireframe tab, select Circle Center Point.

The Circle Center Point function panel opens, and Mastercam prompts you to enter the center point.
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9. Select AutoCursor Fast Point on the Selection Bar to display the Fast Point field. You can enter numbers,
formulas, or X,Y,Z coordinates.

NOTE:
You can also press the spacebar to display Fast Pointmode.

10. Type 0,0,0 to enter the coordinate location of the circle’s center point, and then press [Enter].

11. Drag and click to set the radius of the circle. The center point is 0,0,0.
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12. Choose OK in the Circle Center Point function panel.

13. If the entities are outside of the graphics window, right-click and choose Fit.

14. Press [F9] again to hide the coordinate axes.

15. Save your file.

Exercise 10: Using Quick Masks
Mastercam’s Quick Masks allow you to select all entities of a specific type or to select only entities of a specific type.
Most Quick Mask controls are divided in half. Clicking the left or right side of the control toggles between all/only
selection modes. You can select multiple Quick Masks. Hover over each control to view the tooltip describing its
function.

In this exercise, you select entities using several Quick Mask functions.

1. If necessary click File, Open and open ATTRIBUTES.mcam, which you saved in the previous lesson.

2. Click Clear all masking.

3. Click Select all line entities.
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Mastercam selects the rectangles and line that you drew in the previous exercise.

NOTE:
In Mastercam, a rectangle is a set of four lines.

4. Click Clear selection to deselect the line entities.

5. Click Select only arc entities.
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6. Click and drag to window select all entities in the graphics window.

Mastercam selects only the arc.

If there had been arcs outside of the selection window, Mastercam would not have selected them. The Select
only side of quick mask buttons only selects geometry inside of the selection window.
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7. Click Clear selection.

8. Click Select all entities by color.

The Select All dialog box opens.

9. Select the blue color checkbox, and then click OK.

NOTE:
Notice that Select only arc entities and Select only wireframe entities remain selected from the
previous steps and affect the outcome.
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Mastercam selects only the circle because it is the only blue arc entity.

10. Select Clear all masking.

11. Save your file.

Exercise 11: Editing Geometry from the Top-Level
If no other function is active, you can edit wireframe geometry without interacting with a dialog box. In Mastercam,
we call this top-level editing. In this exercise, you use this feature to edit lines and arcs in ATTRIBUTES.mcam.

Editing with line controls
1. If necessary click File, Open and open ATTRIBUTES.mcam, which you saved in the previous lesson.

2. Double-click a line. Since no other function is active, the line highlights with a combination of spheres and a
button.
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3. Toggle the button fromMove to Copy.

4. Click and drag the blue sphere to create an offset parallel line.
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5. Click and drag either of the endpoint spheres on the newly-created line to shorten, lengthen, or change the
angle of the line.

6. Hover over the green or red sphere to display its arrow.

7. Click the arrow to activate the ruler control. Type an exact value and press [Enter] twice to precisely change
the length of the line.

8. Press [Esc] to exit the function.

Editing with arc controls
1. Double-click the circle. Since no other function is active, it highlights with a combination of arrows and

buttons.
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2. Click and drag the origin sphere to move the center point of the circle.

3. Click and drag the green and the red arrows to change the sweep angle of the arc.

4. Hover over the red arrow and notice that Mastercam displays the absolute value of the sweep angle. In this
example, the absolute value is 195.00 degrees.

5. Toggle the ABS/REL button to change the display so that it shows the angle's relative value. This example
now shows the relative value is 143.02 degrees.
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6. Click and drag the blue arrow to change the radius of the arc. As with the line controls, you can type in an
exact value.

7. Click the Flip button to invert the arc and display its complement.

You cannot edit multiple entities with top-level editing. To do that, use the Analyze function. To display the Analyze
dialog box from the top-level, press the [End] key. You can continue to use the new graphic controls as well as
change entity attributes such as level, color, and line style. Press the [End] key again when you are finished. (The
section, "Analyzing Your Part" on page 97, later in this tutorial has more information about the Analyze function.)

8. Press [Esc] to exit the top-level editing function and save your part.
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Exercise 12: Exploring the Status Bar
The Status Bar across the bottom of the Mastercam workspace displays the XYZ coordinates of the cursor in the
workspace. It also provides quick access to the 2D/3D switch and lets you modify the Cplane, Tplane, WCS, and Z
Depth of geometry and toolpaths in the graphics window. The right side of the Status Bar contains wireframe,
shading, and translucency controls.

In this exercise, you use the wireframe, shading, and translucency controls to change the appearance of a part.

1. Open BRACE.mcam, which was provided with the tutorial. If you see a message for switching units from inch
to metric, click OK to allow the change.

2. ChooseWireframe on the Status Bar.

3. Choose No Hidden on the Status Bar.
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The part displays only the wireframe that is visible in the current view. No hidden wireframe is visible.

4. Choose Outline Shaded and Translucency on the Status Bar.
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The part displays as a translucent solid.

You can also alter how a part displays using the Appearance options located on the View tab.

5. Close Mastercam without saving your changes or leave the part open for the next exercise.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learn more about
Mastercam configuration files.
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Chapter 2

Working with Configuration Files
The System Configuration dialog box defines and manages the configuration files that store Mastercam’s settings.
You can change your system configuration or create a new configuration at any time. It is easy to switch from one
environment to another because each configuration is saved to a separate file.

In this chapter, you change options in the System Configuration dialog box to see the different kinds of settings
that are stored within one configuration file.

Goals

l Create a configuration file.

l Change system colors and CAD styles.

l Modify the size and opacity of on-screen controls.

l Set up AutoSave and Backup.

Exercise 1: Creating a Configuration File
In this exercise, you create a configuration file (.config).

1. Press [Ctrl + N] to create a new file.

If prompted to save your work from the last chapter, select Don't Save.

2. Select File, Configuration.



The System Configuration dialog box opens.

3. Click Save As in the lower left corner.

The Save As dialog box opens.

4. Enter Tutorialconfig for the File name.

5. Click Save.

Mastercam creates a new .config file. You can create multiple .config files using the same method.

In the following exercises, you save system settings to this configuration file.

Exercise 2: Changing System Colors
In this exercise, you change some default colors to customize Mastercam’s interface and geometry colors.
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1. In the System Configuration dialog box, select the Colors page.

2. Select Background (gradient start) from the list.

Background (gradient start) is assigned to color 111.

3. Select white from the color options on the right side of the dialog box.

The start of the gradient background is now white.

4. Deselect Use gradient background to remove the gradient from the background.
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NOTE:
The drop-down list next to Direction allows you to set gradient direction when Use Gradient
background is selected.

While you can change the defaults of many Mastercam interface colors on the Colors page, the Geometry Display
page customizes the colors for most types of Mastercam geometry.

5. If necessary, expand the Colors node on the left-side of the System Configuration dialog box, and select the
Geometry Display page.

6. SelectWireframe geometry from the list.

Wireframe geometry is assigned to color 1.
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7. Type 163 for the Color value, and press [Enter].

Wireframe geometry you create now uses this color.

8. Click Apply to save the settings on this page and leave the System Configuration dialog box open.

9. Choose Yes to save all current settings to the Tutorialconfig.config file.

Choosing Yes preserves your changes. They are in effect every time you open Mastercam. If you choose No,
the changes are in effect only until you close Mastercam.

Exercise 3: Changing CAD Settings
In this exercise, you make changes to the CAD page. The CAD page specifies design defaults, such as default line
and spline attributes.

1. Select the CAD page.
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2. In the Default attributes section, select the Line style shown below.

Wireframe geometry you create now uses this line style.

3. Select the Line width shown below.

Wireframe geometry you create now uses this line width.

4. Click OK in the System Configuration dialog box.

5. Click Yes to save all current settings to the Tutorialconfig.config file.
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6. On theWireframe tab, select Rectangle.

The Rectangle function panel opens.

7. Follow the prompts to create a rectangle, and then click OK in the Rectangle function panel.

The line style and width of the geometry matches the selections in the CAD page, as well as the geometry
color set in the Colors page.

Exercise 4: Changing the Size and Opacity of On-screen Controls
In this exercise, you set the size of the on-screen gnomons and text and change the opacity of the Selection Bar
and Quick Mask buttons.

1. Click File, Configuration to open the System Configuration dialog box.

2. Select the Screen page.
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3. Move the slider for the Cube/gnomon size to 3.

This option adjusts the size of the Gview cube. Watch as the size changes with the slider movement, and
choose the size setting that you like. Below, the image on the left shows the slider set to 3 and the image on
the right shows the slider set to 7.

4. Click OK to close the System Configuration dialog box, and select Yes to save your settings.

5. Right-click the GView cube and click Show Cube to toggle its display. Use the arrows on the left side and the
bottom of the GView cube to pan the display left or right.

6. Reopen the System Configuration dialog box.
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7. On the Screen page, move the Overlay controls opacity slider from left to right.

This option adjusts the opacity of the Selection Bar and Quick Masks. Watch as the opacity changes with the
slider movement, and choose an opacity setting you like. The first image below shows the slider set to 50%
opacity and the second image shows the slider set to 100% opacity.

8. Click Apply to save the settings on this page.

9. Select Yes to save the settings to the configuration file.

Exercise 5: Setting up AutoSave and Backup
When you work on a part, Mastercam can save your changes automatically at intervals that you specify. You can
also save versions of your files as backups. In this exercise, you set up these functions.

1. Expand the Files category, and select the AutoSave / Backup page.

2. In the AutoSave / Backup page, do the following:

l Select AutoSave to activate the AutoSave options.

l Enter 10 for Interval (in minutes).
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l SelectMastercam Backup Files to activate the backup options.

Mastercam will save your work automatically every ten minutes and keep the ten most recent
versions of your file.

3. Select the Files page to view the location of your backup files.

4. Choose Backup files (Mastercam format) in the Data paths list. The path displays in the Selected item box
as shown below.

5. At the bottom of the System Configuration dialog box, selectmcamxm.config <Millimeter> from the
Current drop-down to enable millimeter configuration for the remainder of this tutorial.

6. Click OK.

NOTE:
If you would like to learn more about the individual settings on any System Configuration page, click the
Help button located in the lower right-hand corner of the dialog box.
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You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learn how to
customize the Mastercam workspace.
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Chapter 3

Customizing Mastercam
In this chapter, you learn how to customize your Mastercam workspace, including tab and interface options, the
graphics window context menu, and keyboard shortcuts. Your settings apply each time you open Mastercam and
are not specific to a configuration file.

Goals

l Customize the graphics window context menu.

l Map Mastercam functions to keyboard shortcuts.

l Set display options for tabs and interface colors.

Exercise 1: Customizing the Graphics Window Context Menu
In this exercise, you customize the graphics window context menu that displays when you right-click in the graphics
window. Customizing this menu allows you quick access to your commonly used functions.

1. Select File, Options.

The Options dialog box opens.

2. Select the Context Menu page.

Categories of functions are displayed on the left side of the dialog box, while the right side contains the
functions currently in the context menu.



3. Select the last item in the Context Menu list, and click Insert Separator to place a line of separation after the
item.

NOTE:
You can also right-click the last item in the Context Menu list, and select Insert Separator from the
menu to place a line of separation after the item.

A separator line appears after the last item.

4. Select File Tab from the Choose commands from drop-down list.
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5. Select the Save As function in the Category list and SEPARATOR in the Context Menu list.

6. Click Add to add the Save As function after the separator.

7. Click OK to save these changes to the right-click menu.
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8. Right-click in the graphics window to see the updated context menu.

Save As has been added to the bottom of the menu.

Exercise 2: Mapping Functions to Keyboard Shortcuts
In this exercise, you map a Mastercam function to a shortcut key.

1. Select File, Options.

The Options dialog box opens.

2. On the Quick Access Toolbar page, select Customize next to Keyboard shortcuts.

The Customize Keyboard dialog box opens.
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3. Select Home from the Categories list.

The Commands list populates with functions from the Home tab.

4. Select Statistics from the Commands list.

Notice that the Current Keys list is blank. This is because there are no shortcut keys assigned to this function.

5. Click in the Press new shortcut key field, and press [Ctrl+Shift+H] to create a new shortcut key.

6. Select Assign to map this shortcut key to the Statistics function.

7. Select Close to exit the Customize Keyboard dialog box, and then OK to close the Options dialog box.
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8. In the graphics window, press [Ctrl+Shift+H] to access the Statistics function.

The Statistics dialog box displays a summary of the entities in the current file, including total number of
visible entities by type, and the number of operations and tools. In this example, Statistics reports four lines
because of the rectangle created in the previous lesson.

9. Click OK to close the dialog box.

Exercise 3: Setting Mastercam Display Options
In this exercise, you set some of Mastercam’s display options.

1. Select File, Options.

The Options dialog box opens.

2. Select the Options page.

3. Select Large icons.
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4. Set Theme to Colorful and Accent color to Green.

5. Click OK to close Options. Mastercam uses the larger icons and green theme.

6. Click File, Options, and return the options to the original settings.

7. Close Mastercam without saving your changes or leave the file open for the next exercise.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learn more about
working with files.
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Chapter 4

Working with Files
Mastercam not only saves and loads its own file types (.mcx-*, .mcam), but also many common file formats, including
the following:

l SOLIDWORKS (.sldprt, .sldasm, .slddrw)

l AutoCAD (.dwg, .dxf, .dwf)

l ProE/Creo (.prt, .asm)

For the full list of available formats, refer to the Mastercam website (mastercam.com/support/technical-
support/translators/). Load and save native Mastercam files by selecting Open, Save, Save As, or Save Some from
the Backstage menu or from the QAT.

You can also open files by:

l Dragging a Mastercam file or third-party compatible file from Windows Explorer and dropping it in
Mastercam’s graphics window.

l Dragging and dropping a file onto the Mastercam desktop icon to open a new instance of Mastercam.

Goals

l Open a non-Mastercam file.

l Export a Mastercam file.

l Use Zip2Go files.

https://www.mastercam.com/support/technical-support/translators/
https://www.mastercam.com/support/technical-support/translators/


Exercise 1: Opening Non-Mastercam Part Files
Importing files from other applications is similar to opening native Mastercam files. Depending on the file, you
might need to specify how Mastercam imports elements of the file. In this exercise, you convert a SOLIDWORKS
(.sldprt) file to a Mastercam part. You do not need SOLIDWORKS to open or convert a SOLIDWORKS file.

1. Select File, Open. Select Computer, then Browse.

The Open dialog box displays. Browse to the tutorial parts folder.

2. In the Open dialog box, select SOLIDWORKS Files ("*.sldprt"; "*sldasm"; "*slddrw") from the drop-down.

The dialog now displays only SOLIDWORKS parts.

3. Select SW_PART.sldprt, which was provided with this tutorial.

4. Select Options.

The SOLIDWORKS File Parameters dialog box opens.
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You can use these options, which change based on the file type, to control how files are read into the
Mastercam database.

5. Select OK without making changes.

6. Select Open in the Open dialog box.

Select Don’t Save if you are asked to save changes to the current Mastercam file.

Mastercam converts and opens the part.

7. Click Outline Shaded and toggle Translucency off to view the part as a solid.
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The part displays as shown below.

You learn more about the graphics window and views in later sections of the tutorial.
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NOTE:
To learn about converting multiple non-Mastercam files at the same time, click File, Convert,
Import Folder. Select the help button in the Import Folder dialog box.

Exercise 2: Exporting a Single File
When exporting, you might need to set a few options to guarantee a successful conversion of the file data for your
purposes. In most cases, you need only select the software package to which you are exporting the file. In this
exercise, you learn to convert a Mastercam file to a different format.

1. Open 2D_CHAMFER_MM.mcam, which was provided with this tutorial. If prompted to save changes to the
current Mastercam file, select Don't Save.
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2. Select File, Save As, and then click Browse.

The Save As dialog box opens.

NOTE:
You can also click the Save As button on the Quick Access Toolbar.

3. Select StereoLithography Files ("*.stl") from the Save as type drop-down list.

4. Select Options.

The Save as an STL File dialog box opens.
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5. Select the ASCII option.

6. Click OK to close the Save as an STL File dialog box.

7. Click Save in the Save As dialog box.

8. Mastercam saves the file in ASCII StereoLithography format, which allows you to view it with any text editor,
such as Notepad, as shown below.
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NOTE:
To learn more about exporting multiple Mastercam files at the same time, click File, Convert,
Export Folder. Select the help button in the Export Folder dialog box.

Exercise 3: Using Zip2Go
The Zip2Go Wizard gathers and compresses the current Mastercam part data into a .MCAM-CONTENT, .Z2G, or .ZIP
file. It scans the machine groups in your current file and captures information such as your Mastercam
configuration, machine definition, post files, tool and material libraries, and other files associated with your part.
This is useful if you are trying to share information with other users or Technical Support.

For information about each file type, see the following table.

File Type Benefits

.MCAM-CONTENT
Can be dragged and dropped into Mastercam. This unzips the files to their proper location
within the default folder structure. To view the files inside, rename it to a .zip.

.Z2G and .ZIP Can be unzipped by anyone to view contents. These maintain the original file structure inside
the compressed file.

In this exercise, you run the Zip2Go Wizard to compress a Mastercam part file and all the files associated with it into
an .Z2G file.

1. Open BRACE.mcam, which was provided with this tutorial.

If prompted to save changes to 2D_CHAMFER_MM.mcam, choose Don't Save.
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2. If necessary, click Outline Shaded on the Status Bar to view the part as a solid.

3. Select File, Zip2Go.
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The Zip2Go Wizard opens.

4. Click Create.

The File Options page displays information about the files that will be saved in the Zip2Go archive. Select the
file types that you want include and deselect file types that you do not want to include in the compressed file.
You can also remove specific files from the archive. For this tutorial, keep the default settings and files
selected.
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5. Click Next.
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TheManage Files page displays the files that Zip2Go will include in the package. On this page, you can
review, add files and folders, as well as remove specific files from the package.

6. Click Finish to display the Save As dialog box, where you can name the newly-compressed file package and
save it.

By default, Mastercam creates a zipped file with a .MCAM-CONTENT extension in the selected folder. Choose a
destination and change the file type to .Z2G in the Save as type drop-down.

7. Click Save.

Mastercam creates a compressed file in the destination folder.

8. Close Mastercam without saving your changes or leave the file open for the next exercise.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learn more about
viewing your part.
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Chapter 5

Viewing Your Part
Mastercam provides several tools and methods for changing the appearance of the geometry and toolpaths in the
graphics window. In this chapter, you learn to view your part, use materials, analyze your part, and create and use
Viewsheets.

Goals

l Fit all entities in the graphics window.

l Use zoom functions to magnify your view of selected entities.

l Dynamically rotate and pan entities in the graphics window.

l Create a Viewsheet.

l Select materials.

l Analyze your part.

Exercise 1: Changing Standard Views
In this exercise, you learn how to look at your part from different sides and fit it to the graphics window.

1. Open ANGLEBLOCK-MM.mcam, which was provided with this tutorial. The part opens in Isometric (WCS) view.



2. On the View tab, select the Show Axes drop-down. If necessary, deselectWorld, Cplane, and Tplane. Only
WCS remains selected.

3. On the View tab, select Show Axes or press [F9] to toggle the display of the WCS axes.

The coordinate axes show the origin and the part orientation to help you visualize the part in 3D space.

4. On the View tab, select the Show Gnomons drop-down and deselect Cplane and Tplane. OnlyWCS remains
selected.
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5. On the View tab, select Show Gnomons. The WCS gnomon displays. The text indicates that the WCS is set to
the Top plane, and the Cplane and Tplane are also set to Top.

6. On the View tab, select Top.

The part changes to show the Top WCS view.
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7. You can also use the right-click menu to change the view. Practice switching to other views using this menu.

8. When finished, return the part to Isometric (WCS) view.

9. Click Show Gnomons to turn off the display of gnomons in the graphics window.

10. On the View tab, select Unzoom 80% to reduce the size of the part on the screen.

11. On the View tab, select Fit. You can also press [Alt+F1].
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The part now fills the entire graphics window.

NOTE:
Fit and several other Zoom commands are also available in the right-click menu.

Exercise 2: Zooming In and Out
In this exercise, you practice different techniques for viewing areas of detail in your part.

1. Place your cursor in the upper left quadrant of the graphics window.

2. If your mouse has a middle mouse wheel, spin it back and forth to dynamically zoom in and out. Hold the
shift key to zoom faster. You can also press the [Page Up] and [Page Down] keys on your keyboard to zoom
in and out.

3. Click Fit or press [Alt+F1] to fit the part to the screen.
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4. On the View tab, selectWindow.

5. Click and drag a window around the upper section of the part as shown below.

6. Click to set the zoom window. Mastercam scales the selected area to fit the entire graphics window.

7. Right-click the graphics window and choose Fit.

Mastercam 2025 •Mastercam Basics Tutorial

94



95

8. Select the circle on the front of the angle block.

9. On the View tab, choose Selected from the Fit drop-down menu.

The selected entity is scaled to fit the graphics window.

10. Press [Esc] to clear the selection.

11. Right-click in the graphics window and select Fit.

Exercise 3: Rotating Your Part View
This exercise shows how to set the action that your middle mouse button or wheel performs in the graphics window
(rotate or pan). You also learn to dynamically rotate entities in the graphics window.
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1. Select File, Configuration.

The System Configuration dialog box opens.

2. Expand the Screen group, and select View.

3. If necessary, setMiddle button/wheel to Rotate.

By choosing Rotate, Mastercam sets dynamic rotation as the primary function when you click and hold the
middle mouse button or mouse wheel.

4. Click OK to close the System Configuration dialog box. If prompted to save the current settings to
configuration file, click No.

5. Set up the part in the graphics window, as follows:

a. Set the Gview to Front.

b. Click Unzoom 80%.

6. Middle-click in the graphics window where indicated below and continue to hold down the middle mouse
button or wheel as you move the mouse slowly in a circular motion.

This action rotates the part in space about the selected position and lets you see it from any angle.

Mastercam 2025 •Mastercam Basics Tutorial

96



97

7. Let go of the middle mouse button/wheel to finish rotating the part.

The axes symbol (gnomon) in the graphics window changes as you rotate the part. The Gview name in the
graphics window no longer displays because you are not in a standard view.

8. Return the view to Isometric, and fit the part to the screen.

You can also select Dynamic Rotation from the right-click menu and follow the on-screen prompts to rotate
the part.

Exercise 4: Panning Your Part
In this exercise, you change your view in the graphics window by using shortcut keys.

1. Hold down the [Shift] key, middle-click in the graphics window where indicated, and continue to hold down
the button/wheel while you move the mouse up, down, side to side, and around.

It appears that you have picked up the part and are moving it in the direction of the mouse. However, the
entities are not physically moved in space, only the display changes. The GView does not change as you pan
the entities.

2. Release the [Shift] key while still holding down the middle mouse button/wheel and you can rotate the part.
Press the [Shift] key again to return to panning.

3. When you finish panning, release the [Shift] key and the middle mouse button/wheel at the same time to exit
the function.

Exercise 5: Analyzing Your Part
Mastercam's Analyze functions allow you to measure distances between lines, arcs, points, angles, and more.
Depending on the type of entity you analyze, these functions can provide information about the following:

l Entity type

l Coordinates
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l Operations

l Measurements

l Associated toolpaths

The Analyze functions also allow you to edit features, such as the entity's name, measurement units, and levels.

In this exercise, you use the Analyze functions to view and edit the properties of your wireframe.

1. Set your view to Isometric and press [Alt + F9] to show gnomons.

2. On the Home tab, select Analyze Entity.
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3. In the graphics window, select the line shown in the following image.

The Line Properties dialog box opens. Analyze Entity recognizes you have selected a line and shows
information such as the X / Y / Z endpoint coordinates, the angle, and the level.

NOTE:
Analyze functions report position coordinates in relation to the Cplane origin.

4. Enter -1.0 in the Y position field for the start and end points.

5. Press [Enter].
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The line moves -1 units on the Y axis.

NOTE:
Top-Level Editing allows you to adjust the geometry of your part from within the graphics window.
To learn more about Top-Level Editing, see "Editing Geometry from the Top-Level" on page 49 in this
tutorial or visit the Mastercam Help Center.

6. From the Style drop-down, select the option shown below.

The selected line changes to dashed. You can also change its level, color, and width. Use this function to
adjust units and precision as well.

7. Click Cancel or press [Esc] to exit the Analyze Entity function. If you select OK, the changes are applied.
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8. On the Home tab, expand the Analyze Distance drop-down and select Analyze Distance Along Curve.

The Analyze Distance Along Curve dialog box appears.

9. Select the circle shown below.

The Analyze Distance Along Curve dialog box updates to show information about your selection. It lists the
distance along the curve and the angle information.
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You can use the Units and Precision drop-downs to adjust the measurements.

10. Press [Esc] to exit the function.

11. Press [Alt + F9] to turn off the gnomons.

Exercise 6: Using viewsheets
Mastercam allows you to view your part in different orientations with viewsheets. Viewsheets make viewing a large
part easier, as you can set up multiple viewsheets with different views.

Additionally, you can create a bookmark for individual viewsheets and/or create groups of multiple viewsheets. A
viewsheet bookmark holds the settings for the view displayed in the viewsheet. When you save your part file,
Mastercam stores the viewsheet settings, including the bookmark, along with the part. When working with your
part, you can restore the viewsheet to its saved view by restoring the bookmark.

In this exercise, you create a viewsheet.

1. If necessary, fit the part to the graphics window, and set the view to Isometric.

2. On the View tab, select On/Off to toggle viewsheets on.
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A tab named Viewsheet–1 appears at the bottom of the graphics window.

3. On the View tab, select New from the New drop-down.

Mastercam creates Viewsheet–2.

4. Right-click Viewsheet–2 and select Rename from the menu. Enter Right View and press [Enter] to accept
the name.
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5. Right-click in the graphics window, and select Right to view the part from the right.

6. Select Viewsheet–1 again.

Notice that this viewsheet still shows the isometric view. Each viewsheet can contain different views and
planes.
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7. Right-click Viewsheet–1 and select Settings.

The Viewsheet dialog box opens.

Use the Viewsheet dialog box to indicate which settings to save to the viewsheets. You can also access the
viewsheet settings on the Viewsheet page of System Configuration.

8. Click OK to exit the Viewsheet dialog box without making changes.
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Exercise 7: Using Materials
In this exercise, you use Mastercam's material options to make your parts look more realistic.

1. Open the GPS SUCTIONMOUNT.mcam file, which is included with this tutorial. If prompted to save
ANGLEBLOCK-MM.mcam choose Don't Save.

2. Press [F9] to hide the gnomon axes.

3. On the View tab, selectMaterial.

4. In the graphics window, click the base of the part to select it.
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5. On the Home tab, select the Set Material drop-down to display the material type gallery.

6. In theMetal group, select theMetal Level 4 from the gallery.
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The part's base changes to the selected material, a semi-reflective metal.

7. Select the face of the clamp, as shown below.

Mastercam 2025 •Mastercam Basics Tutorial

108



109

8. On the Home tab, select the Set Material drop-down and select Plastic Level 7.

9. Select the casing behind the clamp face, and choose Glass Level 3 from the Set Material drop-down.
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10. Rotate and zoom in on the part to view the different types of material.

11. On the View tab, toggleMaterial on and off to see how the material options affect the part.

12. Before moving to the next exercise, ensure thatMaterial is toggled off.

Exercise 8: Managing Section Views
In this exercise, you use Mastercam's section views to show cross sections of a part.

1. Load the file SPOOL BODY.mcam, which is included with this tutorial. If prompted to save
GPS SUCTION MOUNT.mcam choose Don't Save. If you see a message for switching units, click OK to allow the
change.

2. On the View tab, select Section View to toggle section views on.

Section views only show in the graphics window when the feature is on.
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3. Select the Planes tab to bring the Planes Manager to the front.

4. In the Top plane row, click the Section column. The X indicates that there is now a section view for the plane.

Mastercam displays a cross section of the part, using Top as the clipping plane, as shown below.
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5. On the View tab, click the Section View drop-down.

Use this menu to select what types of entities are affected when using section views.

6. From the Section View drop-down menu, select Show Caps. Mastercam adds solid caps to the sectioned
areas, as shown below.

You can also access Section View from the Planes Manager's toolbar.

7. Close Mastercam without saving your changes or leave the file open for the next exercise.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learn more about
levels.
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Chapter 6

Working With Levels
A Mastercam file can contain separate levels that include wireframe, solids, surfaces, drafting entities, and other
part data. Organizing your geometry by levels lets you control which areas of the part are visible and which entities
you can select in the graphics window. This control makes it easier to work with the file and helps prevent you from
affecting areas of the drawing you do not want to change.

You can create and name unlimited levels and set any one to be the active, current working level. For each level you
create, you assign a unique number and, optionally, a name. Mastercam’s Levels Manager provides a central
location where you can view and create levels, and set their properties.

Goals

l Explore the Levels Manager.

l Modify the Levels Manager display options.

l Turn level displays off and on.

l Change the active level.

l Create a new level.

l Move selected entities to a different level.

Exercise 1: Exploring the Levels Manager
In this exercise, you explore the Levels Manager and modify some display options.

1. Open LEVELS_PART.mcam, which was provided with the tutorial, and save it with a new name. If prompted to
save SPOOL BODY.mcam choose Don’t Save. If you see a message for switching units, click OK to allow the
change.



2. Click the Levels tab.

If the Levels tab is not displayed, select Levels on the View tab to toggle the display.
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The Levels Manager shows all levels that are in the current part file, their display status, and the number of
entities per level.

A. The check mark in the Number column indicates the current active level.

B. Settings for the active level display in this section.

C. Click any column heading to sort the levels grid. Click again to change the sort order.

D. Use these options to choose which levels are displayed in the grid.

3. Select Hide level properties to hide the property controls in the lower section of the Levels Manager and
maximize the space allotted to the levels grid.

4. Select Hide level properties again to show the controls at the bottom of the Levels Manager.
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5. Select Display options, Contrast rows to apply shading to every other row used in the grid.

6. Select Display options and deselect Contrast rows to remove shading from the levels grid.

In the next exercise, you learn to toggle the display of different levels.

Exercise 2: Showing or Hiding Levels
In this exercise, you change the graphics window display by hiding and showing the levels. To select or otherwise
work with an entity in the graphics window, the level it occupies must be visible.

1. In the Visible column for the 2: Solid level, click once to hide the level.

The part display in the graphics window updates accordingly.

2. Click again in the Visible column to display the solid.
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3. Try turning off the display of level 1: Wireframe.

When Active level is always visible is selected in Display options, you cannot hide the active level.

Turning off the display of the active level while you are working in that level is not recommended. However, it
may occasionally be necessary.

4. Select Display options, and deselect Active level is always visible.

5. Use Turn all levels off and Turn all levels on to toggle the display of all levels.

6. Select Active level is always visible again.

7. Make sure all levels are visible before continuing on to the next exercise.

Exercise 3: Changing the Active Level
Any geometry that you create is always placed on the active level. There can only be one active level at a time, but
you can change the active level as often as necessary to work with the part. In this exercise, you change the active
level using several methods.
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1. In the Levels Manager, click once in the Number column of level 2: Solid to set it as the active level.

NOTE:
The level field located on the Home tab also shows that level 2: Solid is the active level.

2. On the Home tab, select the Level drop-down and select 1 : Wireframe to make it the active level.

In the Levels Manager, a check mark appears in the Number column for level 1.

3. In the Levels Manager, turn off level 2's visibility.
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4. Position the cursor anywhere in the row for level 2: Solid, right-click and chooseMake active.

A check mark appears in the Number column for level 2.

Level 2: Solid is also visible because the Levels Manager display option Active level is always visible is
selected.

Exercise 4: Creating a Level and Assigning Entities
In this exercise, you create and name a level, and then assign entities to that level.

1. In the Levels Manager, select Add a new level.

Mastercam adds a new level to the Levels Manager grid and sets it as the active level.

Chapter 6: Working With Levels



2. Enter Tutorial for the Name.

The Levels Manager grid updates to show the new name. Although level names are optional, descriptive
names are helpful.

3. Make level 1: Wireframe the active level.

4. Use the Display options in the lower section of the Levels Manager to control the visibility of levels.

l Click Used and notice that level 3: Tutorial is no longer visible because there are no entities assigned
to it.

l Click Used or named to restore visibility of all levels.

5. Make level 3: Tutorial the active level.
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6. On theWireframe tab, select Point Position.

The Point Position function panel opens.

7. Click a few times in different places in the graphics window to create points.

8. Click OK in the Point Position function panel to exit the function.

9. In the Levels Manager, verify that the new geometry was created on level 3: Tutorial. The number of entities
is not 0.
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Your number of points may be different than what is shown.

10. Practice turning level displays on and off and changing the main level.

When you are ready, turn on the visibility for all levels and continue with the next exercise.

Exercise 5: Moving Entities to a Different Level
In this exercise, you create a new level by moving entities from one level to another. You can use the same basic
procedure to copy entities to a different level.

1. In the Levels Manager, enter 4 in the Number field, and then enter Labels for the Name.

The new level, 4: Labels becomes the active level.

2. Make level 1: Wireframe the active level.

3. On the Home tab, select Change Level.

Mastercam prompts you to select which entities to move.
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4. In the graphics window, choose the Select all advanced Quick Mask.

The Select All dialog box displays.

5. In the Select All dialog box, do the following:

a. Select the Entities checkbox.

b. Expand Drafting and select Labels.
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6. Click OK.

In the graphics window, Mastercam highlights all of the labels, indicating that they are selected.

7. Press [Enter] or choose End Selection.

The Change Levels dialog box opens.

NOTE:
You can also use general selection methods to preselect entities before choosing the Change Level
option. When you preselect entities, Mastercam does not prompt you to select additional entities
and you advance directly to the Change Levels dialog box.

8. In the Change Levels dialog box, do the following:

a. SelectMove.

b. Deselect Use Active Level to allow the entities to be moved to any level.
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c. Enter 4 for Number.

9. Press [Enter].

10. In the Levels Manager, verify that level 4: Labels now contains the four label entities that were on level 1.
Level 1: Wireframe contains four fewer entities.

11. Save your part.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learn more about
views and planes.
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Chapter 7

Understanding Views and Planes
Mastercam locates your work in three-dimensional space. This means that geometry and toolpath positions are
expressed in terms of three coordinate axes: X, Y, and Z. Each axis has a positive and negative direction.

In previous chapters, you learned about standard views and planes. In this chapter, you learn more about creating
your own planes and using them for geometry creation.

Goals

l Understand views and planes.

l Customize the Planes Manager.

l Adjust follow rules.

l Create a new plane using the dynamic gnomon.

l Create a new plane using the Planes Manager.

l Use a new plane for geometry creation.

Views and Planes
You use views and planes in Mastercam for many drawing and machining purposes.

A plane is any two-dimensional slice of a 3D coordinate system. Examples of planes include the XY plane in a 3D
coordinate system, or a face of your part, no matter its angle.

A view is a plane with an origin and orientation. For example, the Left side view and Right side view are both
aligned with the same plane; but a clockwise arc in one view is a counterclockwise arc in the other view.

Mastercam includes a number of predefined views that you explored in " Changing Standard Views" on page 89.
These include Top, Front, Right, Isometric, and others.

The work coordinate system (WCS) refers to the alignment of the coordinate system itself. You can choose to align
the coordinate system axes with any plane you wish. When this happens, you map the XY plane to the plane of the
view. The origin of the view becomes your new (0,0,0) point. The view becomes the Top plane in the new working
coordinate system.

This section introduces some ways planes are used and some ways to access them. You can use views and planes
for three main functions:

l Graphic views (Gviews)—A Gview determines the angle from which you are looking at the part in the
graphics window.

l Construction planes (Cplanes)—When you draw geometry, the Cplane is the plane in which the geometry is
created. This does not have to be the same as the Gview. For example, you can look at your part in Isometric
Gview, while drawing geometry in the Front Cplane.



l Tool planes (Tplanes)—This is the plane that is typically normal to the tool axis. Tplanes are only used when
creating toolpaths. Tool planes determine the tool orientation. In almost all cases, your Cplane will be the
same as your Tplane (the most common exceptions are mill/turn operations).

You use the Planes Manager to select, edit, create, and manage planes.

Exercise 1: Exploring the Planes Manager
In this exercise, you open the Planes Manager and experiment with display options.

1. Open BRACE.mcam, which was provided with the tutorial. Save the file with a new name.

2. Select the Planes tab to bring the Planes Manager to the front.

If the Planes tab is not displayed, select Planes on the View tab to toggle the display.

3. In the Planes Manager, select Show Gnomons.

The gnomon for the currently selected plane displays in the graphics window whether or not the Planes
Manager has focus. Additionally, if the Display column is selected for a particular plane, the gnomon will also
display.
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4. Click the Follow rules drop-down and select the options shown in the following image. With these settings,
when you change the Gview of a plane, the Cplane and Tplane follows.

5. Click in the G column of the Bottom plane to set the Gview to bottom. Note that Cplane and Tplane follow the
Gview as directed by the follow rules.

6. From the Follow rules drop-down, deselect Cplane follows Gview.
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7. Click in the G column of the Top plane to set the Gview to Top. Note that Cplane and Tplane no longer follow
the Gview, as directed by the new follow rules.

8. Click the Follow rules drop-down, and reselect Cplane follows Gview.

9. Click in the G column of the Iso plane to return the Gview to Isometric. Note that Cplane and Tplane remain
in the Top plane as the follow rule, Cplane = Top in Isometric Gview is selected.

10. Select Show Gnomons to toggle it off.

Exercise 2: Creating a New Plane Using the Dynamic Gnomon
In this exercise, you create a new plane using the dynamic gnomon. When creating a new plane using this method,
the gnomon is initially oriented to the current Gview.

1. On the View tab, select the Show Axes drop-down and selectWCS, Cplane and Tplane.

2. Toggle Show Axes on, if necessary.
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3. On the View tab, selectWindow.

4. Draw a box around the area of the part shown below and click to zoom into the window.

5. In the lower left corner of the graphics window, hover over the Dynamic Gnomon.
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6. Click and drag the gnomon so that it matches the orientation shown below. Click to set the position.

The New Plane function panel opens.

7. To change the orientation of the Dynamic Gnomon, hover over the blue arc until the dial appears.
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8. Click the blue arc and rotate the gnomon from within the dial until it is at 90 degrees. Click to set the location.
(Rotating within the compass snaps in angular increments.)

Or, you can enter 90 in the on-screen edit field, and press [Enter] twice.

9. In the New Plane function panel, enter DYNAMIC PLANE for the Name.

10. Click OK to close the New Plane function panel.

11. DYNAMIC PLANE appears in the Planes Manager. Click in the Cplane column of DYNAMIC PLANE.
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The Cplane and Tplane axes indicate the location of the new plane origin as shown below.

Exercise 3: Creating a New Plane Using Planes Manager
In this exercise, you use Planes Manager to create a new plane aligned with the slanted face of the part. You add it
to the list of system planes.

1. Press [F9] to turn off the axes.

2. Press [Alt + F1] to fit your part to the graphics window.

3. In the Planes Manager, select Create a new plane, From solid face.
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4. Select the slanted face of the part, shown below:

The Select plane dialog box opens.

5. In the Select plane dialog box, click the arrows to cycle through the possible planes. For most applications, it
make sense to have +Z pointing away from the part.

6. Cycle to the plane shown below.
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7. Click Save this plane and exit in the Select plane dialog box.

The New Plane function panel opens.

8. In the New Plane function panel, enter the following:

a. Enter FACE OF PART for Name.

b. Select Cplane for Set As.

9. Under the Origin group, click Reselect to return to the graphics window to choose a new point for the origin.
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10. Select the point at the lower-right corner of the face.

11. Click OK in the New Plane function panel to create a plane. Your new plane, FACE OF PART, displays in the
planes grid.

Exercise 4: Using a Custom Plane for Drawing Geometry
In this exercise, you create geometry using the new Cplane. You see that the new plane determines the orientation
of the geometry. You then set the Gview to the new plane.

1. In the Planes Manager, click in theWCS column for the FACE OF PART plane.
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2. On theWireframe tab, select Circle Center Point.

The Circle Center Point function panel opens.

3. On the Selection Bar, select Origin from the AutoCursor drop-down.

4. In the Circle Center Point function panel, enter 80.0 for Radius and then click OK.
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5. On the View tab, select Show Axes. If necessary, click the drop-down and ensure that all options are selected.

6. The axes that define each view display in a different color. Since Cplane and Tplane are the same, the axes
display as dotted lines. Experiment by turning individual sets of axes on and off.
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7. In the Planes Manager, click in the G column of the FACE OF PART plane to set the Gview.

You are now looking straight down into the face of the part. The Gview is aligned with the custom plane that
you just created.

8. Press [F9] to turn off the axes.

9. Save your part.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learn more about
working with chain selection.
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Chapter 8

Working With Chain Selection
Chaining is the process of selecting and linking pieces of geometry. Use chains to create a toolpath, surface, or
solid. Chains are a subset of selection. However, chains are directional. Cutting tools follow the direction of the
chain. The following image shows a clockwise wireframe chain. The tool will move in the direction of the green
arrow.

There are two modes for chaining: wireframe and solid. The mode determines the selection options that are
available to you. You typically use wireframe chains when you wish to create a toolpath without first creating the
associated solid. Use solid chains on solid models.

Goals

l Use Curve All Edges to create wireframe from a solid.

l Explore wireframe chaining.

l Create and modify solid chains.

NOTE:
This chapter requires a Mill machine. If your Mastercam license does not allow access to Mill, you can
either:

l Download Mastercam Learning Edition and use it to complete the exercise:
https://signup.mastercam.com/demo-hle.

l Read through the exercise.

Exercise 1: Creating Wireframe from a Solid
In this exercise, you use Curve All Edges to create wireframe for a solid.

1. Open the file SOLID CHAINS.mcam, which is included with this tutorial, and use Save As to save it with a new
name. If you see a message for switching units, click OK to allow the change.

https://signup.mastercam.com/demo-hle


2. In the Levels Manager, select Add a new level.

Level 2 appears and becomes the active level. Note that it has 0 entities. The solid body remained on level 1.

3. On theWireframe tab, select Curve All Edges.

The Curve On All Edges function panel opens.

4. Window select your entire part.

5. Click End Selection.

6. Click OK in the Curve On All Edges function panel.
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The solid body has a wireframe outline.

7. In the Levels Manager, hide level 1.

The solid body is no longer visible. The wireframe remains.
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8. Save your part.

Exercise 2: Exploring Wireframe Chaining
In this exercise, you explore wireframe chaining methods.

1. On theMachine tab, selectMill, Default.

This sets your machine type, which is the first step in creating a toolpath. You will create a complete toolpath
in the next chapter. For this chapter, you will follow the first steps of toolpath creation in order to practice
chaining.

2. On the Toolpaths contextual tab, select Contour from the 2D gallery. If you are not using a Mill, select any
toolpath available to your machine that brings up theWireframe Chaining dialog box.

Mastercam 2025 •Mastercam Basics Tutorial

144



145

TheWireframe Chaining dialog box opens.

3. Check thatWireframe and 3D are selected beneathMode. These options allow you to select wireframe
entities defined in the X,Y, and Z axes.

4. Be sure that Chain is selected under Selection Method.
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Selection methods make it easier to select the desired geometry. For example, when Chain is selected in 3D
mode, Mastercam pauses chaining at all branches and prompts you to select the next entity.

5. Click the line shown below.

A chain appears with three arrows:

l Green appears at the start of the chain and shows the direction of the cutting tool.

l Red shows the default chaining direction.

l Blue shows alternate chaining directions.

These arrows allow for guided chaining. Guided chaining uses the Next, Previous, and Adjust buttons to
control your chain.

NOTE:
You can customize your chain-related colors in the Colors page of the System Configuration dialog

box.
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6. Click the Next button twice to continue your chain around the base of the wireframe.

Each time you click Next, the chain continues in the default direction indicated by the red arrow.

7. In theWireframe Chaining dialog box, click Adjust.

Adjust changes your default chaining direction. The red arrow of your chain switches direction.

Chapter 8: Working With Chain Selection



8. Click Next. Your chain continues up the corner edge of the wireframe.

9. To undo the most recent addition to the chain, click Previous.

10. Click Reverse to switch the direction of your chain, as well as the start and end points.

NOTE:
When chaining to create a toolpath, clicking Reverse changes the start point of your toolpath and
direction of your cutting tool.
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11. Press [Esc] and click No to exit the toolpath function.

Exercise 3: Exploring Solid Chaining
In this exercise, you create and edit a solid chain.

1. On the Levels tab, make level 1 active and visible. Click in the Visible column of 2 to make the level not
visible.

2. On the Toolpaths contextual tab, select Contour from the 2D gallery. If you are not using a Mill, select any
toolpath available to your machine that brings up the Solid Chaining dialog box.
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The Solid Chaining dialog box opens. It shares many similarities with theWireframe Chaining dialog box.

The default selection modes for solid chaining are Loop and Face.

3. Deselect all modes except Face.
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4. Select the four faces in the following image.

The green arrow appears on the last chain created.

5. Click Display all selection arrows.

A green arrow appears to indicate the direction of each chain.

6. Select Reverse to reverse the direction of all selected chains.
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7. Click Unselect to get rid of the selected chains.

8. Change the selection method to Loop. Be sure to deselect Face.

9. Hold down [Ctrl] and click on the edge shown below.

[Ctrl + click] allows you to select matching holes or fillets on a part. All circles on the same face as the
original selection become chained.
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10. Click OK to accept the chains.

The 2D Toolpaths - Contour dialog box opens. This is where you program a toolpath. You can also edit
chains here.

11. Click Select chains under Chain geometry.

Chain Manager opens.
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12. Expand Solid Chain 1 and select the first Loop. Yellow arrows identify the loop on the part.

13. Right-click the first Loop and select Reverse.

Mastercam reverses the loop. The others maintain their original chaining direction. Your other option is to
double-click on the desired chain to reverse it.
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Use the right-click drop-down in Chain Manager when you want to analyze, edit, name, and make other
changes to your chains.

14. Click OK to accept the new chains.

You return to the 2D Toolpaths - Contour dialog box. After chaining, the next step in toolpath creation is to
set parameters. You will do this in the next chapter.

15. Click Cancel to exit the dialog box.

16. Select No to discard your toolpath.

17. Save your part.

You have now completed this chapter of the Mastercam Basics Tutorial. In the next chapter, you learn more about
the creating toolpaths.
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Chapter 9

Introduction to Toolpaths
As a CAD/CAM program, Mastercam creates both the geometry and toolpaths needed to machine your part and
achieve your project goals. Toolpaths are the routes along which the cutting tool is instructed to travel. To
effectively meet the needs of users, Mastercam is capable of creating toolpaths that range from simple to complex.

For example, the following image shows a 2D milling toolpath.

One of the most important features of Mastercam is associativity, which is the link between the part and the
toolpath. When the part changes shape or moves, the associated toolpaths adapt and change as well. If there is a
part design change, associativity ensures that the toolpaths just require recalculation, rather than being completely
reprogrammed.

To create toolpaths, input specific information such as the machine type, tool specifications, and size and shape of
your material. You also select a toolpath type and set the feeds and speeds at which your part will be machined.

Mastercam turns this information into G-code (sometimes known as NC-code) to be read by a CNC machine.
Depending on the type of machine and your part, this process may be entirely automated or may require occasional
assistance from the machine operator.

Goals

l Choose a machine and set up stock.

l Select a toolpath and geometry.

l Set parameters.



l Backplot and verify.

l Post the part file.

NOTE:
This chapter requires a Mill machine. If your Mastercam license does not allow access to Mill, you can
either:

l Download Mastercam Learning Edition and use it to complete the exercise:
https://signup.mastercam.com/demo-hle. Note that you will not be able to complete Exercise 5 with
Mastercam Learning Edition.

l Read through the exercise.

Exercise 1: Selecting a Machine and Setting Up Stock
In this exercise, you select a machine type and set up your stock.

Each machine type allows access to toolpaths specific to that machine. Selecting a machine is the first step in setting
up a toolpath. Once a machine is selected, you set up the stock material boundaries. When you set up stock, you
enter the dimensions and location of your initial material.

1. If necessary, open the part you created in "Working With Chain Selection" on page 141.

2. Go to the Toolpaths Manager.Machine Group-1 is present because you selected a Mill machine during the
chapter on selection. Machine groups organize your cutting operations by machine.

3. Expand Properties - Mill Default.

4. Click Stock setup.

Stock is the material from which your part will be cut.

TheMachine Group Setup function panel opens to the Stock Setup page.
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TheMachine Group Setup function panel (accessed from the Toolpaths Manager) manages machine groups
for Mill and Router machines. It features a top-down workflow, represented by the icons on the left side of
the panel. When creating a toolpath, use the pages in this panel to:

l Select machine files, tool and operations libraries, and operation defaults.

l Define the final part (the workpiece) after all machining is complete.

l Configure stock shape, origin, and wireframe.

l Define workholding components, such as fixtures or vices.
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l Set feed calculation, material type, and toolpath numbering.

l Set up simulation options without having to open Mastercam Simulator.

NOTE:
Since we are using the default Mill machine in this exercise, we do not need to set up our machine
files in the top (Machine) page.Master Model or workpiece setup, on the next page, is optional.

5. Click Add from a bounding box.

The Bounding Box function panel opens. A bounding box creates a boundary around selected entities in the
graphics window.

6. Select the All shown option to select the part.

NOTE:
To display the coordinate axes in the graphics window, press [F9] .

7. In the Size section of the Bounding Box function panel, change X to 12.1 and Y to 8.1.
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This adds a small amount of material to your stock in the X and Y directions. Although your stock values
would ultimately be defined based on the actual stock that you have available, for the purposes of this
exercise we only want to skim off a small amount of material.

8. Click OK in the Bounding Box function panel.

9. Click OK in theMachine Group Setup panel.

10. If necessary, toggle Stock Display and Stock Shading in the Toolpaths tab to see the stock in the graphics
window.

Exercise 2: Choosing a Toolpath and Geometry
In this exercise, you choose a toolpath and chain associated geometry.

1. In the Toolpaths tab, turn off Stock Shading.

2. On theMill Toolpaths contextual tab, select Contour from the 2D group.
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The Solid Chaining dialog box opens.

3. In the Solid Chaining dialog box, check that Solids and 3D are selected in theMode group. In the Selection
Method group, check that Loop and Face are selected. These options allow you to chain the desired
geometry.

4. Select the chain shown in the following image.

A green directional arrow appears. This arrow shows the direction the tool will follow. Typically, you want the
cutter to move in a clockwise direction so that it will be on the left side of the chain. This is not the case in the
following image.
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5. If necessary, select Reverse to reverse the direction of the arrow so that the part is to the right side of the
green arrow.

Your part is now to the right of the green arrow. Your cutter will be on the left side of the chain.

6. Click OK in the Solid Chaining dialog box.
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The 2D Toolpaths - Contour dialog box opens. This is where you program your toolpath.

Exercise 3: Programming a Toolpath
In this exercise, you program your toolpath by selecting a tool and setting parameters.
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1. Click the Tool page in the 2D Toolpaths - Contour dialog box.

2. Click Filter.

The Tool List Filter dialog box opens. Use this to filter your tools by type.

3. Select None to clear filters. Choose Endmill1 Flat from Tool Types.

4. Click OK.
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5. Click Select library tool.

The Tool Selection dialog box opens. All tools listed are endmills, which are what you set the filter for. Use
the row headers to sort tools by characteristics such as name, diameter, or flutes.

6. Select 1/2 Flat Endmill and click OK.

You return to the 2D Toolpaths - Contour dialog box.

7. Select the Depth Cuts page.
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8. Select Depth cuts.

Depth cuts divide the total depth into separate cuts.

9. ChangeMax rough step to 0.2. This is the maximum amount of material to remove with each rough cut.

10. Select the Linking Parameters page.

The Linking Parameters page defines how Mastercam calculates heights and depths. These can be
measured in absolute, incremental, or associative values.

11. Select the check box next to Clearance. Clearance sets the height at which the tool moves to and from the
part.

12. Enter 2.00 and select Absolute for Clearance.

13. Enter the following, as necessary, on the Linking Parameters page.
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l Retract: Enter 0.25 and select Incremental to set the height that the tool moves up before the next
tool pass. Incremental values are relative to other parameters of chained geometry.

l Feed plane: Enter 0.2 and select Incremental to set the height to which the tool rapids before
changing to the plunge rate to enter the part.

l Top of stock: The bounding box you created has populated the Top of stock value to set the height
of the material in the Z axis. Select Absolute to measure from the origin 0,0,0.

l Depth: Enter 0 and select Incremental to set the final machining depth and the lowest depth that the
tool descends into the stock.

NOTE:
You can explore the other pages, such as Holder, Lead In/Out, and Break Through. For this tutorial
those settings remain at default.

14. Click OK. The toolpath information appears in the Toolpaths Manager. Your 2D Contour toolpath appears in
the graphics window.
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NOTE:
To edit your toolpath, click on Parameters. The 2D Toolpaths - Contour dialog box will re-open.

Exercise 4: Backplotting and Verifying
In this exercise, you use Classic Backplot to backplot a toolpath and use Mastercam Simulator to verify the toolpath.
Classic Backplot allows you to see a quick simulation of your toolpaths. Verify allows you to see a more detailed view
of your operations, including simulated material removal.

1. In the Toolpaths Manager, check that your 2D Contour operation is selected.

2. Click Backplot selected operations.

The following appear in the graphics window:

l Backplot dialog box: Controls the backplot display and allows you to save geometry or settings.

l Play bar: Adjusts the speed of the simulation and allows you to pause, play, and set stops.

l Tool and holder: Simulate the selected tool and holder.

NOTE:
If you do not see the tool and holder, right-click in the graphics window and select Fit.
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3. Click the Play button or press [R].

The tool and holder follow the toolpath.

4. When the simulation has finished, change the simulation speed by adjusting the run speed slider.

5. Press [R] to view the adjusted simulation.

6. While the simulation is running, rotate your part. View the tool as it moves along the toolpath.

Click OK in the Backplot dialog box.

7. Reset your view to Isometric and Fit.

8. Select Verify selected operations.
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Mastercam Simulator opens. Your tool, tool holder, and stock are visible in the graphics window.

9. Click Play.

Mastercam Simulator shows the path of your tool and holder. The stock updates as the simulator removes
material from the part.

10. Reset the simulation by clicking Start.
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11. Click Play and observe the information in theMove Info pane. One of the benefits of Mastercam Simulator is
that it gives you more in-depth information about your operation.

12. Exit Mastercam Simulator.

Exercise 5: Post Processing
In this chapter you post process your part file.

Post processing, or posting, refers to the process by which Mastercam converts the toolpaths in your part file to a
format that can be understood by your machine tool's control (for example, G-codes). A program called a post
processor, or post, reads your part file and writes the appropriate NC code.

1. Click Select all operations.

2. Click Post selected operations to post the toolpaths for the selected operations. The post processor creates
a machine-readable NC program from the Mastercam file.
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The Post processing dialog box displays. The name of the post processor for the machine you have chosen
displays as the Active post field in read-only mode.

3. Click OK. The Save As dialog box opens.

4. Name your NC file and click Save.

The file opens in Mastercam Code Expert.
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The NC code specifies information such as stops, cutting coordinates, and tool changes. Block numbers
appear in front of each command. Code Expert allows you to sync operations, manually edit code, and switch
NC Configurations.

5. Exit Code Expert.

6. Save your part.
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Conclusion
Congratulations! You have completed the Mastercam Basics Tutorial! Now that you have mastered the skills in this
tutorial, explore Mastercam's other features and functions.

You may be interested in other tutorials that we offer. Mastercam tutorials are being constantly developed, and we
will add more as we complete them. Visit our website, or select Help, Tutorials from the File tab.

Mastercam Resources
Enhance your Mastercam 2025 experience by using the following resources:

l Mastercam Documentation—Mastercam installs a number of helpful documents for your version of software in
the Documentation folder of your Mastercam installation.

l Mastercam Help—Access Mastercam Help by selecting Help, Contents from Mastercam's File tab or by
pressing [Alt+H] on your keyboard.

l Mastercam Reseller—Your local Mastercam Reseller can help with most questions about Mastercam.

l Technical Support—Our Technical Support department (+1 860-875-5006 or support@mastercam.com) is open
Monday through Friday from 8:00 a.m. to 5:30 p.m. USA Eastern Standard Time.

l Mastercam Tutorials—We offer a series of tutorials to help registered users become familiar with basic
Mastercam features and functions. Visit our website, or select Help, Tutorials from Mastercam's File tab to
see the latest publications.

l Mastercam University—Mastercam University, an affordable online learning platform, gives you 24/7 access to
Mastercam training materials. Take advantage of our many videos to master skills at your own pace and help
prepare for Mastercam Certification. For more information on Mastercam University, please contact your
Authorized Mastercam Reseller, visit university.mastercam.com/, or email training@mastercam.com.

l Online Communities—You can find a wealth of information at www.mastercam.com.

l Follow us on Facebook (www.facebook.com/Mastercam), Twitter (twitter.com/Mastercam), and
Instagram (https://www.instagram.com/mastercam/) for the latest tech tips and Mastercam news.

l See Mastercam in action on YouTube (www.youtube.com/user/MastercamCadCam).

l For more information on Mastercam, to find and apply to jobs, and connect with people using
Mastercam, visit us on LinkedIn (www.linkedin.com/company/cnc-software/).

l Registered users can search for information or ask questions on the Mastercam Web forum,
forum.mastercam.com, or use the Mastercam Knowledgebase at kb.mastercam.com.

Contact Us
For questions about this or other Mastercam documentation, contact the Content Development Department by
email at techdocs@mastercam.com.

mailto:support@mastercam.com?subject=Technical Support
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Attention! Updates may be available.
Please refer to my.mastercam.com for the

latest downloads.
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